Question about Rockford Fosgate Punch P325.2 2-Channel Amp - 160W Punch Series 325W Bridged Mono Remote Punch Bas... Car Audio Amplifier

1 Answer

No power I swapped out my old amp which was working fine, for this RF one and I'm not getting any power on this one. I put it in my friend's car and it works fine. I put my friend's amp in my car and it works fine. Why doesn't the RF work in my car?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers
Re: no power

Hi, some car amps need a high current remote supply to turn on. first make sure that you are using the proper gauge b+ and gnd cable for this particular rockford amp. then try switching the remtote turn on to this amp thru a simple Relay.(use the remote supply from your headunit as a trigger for the relay). do these connections without connecting any spks or rca line inputs. once amp is switching on then connect all other cables. OR lastly check the main fuse on the RF amp?? cheers

Posted on Aug 05, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

Is a boss ce2800 amp a good amp it says its 2800 watt class d mono block

It's over rated on it's specs and they run real hot when working hard. Make sure to located in an area with good air flow and away from material that may melt.

Nov 15, 2013 | Car Amplifiers

1 Answer

I took my 1000 watt amp and kit out of my old truck and put it in in my new ride. It worked just fine at first then the subs started going out for hours even days but amp was still powered on then i hooked...

You may need to run a larger wire to the amp or upgrade your alternater to get enough voltage to the amp. double check all of you wire connections going to the battery and from the alternator also. Clean all terminals and maybe even beef up the wires from the alternator to your battery. Your smaller amp works due to it needing less current to work, your big amp can't even power up with the lack of available current.

Apr 01, 2013 | Car Amplifiers

1 Answer

My eclipse amp DA 7122 doesn't put out any power, no fuses are bad and led lights up. I must have a short some where?...any suggestions

check your rca cables and remote wire or wires and also check the wires to the speaker and in the box and if you have a friend that has a set up in there car swap amps to see if it works any different if it dont you may be able to get it fix at a car audio shop.

Dec 28, 2010 | Eclipse DA7122 Car Audio Amplifier

1 Answer

1996 mustang v6. the radio worked fine earlier

Stock headunnits are picky about the power they get, and when you are taking it to the headunit, it is putting unwanted strain on it. I can help more if I know where you put the fuse too.

Oct 10, 2009 | Car Amplifiers

1 Answer

Amp gets very hot in as little as 5-10 min.

Whats the omh load and how old is amp??? The old Rf amps always got hot that how they worked.... No ventilation???? 

Nov 05, 2008 | Rockford Fosgate Punch 700S Car Audio...

1 Answer

Hifonics Brutus BXi 1208d Amplifier

Possibly you need to return the amp and get a new one cause that could mean an internal problem and its deffective, you could try replacing the fuses or try changing the ground wire, this problem is very unusual

Sep 13, 2008 | Hifonics Car Amplifiers

1 Answer

When powered on protection light comes on

Protection usually means that there is a short some where. If it is inside the amp or external I couldn't tell you. You could check the fuse to make sure that isn't blown. I had a Memphis amp that blew both fuses and the protection light came on. I swapped out the fuses and worked fine, still works. If you have a multimeter set it to OHMs and check the resistance between the power terminals. It should be very high. If these things don't work then there is most likely something wrong with the amp or your power termination. I wasn't able to find a lot of information on this amp but if it has screw type terminals, did you use terminals. If you just put the wires in the terminals make sure there wasn't loose strands touching. I hope you can get this one.
-Andrew Hawkins

Mar 27, 2008 | Car Amplifiers

1 Answer

Rockford Fosgate 800.2 no power

This one is a real twister. Some questions of you might help to correct this problem.
1) Did you in some way hook the CB Radio up to the amplifier?
2) Did you use the same power lead from the amp to install the CB Radio?
3) In some way, did you unhook the ground from the amp?

These questions will help in solving your problem
I'll be waiting to hear from you
NC Electronic
Mills, Wyoming

Jan 29, 2008 | Rockford Fosgate 800.2 Car Audio Amplifier

1 Answer


Check your ground wire! Relocate it to another place in the car and try to get a heavier ground wire aswell.

Apr 03, 2007 | Sony XM-2200GTX Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Amplifiers Experts

Pablo Gonzalez

Level 3 Expert

733 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Robert Rankin

Level 2 Expert

338 Answers

Are you a Rockford Fosgate Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides