Question about Audio Players & Recorders

1 Answer

I have a technics stereo int amp su-v96. It has the electronic button style volume/balance controls. It is hooked to the factory speakers it came with. Here's what it does. It will work then it will not make sound on left channel and right channel will b really quiet. If u adj the volume or balance it will crackle and sometimes full sound will come back in. It does this even at very low volume settings. It does not go into protection or blow the fuse. It has the jumpers connecting The preamp to the main input, I ran it using only the main input and it wont cut out that way. so I do not think it's the amp but the volume control buttons or board. Visually the board looks. Are their other components in the unit that would cause this problem? If so which ones? Thank u for any help!

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Audio Player... Master
  • 5,017 Answers

Have you tried cleaning the controls were Servisol Video 40 or other switch cleaning fluid?

Posted on Jan 27, 2013

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 4234 Answers

SOURCE: Technics SU-G95 Amplifier and no sound on left speakers

Usually this is a defect in the output amp IC. If you have no experience with repairs of these types of units, have it checked by a service shop. If the output AMP IChas failed, it will cost about $75 for a replacement. This unit uses an RSN3306P IC .

Dan

Posted on Mar 15, 2010

Grubhead
  • 5017 Answers

SOURCE: Just set up my brand new cambridge audio azur 650a

Just make certain that the connections are all good with no wires touching. If it still doesn't perform after that return it to where you bought it and get a new replacement or your money back.

Posted on Feb 19, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Technics su-g75 amp goes to loud static after a few minutes


Hi Aawpharmd,

system control error.
please go for repair shop.
regards,
nuwan

Jan 13, 2014 | Technics SU-G75 Amplifier

1 Answer

How do I hook up a stereo reciver to the technics su-g91


I assume you want to use the SU-G91 as a power amplifier to drive your speakers. If your receiver has connections for inserting an equalizer (may be labeled pre-amp output and power amp input), remove the jumpers between the pre-amp and the power amp, then run cables from the pre-amp to the SU-G91 inputs. You can have an equalizer between the receiver and the integrated amplifier.
If this is not available, use the recording output (for a tape recorder on older receivers). Note that the volume control on the receiver will be bypassed with this connection.

Sep 23, 2012 | Audio Players & Recorders

1 Answer

What could cause intermittent no power to amplifier relay (RLY551) in Technics SU-V96?


Check the relay control transistors. Check the voltage at the collector and base of this transistor. Download the service manual to your device to get more details.

May 26, 2012 | Technics Audio Players & Recorders

2 Answers

I have a technics SU-v500m2 amplifier connected via the aux input to my pc, i wish to link another amp to the same input, is this possible, and if so how?


Let's establish which is the IN and which is the OUT here. The PC is a Line Level source so its OUTPUT would feed one of the amp's Line Level INPUTs.

What's the second amp going to do in your scenario? Something other than the normal stereo channels; something multichannel (if your PC supports it); or just more speakers supported for the PC to feed?

An RCA Y-connector pair would share the stereo output of the PC with multiple Line Level destinations.

If a second amp with its own volume control is intended to share the same two channels with the SU-V500 it could also be slaved off the back of the SU-V500 wih an RCA patch pair exiting the Tape 1 or 2 REC(OUT) jacks. The second amp would receive full-volume audio from whatever source the SU-V500 is playing. Just don't activate the selected Tape monitor on the SU-V500 or you will cut off the source to both amps.

Sep 24, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

Hello I have a Technics SU-V45A amp, it's about 18


See there is a problem with the volume conroller as it is 18 years old the controller has worn out replace the volume controller with a new one and you will be able to enjoy great sound again

Dec 05, 2010 | Technics SUV500 2-Channel Amplifier

1 Answer

Lost left stereo channel from amp. All speakers / wiring ok Technics SU-V6 amplifier. Wondering which component is most likely problem so I can cannibalise another amp.


If at full volume with the balance cutting out the right channel you can hear some music on the left (very weak), then the pre-amp is working and it's the power amp that's gone. Vice-versa if you can't anything, but say hum.
If it is the power amp check out the devices on the heat sink.
Check too for broken or burnt parts too!

Jan 21, 2010 | Audio Players & Recorders

2 Answers

About amplifier specification


sounds like you need a service or users manual...check their website,to find one

May 25, 2008 | Computers & Internet

3 Answers

Technics SU-V460 Amp Problems


Hi There, you need to eliminate all the connection and surplus items around the SUV-460 amplifier to determine if its the amp or not..

That is disconnect every thing then connect just the speakers and an input to the amp like a CD player or radio input. Then see if the amplifier plays OK thru the speakers on both channels and the balance control works fine....If it doesnt then the fault is inside the SUV-460 but if it all works fine than start reconnecting theemixer panel carefully and recheck all your cables and connections. Its a process of elimination to determine if its a "Box" fault or a cable fault...

Cheers From YUBEUT

Nov 14, 2007 | Technics SUV500 2-Channel Amplifier

3 Answers

Erratic volume on Technics SU-X911 amplifier (Class A)


its the ic that controls the + and - voltage and there are capacitors that have leaked all the caps on that board need changing could be expensive and time consuming but its the age of it . if i was going to do that job £200 plus\

Aug 24, 2007 | Technics SA-DX940

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

139 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5017 Answers

The Knight
The Knight

Level 3 Expert

73635 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...