Question about RCA 32V420T 32" TV

1 Answer

My tv has picture, but no sound (lots of hash sound)

My tv was on and playing just fine a couple of days ago when the sound went out suddenly and was replaced by loud static sounds.
The picture seems to be fine but there is nothing but static for the sound.

Posted by on

  • carl0121 Mar 29, 2009

    I have a Phillips 36 inch HDTV and recently for no reason on my sky digital input I get hissing static noise for sound , nothing wrong with picture at all.. just static.

    Changed the sky input to a EXT 2 same thing ...and it also does it when sky isnt even plugged into the channel so i know for a fact its the TV not sky.

    My xbox plays fine though on the YPBPR input... just seems to be the ext 1 + 2 inputs that are cabbaged !

    Strange one !

    if it doesnt change by tomorrow im pulling out the big guns ( 3 years extended warrenty ) although i wont need to cause the TV is about 6 months old :) haha ! Any suggestions would be nice though people, Thanks !!

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 74 Answers

Should replace capacitor ( c 1010 marked on board if it is a M134C chasie also (c 1013) both capastors are 10 mfd at 16 volts. Also check (Q603) rca part number 266897 could be bad.

Posted on Mar 01, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My rca f36450 has no picture or sound but does have power what can i do to fix it


There is nothing you can do to this set now. The only thing you can do, is to make a hard reset to this set. Just unplug it from AC mains socket, and replug it after a while. If this do not help you, just contact any experienced service technician.

Mar 20, 2012 | RCA Standard (CRT) Televisions

1 Answer

TV has no picture, but sound works fine


Are you using the AV input for the XBox or other cable? If you use AV, then use the same input that the Xbox does not show picture, plug in a DVD and see if it works. If it does not have a picture, so 100% your TV has problem.

Aug 11, 2009 | Sony Standard (CRT) Televisions

1 Answer

Screen black no sound or picture with line in center


this is a common problem,the vertical hold has been damaged.dont leave the teli. on,the white line will burn the middle of the screen and leave a black mark. You need a new integrated circuit(i.c.) for vertical hold.

Mar 17, 2009 | Standard (CRT) Televisions

1 Answer

Quasar TV sp 2724E Loses the picture


Sounds like a failed vertical amplifier circuit. This is normally primarily contained in an integrated circuit mounted on a heatsink.
There are other possibilities along the line but the one above is the most likely.
Now all you need is a TV repair shop that is still in buisness.

Jan 03, 2009 | Quasar SP-2725 27" TV

1 Answer

TV picture is not good


from what your describing it sounds like a resolution or ratio setting on your t.v. you can change these setting on your cable box and t.v as well this seems to be the setting on your t.v. since you have already unhooked the cable box. if changing the settings doesnt resolve your issue you may have some failed components on the pc board that could be repaired by a repairman v/s purchasing a new one. hope this was helpful....

Dec 16, 2008 | Sylvania 6427TE 27" TV

1 Answer

T V Shuts off by itself, after a couple of minutes.


Hi there,
here is some tips for ur TV which blinks 4 time.
1 Probable
Cause
Location


Solution • +13V is not supplied.
(A Board)
• IC503 voltage list is faulty.
(A Board)

Detected
Symptoms


• Has entered standby state
Solution after horizontal raster.
•Vertical deflection pulse is
stopped.
•Power line is shorted or power
supply is stopped.


this info must remady ur problem.

Dec 03, 2007 | Sony KV-36XBR400 36" TV

1 Answer

Delay to see the picture


Your power supply is going south, I have an old sony with the same problem. The voltage level drops and does not have enough 'kick' to start. It will work better when it is warm. The module will need to be replaced.

Nov 29, 2007 | Sony KV-27XBR45 27" TV

1 Answer

Tv not powering on


as per your statement there is a loose contact in power supply section of your tv. it is 1oo% sure that allthe parts are ok as tv runs ok when it comes on. but you will have to call tech. as without knowing technology it is dangerous to open tv due to high voltage.

Sep 15, 2007 | RCA HD52W58 52" TV

4 Answers

Strange audio problems


called a tve repair man tha is a buddy of minr hr had me unplug the tv to reset the ic ship and it worked !!! thanx and good luck

Jun 10, 2007 | RCA F27665 27" TV

Not finding what you are looking for?
RCA 32V420T 32" TV Logo

Related Topics:

407 people viewed this question

Ask a Question

Usually answered in minutes!

Top RCA Standard (CRT) Televisions Experts

The Knight
The Knight

Level 3 Expert

68427 Answers

John mullen

Level 2 Expert

245 Answers

gbob59

Level 3 Expert

2963 Answers

Are you a RCA Standard (CRT) Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...