Question about Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Open Question

Hoover Windtunnel model 6626 900 no suction - Hoover U6630-900 WindTunnel Bagless Upright Vacuum

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 13 Answers

SOURCE: plugged hose on Hoover Windtunnel

you will have to remove the bottom cowling under the vaccum cleaner there are 4 phillips head screws one at each corner when you turn over the vaccum cleaner, take this off and remember how it goes back on. in the area where the hos is there will probably be a clog at that point. remove this and pull hose off and make sure it is not clogged farther up the hose, reinstall and check

Posted on Dec 31, 2008

Ad
  • 2 Answers

SOURCE: auto brush on hoover windtunnel doesn't spin anymore

I have a Windtunnel S3765 with the same problem - and it has very little use so I'm confident it isn't wear. I find that the wheels do not raise the agitator brush sufficiently high to reduce the drag caused by excessive contact with the carpet. If I raise the front a bit the brush spins as it should. It also works if I take the housing apart and use it without ..... but this is tricky.

Unfortunately I haven't figured out a way to hold it up efficiently. I am toying with afixing something to the bottom of the housing to raise the front enough to give the brush a little more room.

Posted on Jul 09, 2009

nwj2468
  • 76 Answers

SOURCE: Hoover 6446 900 WindTunnel Bagged Upright has

check for a clog in the brush hose

Posted on Aug 22, 2009

  • 8 Answers

SOURCE: Hoover Windtunnel shuts off

I found the following solution on this website. I have searched for hours and finally found this solution, it works! I HAD the same problem after cleaning the filter mentioned below, it is now working like it was new.

***by maverick_bea***
yes this machine has a thermal protector in it to shut off the machine if it gets to hot, this is normal. if there is no clogs in the hoses or in the machine then you will need to wash the filter at the top of the machine. you will have to remove the dirt cup and at the top you should see a half moon orange, well inside of this piece is the washable filter, clean and let it dry completly before putting back into machine. if this gets dirty and has not been cleaned, you can lose alot of suction. in some cases if this filter is not cleaned it can cause the machine to overheat so bad that it can damage the motor.

Posted on Oct 25, 2009

kevin_getz
  • 1031 Answers

SOURCE: My Hoover Dual V Windtunnel has suction but the

Take the lower plate off of the unit and check the belt for breakage. also, if it isn't broken, are there any obstructions between the belt and housing?

Posted on Jan 29, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why would a Hoover Windtunnel have no suction?


It could be clogged at the head or throat, or you might have a hole in the hose. Unplug the hose; if you're getting suction where the hose plugs in then the problem is in the hose or the head. If you're not getting suction where the hose plugs in then the problem is in the body, probably the throat. If the problem is in the hose or head, detach the hose from the head and check for suction at the end of the hose. If there's not suction there, then you've got a clog or a hole. If there is suction there, then you've got a clog in then head.

May 20, 2014 | Vacuums

2 Answers

Vacuum not clogged but has low suction


Check all the pipes, there could be something stuck in them which hasn't come out.
Also check the base of the vacuum if there is something stuck in the base.
Lastly check if there are any leaks in the pipes.
Also check the suction without using the handle, by pulling the pipe in your hand and see if it has more suction.

Apr 28, 2014 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Suction not working on vaccuum.


Check for a blockage in the hose, or a tear / hole in the hose between the "pleats"

Jun 13, 2010 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Brush spin,good suction at hose, no suction at


Air passage from back of brush head, through the joint, and up to bag, may be blocked.

Jul 11, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover windtinnel suction problem


the intake hos at the bottom might be clogged.first take all the filters out and disconnect the hos completely from the vacuum,then check and see if you have suction.the intake hose is the clear looking one at the bottom that wrapps itself up from the base to the backside of the upright.you can use a coat hanger to push out the clog if there is one just bend the tip till its rounded.work it down into the intake hose from the back.after removing the hose and the filters you should have suction.just make sure all the filters get cleaned .you can blow out the hose with a garden hose

Apr 02, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

The Hoover Windtunnel vacum will not pull suction


Either the machine or hose is blocked OR the filters are blocked.
Also possible that the belt is broken.
Please leave feedback
Thanks

Feb 13, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover Windtunnel spits dirt back out the back


Your problem sounds to be an obstruction in the foot (lower body) of the windrummel. Most all windtunnel's have a second cavity for suction to go over the top of the roller. When you remove the bottom plate, next remobe the belt and roller, under the roller will be a removable cavity, take it out. remove the dirt and clean out any debris. also check the suction path connecting hose. if your belt has not been changed in the last 12 months, I would recommend changing that as well.

Jan 17, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

No suction


have u checked all of the filters. I know that when not all the filters r clean the machine will turn on but then it will sound louder and still have no suction. Most times there is a filter under dirt container thats sits above motor and if this filter is not clean the motor cannot breath. Thus no suction

Sep 29, 2008 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Hoover Windtunnel


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door manually throught the opening under the light.

Oct 15, 2006 | Hoover U6630-900 WindTunnel Bagless...

Not finding what you are looking for?
Hoover U6630-900 WindTunnel Bagless Upright Vacuum Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1461 Answers

Brad Brown

Level 3 Expert

15644 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...