Question about Jl Audio 300/4 Car Audio Amplifier

2 Answers

Green light blinks slowly on my JL Audio 300/4 amp

I just replaced the battery in my 2004 Avalanche and the receiver and subwoofer (bazooka) works, but the JL Audio 300/4 power amp is not working as the green light slowly blinks off and on. Help!

Posted by on

  • jlaufer4 Jan 28, 2009

    We found the problem to be the ground wire attached near the driver's side rear door. After reattaching with a new washer, everything worked. Thanks.

  • Jr20 Feb 03, 2009

    I have a Hollywood Amplifier 750w...and this green light keeps blinking on/off...i tested on my friend's car to check if it was a wrong connection on my car, but the same thing happened. Some one on the web told me it could be the solders inside the amp. is it true?

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers

I got autotech 1000 watt amp i had sony 1200 watt i had it hooked up the light stayed green and the autotech want say green it keeps blinking it wont stay solid

Posted on Jul 06, 2010

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 116 Answers

Check your fuse at the battery. While AGU glass fuses "look" good, when you read the voltage AFTER the fuse, you can only be getting 5 volts or so. I can't tell you how many times I have seen this.

Larry T
Winona Lake, IN
http://www.cybersoundsaudio.com/cybersounds/vehiclepics.html

Posted on Jan 28, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can you use a bazooka ba1150 to power up an infinity 1230w sub? not a techie just happened to have these two items and was wondering if i can use them together. thanks.


This is an 150 RMS amp, but the ratings say it'll push 2 10's.
You probably won't get much out of that amp with a 1230 watt subwoofer.
The subwoofer you are wanting to run is 300 RMS, so you'll get half the power you could be pulling. But it would do okay I guess. Nothing like what you could get with a different amp though. You need like a 1000 watt amp to get the most out of your sub. But "YES" you can use them together.

Aug 01, 2010 | Bazooka BA1150 150 Watt Monoblock...

1 Answer

My Jl Audio 500/1, power light comes on but no power to subs


maybe it dont have enough to push it ,,did you try it before you buy it?

Mar 01, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Got jl300/2 amp confused which subwoofer sounds good


Hello drsubhakar26,

JL W6's will perform well with from 150-600 watts RMS. W7's with from 150-500 watts. Less expensive Alpine Type R's work OK with from 200-500 watts RMS. Either of the brands will sound good. None of them will perform to their full potential with 300 watts RMS. Powering any sub with a 2-channel amp is a compromise. A monoblock is more efficient.

Hope this helps.

Jul 12, 2009 | Jl Audio Slash 300/2 Car Audio Amplifier

1 Answer

Jl audio 1000/1 low voltage -keeps shutting off at high volume


You should definitely upgrade the power wire to the sub amp to 4 gauge -absolutely your choking your amp its starving for current-poor thing is starving !!!!!!!

Apr 16, 2009 | Jl Audio 1000/1 Car Audio Amplifier

2 Answers

JL 300/2 v2 Power Light Blinks, No sound out of Sub. Works in friends Car HELP


Are you sure you don't have any shorted wiring or defective speakers?


Sep 30, 2008 | Jl Audio 300/2 Car Audio Amplifier

2 Answers

Have a jl 500.1 amp


for that amp u need a compasitor to mantain the amps the amp draws the amp is being choked when the car is off and when its running its killing the cars charging system

Jun 25, 2008 | Jl Audio E1200 Car Audio Amplifier

1 Answer

Wrong connection


You should have blown a fuse. Check the main power fuse feeding the system (usually at the battery). If it appears to be good, you'll need a multimeter to check the voltage at the B+ and remote terminals of the amplifiers. Place the black meter lead on the ground terminal of the amp when testing. .

Dec 16, 2007 | Jl Audio 300/4 Car Audio Amplifier

1 Answer

Jl audio E6450 cutting out


hi, have you figured out whats wrong with ur amp ...i have the same amp ....and as soon as i finished the connections ...and connect the remote on wire,,, the amp goes on ...making a ticking sound with the green light blinking and the red light staying solid on ...whats the problem please help ....how can i fix this ......my amp is a jl e6450 ....im using a panasonic cd player with a built in amp ....and thats the cd player im trying to connect to the jl amp ...please HELP

Nov 01, 2007 | Jl Audio E6450 Car Audio Amplifier

1 Answer

JL 1000/1 Amplifier


mine did that. i cleand the battery wires and hook ups now it works fine.

Jul 24, 2007 | Jl Audio JL1000 / 1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio 300/4 Car Audio Amplifier Logo

1,037 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Amplifiers Experts

matthew walsh

Level 1 Expert

69 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

Are you a Jl Audio Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...