Question about Olympus EVOLT E-500 Digital Camera

1 Answer

Help The hotshoot on my camera is loose. When the flash is attached, somtimes it doesn't make a connection to the camera. This problems stops the camera from flashing because the sensors are not connecting.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert who has answered 1,000 questions.

  • Master
  • 2,985 Answers
Re: Help

An extern flach should have a 'screw' down whell on its shoe to firm us the connection does this one not have it?

Posted on Aug 20, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

The pop up flash stopped working on my Nikon Coolpix L110 camera. Camera still works, but without the flash, the pictures are less than desirable. What can I do to correct this problem?

Check your settings first. If this still doesn't work then you'll have to take/send your camera to an authorized Nikon service center.

Photo Tech Repair Service
110 East 13th Street
New York, NY 10003

Jul 01, 2011 | Nikon Coolpix L110 Digital Camera

1 Answer

AV error whn pentax ist DL & Quantaray zoom lens attached

I've got the same problem. The problem is that the lense is loosely attached to the body. What you need to do is that when you see the Av flashing, press the lense of the camera to the body and twist the lense to the left a bit. This tightens the connection. You can then take the photo.

Feb 20, 2009 | Pentax *ist DL Digital Camera

2 Answers

Hot shoe

If the flash is not sitting securely on the hot shoe when attached to the camera you may want to send the camera body to Olympus repair center for service. Their telephone number is 800-622-6372 option 2 and then option 3 to discuss the repair process and pricing if needed.

Dec 29, 2008 | Olympus EVOLT E-500 Digital Camera

3 Answers

Internal Flash not working-Canon Eos 40D

I've had this happen to me too and I've been researching about it. Aparantly it happens because the camera still think the external flash is attached. If you go into the menu and under flash control, try ot enter the settings for built in flash. If this is the problem it will tell you here that the external flash is still attached. From what I have read to far, I'm not sure how to fix it. I would reccomend taking it in somehwere. I dont htink its a hard problem to fix.

Dec 06, 2008 | Canon EOS 40D Digital Camera

1 Answer

There appears to be a loose connection . The camera stops working

i have an olympus fe-100 even with a new battry when swith on the lens move out & back in , then two light green & orange flash 10 times & stop

Nov 17, 2008 | Olympus FE-100 Digital Camera

1 Answer

Flash off

Remove the camera case (about 10 screws) and expose the circuit board that is attached to the camera chassis. Look at top button board (shutter and video buttons). This is also the flash board. The capacitor is attached to the board. The flash board has a serial cable and two wires that connect to the main circuit board. Severing one of the wires will stop the flash from working. After re-assembling the camera, the camera will not take pictures with any of the flash settings. You will see a constant charging flash message every time the shutter button is pressed. Turn off the flash setting on the camera for your camera to operate.

Nov 08, 2008 | HP Photosmart M425 Digital Camera

3 Answers

Unwanted flash fire in nikonD200

Hi, I had the same sort of problem. It started with erratic small flashes but then evolved to the SB-800 not regonizing the D200 at all. The result of this is that I only get TTL and not TTL+BL+FP functionallity.
To solve this I cleaned the hotshoe on the D200 with all purpose cleaner for electical appliances (CRC 5-56). This gave minor improvment. Then I adjusted the spings to the left and right on the hotshoe on the D200 to press harder against the flash's connection (which I suppose is the grounding). Now everything works again.

Best regards,


Jun 21, 2008 | Nikon D200 Body Only Digital Camera

4 Answers

K100D flash doesn´t work

My camera with the dodgy flash is holidaying in Japan as they sent it to be fixed - not sure how old your camera is but I am trying to see if this is an issue that occurs with the camera model.... given that there are only two of us to date I am thinking that we may have just struck the jackpot :(

Dec 27, 2007 | Pentax K100D Digital Camera

Not finding what you are looking for?
Olympus EVOLT E-500 Digital Camera Logo

15 people viewed this question

Ask a Question

Usually answered in minutes!

Top Olympus Digital Cameras Experts


Level 3 Expert

94039 Answers

Steven Wander
Steven Wander

Level 3 Expert

574 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you an Olympus Digital Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides