Question about Pioneer GM-X962 Car Audio Amplifier

2 Answers

Alpine subs not hitting hard

Ok so I had this system that's nothing but Alpine. I got 2 12 inch SWR-1242D Type R subs, 850 watt amp, and a iva-w100 cd player. Well I wanted a different cd playerso I bought the iva-w205. So i installed the cd player and when I got installed competely and turned everything on my subs hasn't hit as hard as I thought they would. I didn't buy anything but a new cd player. I'm just wondering what the problem could be. I need some help please.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

You might be able to set your sub levle or your pre amp outputs on the cd player

Posted on Dec 17, 2009

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 21 Answers

Could it be as simple as bass boost??? maybe you have the subs hooked up wrong... have to have the ohms right.....hopefully this helped

Posted on Jan 27, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Bridging two12" subs and one 15" sub to my Rockford fosgate T 1500bd amp


assuming all 3 subs are 3-4 ohms, running all 3 in parallel (the 3 positive leads all attach to the amp positive terminal, and all 3 speaker negative leads connect to the amp negative terminal) will bring you at or above 1 ohm, which the amp is capable of handling. With 1500 watts, you will want to use 8 gague power leads for the amp, 12 gague speaker cables, and an inline 120 amp fuse between the amp and the battery, within 1 foot of the battery.

Jan 11, 2017 | Rockford Fosgate Car Audio & Video

2 Answers

I have a Sony STR-KM7 AMP and the subwoofers have stopped working?


Sorry but it sounds like the subwoofer voice coil has shorted, you will need to replace the sub.

Jan 08, 2017 | Sony Car Audio & Video

1 Answer

So how do wire this set set up to a bridged amp any help would be appreciated


assuming that is a dvc dual 4 ohm speaker, and you have a 2 ohm bridged amp, you run a positive from each side of the speaker into the bridged positive of the power amp, and run a negative from each side of the speaker into the negative bridged terminal of the amp. if, indeed, you have 2 4 ohm voice coils, running them bridged in parallel wiring will bring the load to 2 ohms. if you have 4 voice coils, of 4 ohms apiece, you could run all 4 parallel into the amp, but that would bring the load down to 1 ohm, and you would have to make sure you8r amp can support 1 ohm operation.

Jan 07, 2017 | Car Audio & Video

1 Answer

Try change my car radio cd .after connecting electric power and audio cable the new radio panasonic start 1 minute and stop loss power i reconnecting the old car radio ask me for cood the car is


You need to enter the radio code.....this should be with the service book or handbook, or contact the main dealer who will have a record of the code!

Jan 26, 2015 | Car Audio & Video

1 Answer

My 2002 mazda mvp ausio system is not working but I can insert and eject the CD but cannot do the in tape cassette also the display is not showing the clock or any thing plz any one tell me whats wrong...


Internal board damage. Also the ribbon cable for the soft load on the cassette is not engaging. This can happen due to just ware from the age of the unit. Cold solder joints are usually the culprit, that is why the display will not light. Check yards for a newer used deck it just might be easier unless you have a shop you can send it to.

Nov 10, 2014 | Car Audio & Video

1 Answer

My ripspeed incar dvd player has got no picture but has got the sound what can i do to make this work


First thing comes to mind is a possible update to the system. Have you had it for a while now? If so, you should go to the computer and go the maker of the unit. Check under software updates or downloads to see if there has been a remedy or fix that the maker has published, if so...then do as it says to do and see if this resolves the problem before you get into the actual technicals of the unit. It may need nothing more. I hope this helps.

May 18, 2014 | Car Audio & Video

2 Answers

How to on bluetooth


KD-R200 does not have the ability to add Bluetooth to it

Apr 03, 2014 | JVC KD-R200 Car CD/ MP3 Player

2 Answers

No power to amp


check and try finding another grounding spot

May 16, 2010 | Lightning Audio B4.250.2 Car Amp

Not finding what you are looking for?
Pioneer GM-X962 Car Audio Amplifier Logo

Related Topics:

143 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pioneer Car Audio & Video Experts

Michael Kovalik III
Michael Kovalik III

Level 2 Expert

117 Answers

The Knight
The Knight

Level 3 Expert

71736 Answers

yadayada
yadayada

Level 3 Expert

68032 Answers

Are you a Pioneer Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...