Question about Vacuums

1 Answer

My central kenmore vacuum wont suction

The large cannister was full and the vacuum lacked suction so i emptied the cannister but it still wont suction properly? i have tried to clean the cloth filter on the bottom of the large canister in the basement and i have checked all the outlets and they all have good suction. it could be that the hose itself is blocked. i dont have soemthing long enough to snake it through and see if it is unblocked. this prob started though when the cannister became too full and we emptied it but after that the suction sucked. thanks

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 706 Answers

Hello hdd85,
I think you answered your own question when you verified that all the vacuum outlets have vacuum on them and then after you hook up tyhe vac hose, you fail to get vacuum at the other end. I would say that based on your problem description, you have an obstruction in the hose. You may have afriend with an air compressor that you can try forcing air in one end to free up the clog but if that doesn't work, do you know anyone with a wet/dry utility vac that you can try using the vacuum or exaust side to free the hose up ? Lastly, if you know an electrician, they normally have 'snakes' used to fish wires thru wall cavities... If careful, that might get the clog out.. Hope that gives you soem ideas on how to resolve,,,,
Regards,
Rick

Posted on Jan 26, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I fix the suction on my Dyson vacuum?


check the pipe is saying that is clogged with something who knows lots clock that pipe make sure all pipes from your vacuum is is unstuck are clogged.

Nov 29, 2014 | Dyson DC65 Animal Complete Bagless Upright...

1 Answer

My home has a central vacuum system hook-up but no vacuum installed. My friend upgraded his central system and gave me his Eureka Mega Boss central vacuum system and the accessories, including the pow


The power head requires 120 Volts. Some hoses have a receptacle in the handle for the power head plug, and the hose has a cord at the wall inlet end that plugs into a receptacle. Some hoses have a plug at the wall inlet end that plugs into a 120Volt receptacle built into the inlet. The hose plugs into this receptacle when you push the hose into the inlet. The power for this built-in receptacle is wired with line voltage when the system is installed.

Apr 15, 2012 | Eureka 1810 Central System Vacuum

1 Answer

Hoover dm6200 blowing air


check your suction hose again, follow it to where it goes into the body of the machine. I assume this will be near where the bagless cannister is. Remove the bagless cannister and look up inside to where the attachment hose should come into the cannister. I believe you are still blocked up there. using a butter knife or something along those lines should free up the blockage.
Also, if that is all clear, try re-adjusting the dirt cannister as it may not be on properly to create your suction flow through the hose.
Good luck and let me know if I can help further.

Jan 24, 2012 | Hoover Vacuums

1 Answer

Suction has diminished since I purchased it a year ago. Hose is not blocked, Cannister is empty, and plastic filter above cannister is clean. What could be the problem?


Three possibilities I can think of:
1. Leak/holes in the hose.
2. The fan blade are worn down or broken. The more they're worn down, the less suction.
3. The motor itself is dirty and/or wearing out.

Any one of those problem would call for a replacement of the part involved, or the vacuum itself. It could also be a combination of any of them.

Dec 14, 2010 | Bissell Versus Bare Floor Vacuum

1 Answer

Pops open when bag still almost empty


try cleaning the filters if they are blocked then suction is lost and would appear like bag was full. hope this helps

May 20, 2009 | Vacuums

1 Answer

No suction


If the motor is running and is not full of dirt, and the hose is not plugged, the canister must be cracked or open somehow.

May 08, 2009 | Kenmore 22812 Bagged Canister Vacuum

1 Answer

Auto-matic suction shut-off didn't resume once tank was emptied


look on the bottom of the tank and there should be a fitting on there take it off and clean..there should be some hind of float inside the tank.turn it right side up and tap on the tank the float might be stuck

Apr 07, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

Central Vaccum - Kenmore Model No 34330


Is there suction where the pipe hooks to the cannister? If so, then are all of the outlets without suction? Maybe the hose is plugged. If the hose is ok, and there is suction at the cannister, then **** up a small **** of paper, one for each room outlet, have a number on each piece of paper, Which ever one doesn't ,ake it thru to the cannasiter is the outlet that is plugged. You can use a plumbers snake to clean out a clogged outlet or even a clogged hose.

If the motors are running and sound ok, then there has to be suction at the outlet on the cannister. If the filter bag is old, it may be best to replace it with a new one.

Jul 19, 2008 | Vacuums

1 Answer

CENTRAL VACUUM SYSTEM


Disconnect the inlet piping from the unit and check the suction there. Be sure that the utility inlet on the unit is closed. If you have good suction, you have an open/broken pipe somewhere, or possible an inlet valve or vacpan that is not sealing when closed. The easiest way to find it would be to install your tubing back into the inlet of the unit, turn the unit on, and walk around the house listening for air leaks. Good Luck!!

Jun 29, 2008 | Broan-NuTone CV353 Central Vacuum

1 Answer

Kenmore Bagless Issue


after cleaning the filter,replace the bag.But this time before you close the lid,make sure you remove the hose.after the lid is closed then put the hose back on.

leaving the hose connected to the lid after closing will create a gap between the bag holder and the bag.so just remove the hose first before changing the bag

Jun 16, 2007 | Kenmore 23313 Whispertone Bagged Canister...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

281 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18333 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...