Question about Fasco Heating & Cooling

1 Answer

I posted a question about the Ultra sx 90 (Armstrong) furnace not lighting and the combustion blower keeps running. I did clean the flame sensor and no change. I also changed the spark control moduleas well and it still does not lite. I checked power at the control module and is 24V. When it calls for heat, there is power coming up to the control module and the PV terminal only. There is no power on the PV/MV terminal at all. I am sure that power is required there for it to let the gas out. I can flip the the pilot valve switch back and forth carefully on the gas regulator valve a few times and I can get the furnace to lite. There is spark, but no gas it seems is coming out. Is the control module faulty? It was the S8610U3009 model. It says not to use the 24V terminal on the box if you do have a damper on the furnace. The wire gets switched to the TH-W terminal and nothing on the 24V terminal. All other wires go as labeled. High pressure switch and rollout switch are all functioning. Power is going thru when it calls for heat and none when it doesn't call for heat. Any suggestions?

Posted by on

  • Dennis Jan 19, 2013

    Can I just bypass this for now? Just jumper the two wires across to see if it will ignite on its own.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Fasco Master
  • 33,357 Answers

When this problem has occurred on my York furnace, the temperature limit switch had to be replaced. You may have checked this in your troubleshooting but if not, it's worth a try

Posted on Jan 19, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Armstrong ultra 93


The blower motor may have to be replaced.

Jul 15, 2014 | Heating & Cooling

1 Answer

I have an Armstrong SX Ultra 90 propane gas furnace that the fan motor will not shut off ,the thermostat is on auto.


Hit the side of the furnace. Some times there's a sensor inside that gets locked up from a dirty filter.

Oct 19, 2013 | Emerson Lennox Ducane Armstrong Furnace...

1 Answer

Turn main furnace switch on, combustion air fan comes on and main circulation fan comes on. About 40 seconds later the igniter lites, two burners closest to the igniter fire up and immediatly snuff out....


Hello, if all the burners are not firing up then they must be cleaned out, usually dirt gets in the crossover parts of the burner and the gas cant flow to all the burners and therefore the flame sensor will turn off the furnace for safety. Clean the burners out this should fix the problem.

Feb 25, 2011 | Heating & Cooling

1 Answer

I have an americanaire ultra sx 80 furnace that if it does start up the 1st time, the induction motor continue to run and it will not start


On a call for heat, the 24 volt thermostat sends a signal to the control module. The control module will indicate a call for heat with a light on the control either blinking or remain solid depending upon model. The inducer (exhaust) blower will purge all gasses from the furnace and pressurize a pressure switch. Once the pressure switch tells the module to continue, the electronic ignition will energize and send 120 volts to the igniter. The igniter will glow and you will be able to see it if viewed thru the small inspection port. Once the igniter gets hot enough, it sends a signal to the module opening up the gas valve (24 volts). Either a pilot will come on or the burner tube will ignite then spread the flame to all burners. Lastly a safety sensor will be looking for a certain temperature within a few seconds and the furnace will continue to operate and the room air blower will turn on in a minute or two.

What could go wrong? The unit will not run if there is no signal from the thermostat (bad thermostat or broken wire), the control module does not sense a signal from the thermostat (bad control), the inducer does not energize (bad motor), the pressure switch does not close (blocked vent piping, bad switch, plugged condensate hose), the igniter does not energize (bad control, bad igniter), the gas valve does not open or there is no gas (bad gas valve, broken wire, no gas), the pilot does not light (dirty pilot), the burner does not light (bad burner, plugged orifice, not enough combustion air), the flame does not spread to each burner (bad flame spreader, dirty flame spreader, more bad burners), the flame safety sensor does not detect flame (dirty or bad flame spreader, bad flame sensor, broken wire, bad control), or the room air blower does not energize (bad fan motor, bad control).

Jan 04, 2010 | Heating & Cooling

1 Answer

Armstrong ultra sx 80 furnace starts up and runs and then the gas shuts off for a few seconds and then lights backup and causes a small backfire my Ultra sx 80 furnace will ignite then immediately turn...


You have a dirty flame sensor. Look at the very last burner and you will see a wire going to a ceramic sensor and it looks like a thick wire. Take some steel wool or fine sandpaper and clean the surface off and it will work like a champ.

Let me know how it goes ken

Apr 15, 2009 | Heating & Cooling

1 Answer

Furnace blower motor turns on with no flame burning


Hi!!! You might have a bad flame sensor its a single rod located in the burners its white..If the unit runs and then shuts off and on and off.change your flame sensor..Good luckk..

Jan 04, 2009 | Honeywell Power Humidifier: Furnace...

2 Answers

Armstrong ultra sx 80 furnace starts up and runs and then the gas shuts off for a few seconds and then lights backup and causes a small backfire


Flame sensor could be dirty. It is located right beside the last burner looks like a thick piece of wire. Take steel wool and gently clean the probe 4 or 5 strokes is all it will take to take off the carbon build up off. Lets eliminate this item and see if it clears up okay. ken

Dec 21, 2008 | Heating & Cooling

Not finding what you are looking for?
Heating & Cooling Logo

Related Topics:

327 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fasco Heating & Cooling Experts

paulcarew

Level 3 Expert

2458 Answers

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Donni Steen

Level 3 Expert

659 Answers

Are you a Fasco Heating and Cooling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...