Question about Connex 3300 240-Channels Base CB Radio

1 Answer

Cb radio when i key up i get talkback and my light goes from green to red but my transmit is very poor and weak and the needle doesnt move. it is very cold now where im at and could that be a problem.when i change to high band it works great either or. having trouble on lo band. does the radio need to be warm before it works good. i let it stay on for hour or so and truck running with heat on and when i come back it works great,needle moves and transmits great. any suggestions??

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 170 Answers

Not having the radio in front of me,I would check the following things.

1: Loose wire on the antenna connector inside the radio. (cols solder joint)

2.Turn radio upside down with covers off, look for bad connections on the legs of the buffer, driver, or final. Also check the voltage regulator. It should be mounted on the side of the chassis on the same side the mike connector is. If you don;t see any loose connections I would suspect a bad final, or a bad connection in the antenna sysem.

When you say high band wiorks great, I would lean more on the antenna system. Some antennas do not Broadband well. A good going over on the system from coax to antenna is a good idea. Check for ground, corrision, swr. etc.
The thing that gets me going is when things get warm it works better. Well when things get warm, they expand and possibly a bad connection can fix itself.
The connex radio is a good radio, but a big truck can play hell with the circuit board.

Posted on Jan 31, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Receives fine, needle does not move on transmit, transmit light lights


Needle on the meter might have went out . Is it stuck in one spot? If it moves during receive and goes to zero when keyed it most likely the final.

Mar 08, 2015 | Radio Communications

Tip

Galaxy DX 959 CB radio no transmit or talkback


Hi, I have a problem with this CB radio. The PA works good but after installing the MOSFET kit as mentioned here http://cgi.ebay.com/DUAL-POWER-TRANSISTOR-MOD-KIT-GALAXY-949-959_W0QQitemZ190256621565QQcmdZViewItem?hash=item190256621565&_trkparms=72%3A1205%7C39%3A1%7C66%3A2%7C65%3A12%7C240%3A1318&_trksid=p3286.c0.m14 it wont transmit and I cant hear myself on talkback nor do I hear the roger beep. The PA amp works though.

on Oct 15, 2008 | Galaxy Radios DX-959 40-Channels Base CB...

1 Answer

Does the green light turn red when I key the mike


Yes ,it must turn red when transmit.
you have to press the PTT and hold buttom to calibrate the SWR meter for readind.with the switch to calibrate(cal)

Nov 23, 2013 | Cobra 25 LTD 40-Channel CB Radio

1 Answer

DX 2517 keys up, light turns red, audio shows on meter, and through talkback, but no signal at all. whats goin on?


You need an SWR-PWR meter ($20) to run between radio and antenna to see 1) if you are transmitting and 2) if the is a problem with the antenna (SWR). There may be a bad antenna connection or it is grounded out. If the SWR and antenna check out you may have damaged your finals in the radio.

Feb 25, 2011 | Radio Communications

1 Answer

Cobra 29 chrome


you could have a bad soilder but probably your voltage regulator went out.

Dec 15, 2009 | Cobra 29 LTD CB Radio

1 Answer

When i key my mic. it goes from grean to red. how do i fix it


thats what its supposed to do..green for receive..red for transmit

Aug 04, 2009 | Cobra 29 LTD CB Radio

1 Answer

Cobra 29LTD CHROME low tx no mod, rx good low Vol, talkback good


1 why would you change the finals?? Have you checked you antenna? How are your SWR's? Crappy antenna's cause a lot of problems.

Use an external meter to see what the SWR is, and see what the output is PEP. If its low, then there is something wrong. If it is High, change the mic and turn up the dynamic all the way.

Next. Have you been messing around in there?? Tryin to get more wattage? You turned VR4? If you thought you were turning it up by turning it all the way to the right, you turned it all the way down. Turn it all the way to the left.

Jun 05, 2009 | Cobra 29 LTD CB Radio

1 Answer

Keys up and everything dims and does not transmit.


Moving the volume/on/off knob to make the radio work again is interesting and a good clue. On most CB's, the pot is probably soldered directly to the printed ciruit board.

It's possible that there is a bad solder joint to the power connections on the pot that turn the radio on & off. If the solder joint is bad, it can still make a connection but the connection will have added resistance in line. The on/off switch can be bad too.
Switches arc each time they are used and over time, the contacts become pitted and make poor connection.

I had a stereo receiver where the tuner lights flickered and there was electrical noise in the receiver. It turned out to be a bad on/off switch.

This resistance may be low enough not to affect the radio when in the receive mode but when you transmit and draw more current that resistance will be noticable during transmit.

The fact that you rotate or move the volume/on/off knob and the radio starts working again, tells me that there may be a bad connection in the radio.

A cheap thing you can try is spraying some electrical contact cleaner into the pot and rotate the pot back & forth several times and turn the switch on & off several times to clean it.

Please let me know if I can be of further assistance to you.

Good luck!

- Jim

Feb 08, 2008 | Cobra 148 GTL 120-Channels Base CB Radio

Not finding what you are looking for?
Connex 3300 240-Channels Base CB Radio Logo

136 people viewed this question

Ask a Question

Usually answered in minutes!

Top Connex Radio Communications Experts

AnyMHz.com
AnyMHz.com

Level 2 Expert

500 Answers

Iron
Iron

Level 3 Expert

3018 Answers

Steve

Level 3 Expert

3287 Answers

Are you a Connex Radio Communication Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...