Question about Celestion S10 Subwoofer

1 Answer

Clestion S10 Sub not working

Hi,
I have had the S10 sub as part of a Clestion 5.1 speaker package for a few years now connected up to a Denon 2805 AV receiver.About a month ago the sub just stopped working, no sound coming out of it, although the auto/manual light was still on. I checked the connection between sub and receiver - all seemed OK. I did a "tone test" through the 2805's remote button, centre, front and rear speakers all emitted a tone signal, but the sub was still quiet. After speaking to the Kef/ Celestion people in Maidstone I ordered a new amp for the sub ay just over a £100 and have just fitted it . There is still no sound coming out of it. Please help!

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 17 Answers

Instead of connecting it to the sub output, try it on the L or R output of your amp.
This will eliminate the Denon.
If this fails, you need to test the loudspeaker driver unit whilst disconnected from the sub amp. Use a 1.5v cell (AA or bigger) connect using croc leads to the speaker's terminals. If the speaker is OK, you should hear a click. If you hear nothing, the speaker unit is faulty.

Posted on May 19, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi, I have a denon AVR 889 about 4 years old and the subwoofer suddenly stopped working,how can i check if its the amp or the sub thats the problem?


A Denon AVR 889 is not a sub so we don't know anything about the sub in question.

Maybe the existence of the sub is no longer set in the AVR. Look at the speaker definitions first before going to wild.

Try another cable to the sub.

OR, run the sub's signal supply cable to one of the Tape Outs on the receiver and tune in something on FM. If that works a) it will be loud, and b) go back to the SUB settings on the AVR.

Crack the sub open and access the terminals on the speaker itself. Disconnect them from internal components and run one of your amp channels directly to it. If it works, the amp or signal path are dead. If it doesn't work, it's a dead driver.

May 19, 2011 | Denon AVR-889 Receiver

1 Answer

My sub ksw10 do not work with avr589.sub is fine.av receiver works on all 5 channels.with the remote i am unable to adjust all the parameters.


http://usa.denon.com/DocumentMaster/US/AVR-589-OM-E_105A.pdf you'll need to access the receivers speaker Set-up menu. you can download the user manual here. my opinion is that your speaker setup in the menu is not correct. make sure that you have Subwoofer yes selected in the menu, also if you selected ( Large ) as your left and right Main speakers it will not allow you to select Subwoofer ( yes/no ). you must select ( Small ) and then select Subwoofer Yes. also you can connect all speakers and perform Auto setup and it will recognize the sub when a test tone is emitted.

Apr 20, 2011 | Audio Players & Recorders

1 Answer

I've had my Denon AVR-2308CI receiver for 3 years and last week I turned it on to watch a movie and there is no sound coming from my rear speakers? I have a 5 speaker set up (3 in front and 2 in the rear)...


On the front display of the unit, you should have indicator icons that light up if a speaker is being used. Are there only 3 speakers lite up, or are there 5? As a quick check, make sure your speaker connections are secure, and then make sure your surround mode is set to a 5 channel surround mode. 5 channel Stereo is a good one to test with. Also, you can hit the "test" button to see if the speakers are connected and working, it will give a test signal out of each speaker independently. Let me know what you find, and I can answer more.

Mar 05, 2011 | Denon AVR-2805 Receiver

1 Answer

Hi we tried this system is new with denon stereo reviver. And with ioneer AV SYSTEM. Both with ower to sare but the cubes beat the sub by far, Cant get the sub to sound harder or sound like in store....


Some careful typing and model numbers might illuminate the question a bit.

Have you adjusted the speaker levels according to the manual?

Also, bass is heavily dependent on nearby surfaces. Experiment with placement of the sub. Find a spot near a corner.

Feb 06, 2011 | Bose Acoustimass 5 III System

1 Answer

When setting up my receiver the subwoofer is not putting out sound. It is connected and on.


hi,
first of all check ur sub woofer is it working or not. for that pull out its RCA connection from the receiver. power on the sub woofer and touch RCA's middle pin with ur finger. if its working it will produce a hum. if ok, go for the next,

do the following setup in ur av receiver
press menu and select manual setup and press enter
in manual setup select speaker setup and press enter
in the speaker setup select sub woofer and turn it on .
ok

Dec 23, 2010 | Denon AVR-2308CI

1 Answer

No sub audio denon-1506 receiver


You have to let the Denon know it has a sub or it won't send anything to it.

I can't find the manual but I'm sure you could dig through yours and find the area concerning speaker set up.

Mar 08, 2010 | Audio Players & Recorders

1 Answer

Hi all i have a Denon DRA 455 with Eltax Linear 6.5 wich is 8ohms i have a sub but no sub output, apart from sharing power between them, how can i hook these up please? thanks


You did not state if your sub is a powered sub or not, but if you use the "B" channel for your sub, it should work. This is possible if the denon will work with "A" channel and 'B" channel on together. The back of the Denon should have two sets of speaker outputs. Connect the "B" channel speaker outputs to the sub. The "A" channel will still drive your 6.5's.

Aug 05, 2009 | Audio Players & Recorders

1 Answer

Hooking up the sub


To connect the passive sub you have to connect the provided wires to the receiver then to the sub's inputs and from the sub's outputss to the cube speakers. It seems complicated but you'll see that is very easy if you lokk at the sub's connection panel.
Hope that i helped...

Jan 15, 2009 | Bose Acoustimass 10 II System

2 Answers

Denon avr 2802 can't get subwoofer to work all else fine


in the Denon setup under speaker configuration set the sub to LFE+Main

Jan 02, 2009 | Denon AVR-2802

2 Answers

Denon AVR 5803


If there is "large/small speaker" settings on your receiver, maybe you set speakers on Large. Some receivers, when set speakers to "large", won't redirect signal on subwoofer.

Oct 02, 2007 | Audio Players & Recorders

Not finding what you are looking for?
Celestion S10 Subwoofer Logo

772 people viewed this question

Ask a Question

Usually answered in minutes!

Top Celestion Audio Players & Recorders Experts

Josh Whitehead
Josh Whitehead

Level 3 Expert

1148 Answers

 Grubhead
Grubhead

Level 3 Expert

4751 Answers

Robert Rankin

Level 2 Expert

338 Answers

Are you a Celestion Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...