Question about Televison & Video

2 Answers

Polaroid tla-01911c will not power up

The tv worked fine yesterday. It has power to the cord. no lights or sounds. Is it toast?

Posted by on

  • cake271 Jan 25, 2009

    I tried that several times. It didn't work.

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 19 Answers

You likely need to replace the power supply and inverter board (they are on the same board) - you can find them for around $40 in the right places :)

Posted on Dec 08, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Unplug it, plug back in immediatly, and try turning on

Posted on Jan 25, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Fix sound on Polaroid TLA-01911C TV


Audio amp may be blown. A cable may be bad.
What are you connected to?

Apr 04, 2014 | Polaroid TLA-01911C TV

1 Answer

When I turn on my tv the screen is white and nothing else happens.


This is a common symptom of a power supply failure on the TLA-01911c. The board has parts called capacitors that filter the output power and when they go bad the power supply does not power up right. The unit can either have no power, just a flashing power light, just a white screen or it could take a long time to show a picture. Here is a link to a repair guide that shows what to replace on the power supply board to repair the unit.

http://www.ccl-la.com/blog/index.php/repairing-a-polaroid-fla-01911c-with-a-bad-power-supply/

I hope this helps you get your TV bad up and running,
BuddyMc

Jul 13, 2012 | Polaroid TLA-01911C TV

1 Answer

POLAROID TLA-01911C turns on but only white screen. no sound


Hello
The main board has the fault. Your set need a thorough check before confirmiing the fiault.
This is the picture of the board. OK.
2_16_2012_4_20_33_pm.jpg

Feb 16, 2012 | Polaroid TLA-01911C TV

1 Answer

Need a manual for Polaroid TLA-01911C


http://www.hdtvreview.com/Polaroid-TLA-01911C-hdtv.html

May 07, 2011 | Polaroid TLA-01911C TV

1 Answer

I have a polaroid TV model # TLA-01911C. It has sound but no picture. Just black screen.


Check the power supply and the voltage feeding th baclight inverter board.
Parts:
http://www.shopjimmy.com/catalogsearch/result/?q=TLA-01911C

If you are going to DIY and have proper tools, knowledge of electronics and know safety precaution then please read on:
Please see my basic troubleshooting guide here:
http://www.fixya.com/support/r5093881-lcd_flat_panel_tv_troubleshooting_guide

http://s807.photobucket.com/home/budm/allalbums

http://en.wikipedia.org/wiki/Capacitor_plague

Jul 12, 2010 | Polaroid Televison & Video

2 Answers

PROB LEM WITH POLAROID TLA-01911C


Hello,

The white screen and nothing else usually indicates a failure of the filter capacitors in the power supply board. When these capacitors go out the voltages are not correct so the TV can not power up right. You can rebuild the power board by replacing the bad capacitors and this should bring the TV back to life. Here is a link to a repair guide for this power supply board.

http://www.ccl-la.com/blog/index.php/repairing-a-polaroid-tla-01911c-with-a-bad-power-supply/

I hope this helps,
BuddyMc

Dec 28, 2009 | Polaroid TLA-01911C TV

1 Answer

Hi my tla-01911c tv powers on and displays the polaroid logo on the screen for about 30 secounds then shuts down as if there is a power overload or something. any ideas? thanks


Either the power supply/inverter board is bad, or the bulbs are bad - or poorly connected. In my case, the solder joints at the end of the bulbs in the top and bottom were horrible. A quick resolder on the corroded bits and good as new.

Dec 20, 2009 | Polaroid TLA-01911C TV

2 Answers

Will Not Find A Signal Polaroid HD 15" TV - Model TLA-01511C


same (tla-01911c) issue when trying to watch over the air brodcast try rescanning the channels that normally works for me

i got direct tv basic set on my S-video input so i only need over the air when the sat is down (i.e: storms, wind, snow, ...)

May 15, 2008 | Polaroid TLA-01911C TV

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

157 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

74822 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Cindy Wells

Level 3 Expert

5258 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...