Question about Beam Q power Brush Q100

1 Answer

My beam Q100 power brush starts for about 5 seconds then stops power.

When I turn it on it runs and vacuums for about 5 seconds and then the power fades and the red light goes on resulting in no suction or movement of the roller.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,976 Answers

Take the brush out and check for hair & string around the ends where it goes into the bearings. Remove the crud and reassemble. NEVER oil the bearings. It will collect dirt and dust and gum up.

Posted on Jan 18, 2013

Testimonial: "Once I figured out how to open the housing to the power brush (it was tight and difficult), I found an amazing amount of hair and crud. Removal of this resulted in the normal operation of the power brush. Thank you!"

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Roller brushes won't work


Remember, this brush is belt-driven (not air-driven), so if the brush stops working, then there is probably a problem with the belt. The device is likely set to stop the brush from spinning if the belt tension is not correct. My guess is that the belts have become too loose, or there is a malfunction with the sensory mechanism which detects that.

I will trust that your product does have the in-house warranty.

May 19, 2014 | Shark Navigator Bagless Upright Vacuum

1 Answer

We have a Beam Q100 power brush and the fuse repeatedly blows. The Outage for the socket is okay.


Regardless of the vac shops analysis you do have a problem with the power head. It may be an intermittent problem that only happens when not at the shop. Ask the shop if you can test drive a new head at your home. Offer to leave a deposit on the new power head while you test your system.

Jan 09, 2014 | Beam Q power Brush Q100

1 Answer

Broken handle release pedal


Definitely. Just find your local authorized BEAM dealer and they will sort it for you. Sorry, I don't know where you are so I can't find you a dealer but BEAM's website has a dealer locator.

Dec 24, 2013 | Beam Q power Brush Q100

1 Answer

Power head brush wont run


Could have a loos belt, check and replace if necessary.

Nov 23, 2013 | Vacuums

1 Answer

DC 17 UPRIGHT BRUSH MOTOR WONT STAY RUNNING. TURN


have a look at the filters first as it sounds like you blokeage

Oct 31, 2009 | Dyson DC17 Animal Bagless Upright Cyclonic...

1 Answer

Kenmore 116.23513301


If the motor on the power brush is running the belt is bad, if the motor on the power brush only runs when you push the overload, the overload is bad.

Sep 14, 2009 | Kenmore 22812 Bagged Canister Vacuum

2 Answers

I have a one year old Beam central vac. It has supervalves. The handle (connected to the hose stopped turning on the unit. The handle still powers the brush but no longer turns on the suction?


http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=566201
Generic problem for all Vacuums
I have a one year
posted by jon89 on May 02, 2008
I have a one year old Beam central vac. It has supervalves. The handle (connected to the hose stopped turning on the unit. The handle still powers the brush but no longer turns on the suction?

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. The Beam Central Vac may have more than a one year factory warranty and it sounds to me that you may have a bad relay switch the Central Vac, if you do it should be covered under the factory warranty. Otherwise, you may have a bad supervalves or a wire came loose, if the hose switch turns on the power nozzle then it may be a bad supervalve or a bad relay and to contact the installer or the manufacturer of Beam. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

http://www.beamvac.com/usa/ Owner Support
Customer Service 1-800-369-2326 Phone #
Email: beam.dir-support@beamvac.com
Technical Support: beam.tech-info@beasmvac.com
Thanks, Don the Vac Man
Go Ahead. Use Us.

May 02, 2008 | Vacuums

Not finding what you are looking for?
Beam Q power Brush Q100 Logo

Related Topics:

234 people viewed this question

Ask a Question

Usually answered in minutes!

Top Beam Vacuums Experts

cazo06

Level 1 Expert

17 Answers

Beamvacman

Level 1 Expert

20 Answers

Thatvacguy.com

Level 3 Expert

1296 Answers

Are you a Beam Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...