Question about Electrolux EL8807A Precision BrushRoll Clean. Bagless Upright Sealed HEPA Vacuum Cleaner 13"W, Wash Filter, Floors Carpets, 12A, 12Hose, 24Cord 15Lb

Open Question

Why is the red light coming on when I turn on my Vac

Posted by Anonymous on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Starts but turns off immediately. red symbol lights up


check your bag for fullness, if full, change it.
if not, try adjusting your grit control on the top of the canister to the largest setting.
if your vac still shuts off, you need to replace the control valve assembly.

Aug 07, 2015 | Electrolux Epic 6500 Vacuum

1 Answer

How to trouble shoot a brush warning light


What color light are you referring to? If it is one of the green lights that is normal for the up and down adjustments. If it is the red one that is another issue. If it is the red one, what does it do while it is on? Does it flash or is it on solid?

Jun 17, 2014 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

Red exclamation light is on and brushes not turning


On my Electrolux Precision, the exclamation light indicates that it detected an obstruction and will stay lit until the obstruction is cleared AND the "reset" button is pushed. The reset button is on the black part (same side as the exclamation light) about half-way back on the side of the vac.

Apr 17, 2013 | Electrolux Vacuums

1 Answer

The clean filter red is on


That is just a light that comes on when the machine is having trouble breathing. Clean the filter and check the vacuum for plugs. If the filter is too bad you may have to replace it in order to turn that light out. Run it too long that way and you'll burn out the motor so it's a good thing to get fixed.

Good Luck
The Vac Dr.

Jan 10, 2013 | Hoover Vacuums

1 Answer

Hoover windtunnel dirt finder light stays red. We've cleaned the elbow the roller the hose and have a clean bag. The vacuum is new only had it for 3 months.


I'm not sure about a 3 month old vac, I'd probably go the warranty route. However, for the older vacs thy start getting false positives. The sensor is simply a microphone hooked to a computer chip detecting sounds of dirt entering the bag.
To rig it to start working, you'll need to remove the tool accessory tray and elbow that enters the back of the vac, and attached to the bag. This will reveal the microphone at the elbow, and wire that runs into the bottom area of the vac. When on, a large amount of air comes from the bottom screw and area where the wires enter. My fix was to clean up the microphone contact points a little bit with a screwdriver, and then leave the vac running while putting in dampering in the hole at the bottom, and around the back of the elbow. Cotton balls and electrical tape at the bottom hole, and napkins around the outside of the elbow (wedged between the back of the vac assembly and elbow did the trick). The schematic for the vac is here: http<colon>//www<dot>vacsrus<dot>com/CartGenie/pg_U6485900<dot>asp
Look for micrphone.

May 12, 2010 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

My vacuum made a funny noise, the red light was on and so I turned it off. There are small sparks now when turned on


Sorry. It sounds like the suction motor is bad. The best thing to do is take it to a reputable vac shop.
Joe

Oct 25, 2009 | Filter Queen Majestic Canister Vacuum

1 Answer

On my kenmore central vac no power unplug unit plug it back green light comes on but try turning vac on green light goes off again .


Please clarify that we are talking about the central vac LED/switch panel panel and plugging it into a 110 V wall receptacle.
If I understand when you unplug from the power source ,then plug back in the green LED comes on, looking normal ? But when you manually activate the switch on the motor housing of the vac itself the vac does not start and the LED goes out, so no green or red LED at that point?
If this is the case , Kenmore CV's built approx 5 years ago (MADE by EUREKA) and prior had a circuit board with attached cord (as opposed to detachable) which was prone to relay failure. There were several symptoms, most common was that the relay on that switch panel /circuit board would fuse on and the vac would continue to run when the hose was detached from the wall.However some I worked on from that era had exactly the same symptom you describe. If your unit is between 5 and 10 years old and this sounds accurate, you can unscrew this curved side panel relay with one philips screw. Inside on the PCB will be an L shaped black or white 24volt relay, generally rated at 10 amps. The replacement board or relay will be rated at least 24V/ 15 amps or more. If you can isolate your motor and test it separtely with a power cord or meter , the realy/board will be the only control componnet left.
If you have a small tipped soldering IRON, not a gun, you can generally find a replacement relay to rebuild the board for about $6 at an electronics parts store. Otherwise you will need to replace the control board itself, anywhere form $45 to $70 plus service call if you have a tech come out to the house, and the tech will just unscrew , detach wires and replace the board, no repair , approx 15 minutes work. This will likely cost over $100.
Please post back with your results

Oct 24, 2009 | Easy Flo EF1400 Central System Vacuum

1 Answer

Is not sucking. Water comes out fine, but when the trigger is released, the water does not get sucked back.


Without more input from you, it is difficult to know what the problem is. Do you hear the vac motor wining ? If so, then ther is a clog in the passage or there is damage to the vac motor/impellor blade. If no sound from vac motor, well of course it will never ****-up the water. YOU WILL NEED TO TAKE IT TO A GOOD HANDY MAN OR AN APPLIANCE REPAIR/VAC REPAIR CENTER. Good luck, Macgivor

Oct 24, 2009 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

Old red and black Genie Shop Vac


http://geeksquad.fixya.com/ThreadView.aspx?prdid=19255&thid=659916
Old red and black Genie Shop Vac
Posted by girl power on Jun 10, 2008
A Wheel or disk has come off of the motor. I would like to get a copy of the user manual to see if I can determine where it came off of. This Genie Shop Vac was given to us from my father-in-law.

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. You can always check with the manufacturer Shop Vac to get an owner’s manual for the older Genie Shop Vac would be @ the Shop Vac Website and or Customer Service of which I will give you @ the bottom of the response. Other wise check with your local vac dealer in your area. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

http://shopvac.com/contact.asp Customer Service 570-326-0502 Phone #
Shop-Vac Corporation Customer Service 570-326-7185 Fax #
2323 Reach Road
P.O. Box 3307
Williamsport, PA 17701
Hours are: Monday thru Friday 8:00 am to 5:00 pm (EST)
Thanks, Don the Vac Man
Go Ahead. Use Us.


Jun 10, 2008 | Shop Vac 584-06-00 Canister Wet/Dry Vacuum

Not finding what you are looking for?
Electrolux EL8807A Precision BrushRoll Clean. Bagless Upright Sealed HEPA Vacuum Cleaner 13"W, Wash Filter, Floors Carpets, 12A, 12Hose, 24Cord 15Lb Logo

Related Topics:

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

yadayada
yadayada

Level 3 Expert

75077 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...