Question about Bissell 1699 ProHeat Clear View Upright Steam Vacuum

1 Answer

We have everything set up,and have checked all possible, but when turned on it does not despense any solution, ideas

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 66 Answers

Make sure that the line to the tank is not kinked or bent in the tank itself hope this helps

Posted on Jan 24, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Dyson dc 47 head won't turn on


Hi there, it's Jack at Dyson.

If the brush bar in your DC47's carbon fibre turbine head isn't rotating it's worth checking it's set correctly. You can turn off the brush bar manually to clean delicate rugs, and it's possible the brush control may have been accidentally activated:

6417c079-7048-4bbe-93ea-5b7c298c8655.jpg
It's also a good idea to check that the brush bar is free of any threads or hair, and that there are no obstructions in the cleaner head which could be jamming it:

This should resolve the issue, but if you'd like some further advice from our experts when you've given this a try, please give us a call on 0800 298 0298 (UK), 1-866-693-9766 (US) or 1800 239 766 (AU).

Jul 11, 2014 | Dyson DC47 Animal Canister Vacuum Cleaner

1 Answer

My Dyson DC33 isn't working correctly. It's not picking up like it used to. The brush isn't turning and the belt is fine. I've checked all filters, hoses and cleaned everything. Why is the brush not...


Is it possible that you have accidentally changed the brush control setting? I say this because it happened to me and I thought it had broken. I must have caught the dial with my foot! Here a link that might help:

Jul 09, 2014 | Dyson DC33 Bagged Upright Vacuum

1 Answer

What can i do if i dont have a soap despenser


With this unit, use a small shotglass of soap solution into the water container when you are filling it up. the soap will premix in the water there and be good for the system to continue using. Make sure that the dial is set on WATER ONLY so that you are not getting soapy water coming out of where the soap bottle should be.

Nov 04, 2010 | Bissell 1698 PowerSteamer ProHeat Upright...

1 Answer

MY BISSELL SEEMS TO HAVE THE SAME PROBLEM AS EVERYONE ELSE - NONE WHICH TO MY KNOWLEDGE HAVE BEEN RESOLVED. MY MACHINE WILL DESPENSE BUT NOT SUCTION - WHAT GIVES WITH BISSELL -IT THIS AN ONGOING PROBLEM


Please check the following:


First check the motor duct gasket. The motor duct gasket is visible once the tank is removed. It is located underneath the handle on the top of the base of the machine. It has a black rubber coating around it. If there is no suction there please let us know. If your machine does have suction at the duct, continue to check the following:


- Ensure the Ready Tools Dial is set to the appropriate setting (Floor Cleaning or Hose Attachments).
- Remove the tank from the machine and ensure the tank lid is attached properly. The front window must first hook onto the lip of the bottom of the tank and then drape over the tank. Latch the bottom tank to the top tank lid. THIS LID CANNOT BE ATTACHED PROPERLY IF THE TANK IS NOT REMOVED FROM THE MACHINE.
- Make sure the Water Tank is not full on the outside of the bladder. If it is, empty the tank.
- Ensure the hose is firmly attached to the back of the machine. If not, re-insert as necessary by twisting into place.
- The machine must be in an upright, locked position and set to the Hose Attachment setting. If the handle is slightly tilted back while using, it will create a small gap at the suction inlet (where handle meets gasket, above the Bottom Tank) which will cause little or no suction.
- Check the red Tank Lint Screen for debris. If the Lint Screen is dirty, the unit will have poor suction. Clean the Lint Screen if necessary.
- If the float flap door in the tank lid is activating prematurely when you turn the machine on, this flap door should be replaced. This tank may need to be emptied.
- Check the Tank Lid and Tank for damage.


If you continue to experience low suction contact BISSELL Consumer Services at ...

1-800-237-7691
Mon-Fri: 8am to 10pm ET
Sat: 9am to 8pm ET

Aug 16, 2010 | Bissell 9200 Upright Vacuum

1 Answer

Shampooer won't foam correctly.


check all hoses with o'rings installed on them...
one cracked or scored one will affect the suction and despensing the pressure to foam correctly

Mar 06, 2010 | Kirby Vacuums

1 Answer

Powersteamer 1697, 8804 series, Smartmix will not despense cleaning solution


there is usually a button or release lever by the handle that u sqeeze to release salution

Jan 22, 2010 | Bissell Carpet Cleaner Powerbrush Deep...

1 Answer

PROheat cleaner model #8930 will not despense liquid.


yes if it sprays from the hose its the heater clogged its in the handle if no spray replace belt check on rinse only

Dec 12, 2009 | Bissell ProHeat Turbo Deep Cleaner Upright...

1 Answer

Detergent container will not despense fluid


Check that the switch is on autowash and not just on the rinse option. I see that customers do this alot.

Jan 03, 2009 | Hoover F7425-900 SteamVac V2 Widepath...

1 Answer

Leaking


Could be that the despensing tank has melted and deformed at the connection point. This is what happened to me when I put in really hot tap water. The heat allowed the connection (where the water/soap outlet is) to deform when using it. Now when I fill the tank and place it in the machine the water just leaks out all over the place with no control.
If you look at the bottom of your tank, where the water comes out, you may be able to see that the plastic is mis-shaped or deformed slightly. It probably doesn't take much for the seal to be broken.

TEA

Sep 22, 2008 | Eureka Atlantis 2591A Upright Steam Vacuum

1 Answer

I have a Eureka Central Vac CV1601b. The motor does not stop unless the Unit is unplug from the electrical outlet. Any Idea?.I removed the control unit to check if there was disconnected wires or burnt...


If the unit is relay controlled, there is always the possibility that when the unit was turned on, the relay contacts welded themselves shut making the power button ineffective.

If you're familiar with relay pinouts, with the unit unplugged, verify the contact closures with an ohmmeter or continuity checker. With the unit unplugged, the relay contacts should be in their "normal" state (probably open).

Try gently tapping the relays to see if it can be freed that way. If that works, there's nothing stopping them from welding themselves together again. The relay may need replacement.

Cheers.

Mar 07, 2008 | Vacuums

Not finding what you are looking for?
Bissell 1699 ProHeat Clear View Upright Steam Vacuum Logo

Related Topics:

26 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

Brad Brown

Level 3 Expert

13536 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...