Question about Hoover Vacuums

1 Answer

U6425 change power cord

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Hoover Master
  • 18,391 Answers

Here is a video that may help you

Posted on Jan 17, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The brushroll stops turning.


Hoover Windtunnel Self-Propelled Vacuum Belt ... - YouTube

? 2:54
www.youtube.com/watch?v=AJL9McF7MAU
May 22, 2012 - Uploaded by Crucial Vacuum Fits: Hoover U6423-900, U6425-900, U6425-920, U6429-900, U6430-900, ... U6616-900, U6617-900, U6625-900, U6626-900,U6630-900, ...

Aug 06, 2015 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Hoover model U6425-900 brushes do not roll


-- Make sure slide switch is in carpet position
-- The idler arn which tensions the brush belt may be broken
-- The idler arm override which is attached to the carpet slide switch may be broken

The second one is common.

Oct 30, 2011 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

I have a Hoover WindTunnel Model # U6445-900. The on/off switch needs to be replaced and I'm not sure what parts are needed to repair it. Thanks Gloria


You can order any parts needed at the below link. This is a parts diagram. The switch kit doesn't have a part number here, but it's the second item on the list.

http://www.fiorijanitorial.com/p-447-hoover-windtunnel-parts-self-propelled-body-u6423-900-u6425-900-u6425-920-u6431-900-u6445-900.aspx

I recommend using the below site to order. It provides a clear picture of the switch kit.

http://www.sweeper-city.com/howiswkit.html

Mar 16, 2011 | Hoover Vacuums

1 Answer

How do you change the power cord on the Hoover u5475-900 Wind Tunnel 6200? Thanks for your help.


This procedure worked for replacing the cord on my Hoover U6425-900. At a minimum, you will need a number 2 Phillips screwdriver, wire cutter, and two electrical wire nuts and electrical tape. Remove the accessory tools from the storage compartment. Remove two screws, these are recessed. Remove the cover from the bag compartment, remove two screws located at top corners of bag compartment. You may have to open the side filter door but the accessory tool storage compartment should be free at this point and can be removed. You should see the power cord and related wiring. If you have a digital camera you could take a photo at this point in case you need a point of reference. Make note of the power cord strain relief routing and length of wire. Too much wire will make reattaching the storage compartment difficult and the routing prevents the cord from being pulled out.
On my model the wiring colors were purple, orange and white. My replacement cord had black and white wires. The orange wire will not be involved in cord replacement. Using the wire cutters clip the purple wire about three inches back from the existing terminal. If present, clip the two nylon wire ties and discard. The white wire will have a crimped on wire connector. Clip the white wire about three inches back from the existing wire connector. The old power cord can be removed by pulling it out from the rear, it should just slide out of the rubber insulating boot. If not use a set of pliers and crimp the boot from the wiring side and push it outside the vacuum housing. If you have to do this make sure you slip the boot over the replacement cord before you insert the new cord back into the vacuum housing. Remove about a half inch of insulation from the purple and white wires and from your replacement cord unless it was supplied with insulation already removed. Use new wire nuts and connect the white wires. Use the other wire nut and connect the purple wire to the remaining new power cord wire. Use some electrical tape and wrap the nuts to the wires a couple of times so they won't loosen. Make sure you route the power cord around the posts as this is the strain relief and prevents the cord from being pulled out. Reassemble and test.




Feb 03, 2011 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Windtunnel ultra U6425-900 stops running after 5 minutes


Sounds like its overheating and cutting out.
This is normally caused by a blockage or blocked filers.

Please leave feedback
Thanks
Rob

Feb 07, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Self propell doesn't work. Motor spins and belt burns, brushes do not turn. model Hoover self propelled u6425-900


may be a stripped sprocket/cog or snapped shaft. check and replace as needed.

Sep 03, 2008 | Hoover Vacuums

1 Answer

I have a Hoover self propelled WindTunnel vacuum( Model U6425-920) that stops in the middle of cleaning. I have changed the flat belt and I'm still experiencing the problem. I usually have to wait an...


http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=632298
Generic problem for all Vacuums
I have a Hoover self
Posted by thjunk2007 on May 29, 2008
I have a Hoover self propelled Windtunnel vacuum( Model U6425-920) that stops in the middle of cleaning. I have changed the flat belt and I'm still experiencing the problem. I usually have to wait an hour or so b/4 it would work again. Any advice?

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. It is possible that you my have a heat sensor, but as far as what you described you need to change both belts, the brushroll belt and the power drive belt as well and @ the same time. The average belt change is every 4 to 6 months on the vacuum. Does it stop completely or is it just the belt problem. Or #2 is the vacuum giving off a burning smell other than the belts and if it does it could be the motor. Other wise , please call the factory or a local Hoover warranty station in your area. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Thanks, Don the Vac Man
Go Ahead. Use Us.

May 29, 2008 | Vacuums

3 Answers

Handle foot pedal release U6425-900


I have the exact same problem. I can't even open the unit up. Let me know if you found anything out. I have searched the web and can't even find a service manual to purchase ! Thanks.

Apr 08, 2007 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

30 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18390 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1460 Answers

Brad Brown

Level 3 Expert

15557 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...