Question about Optoma H30 Multimedia Projector

1 Answer

H30 Crashing My H30 seems to be crashing not long after turning it on. When the problem occurs the signal from the source input is lost, followed by a black screen and a green bar scretched across the top part of the screen. The only way to fix it is to turn off the projector, leave for 10-15mins and restart. It used to do this occasionally but just recently it is happening nearly everytime i use it. I contacted optoma support and there repair charges were outrageous (and only a 90day warranty after the repair) I haven't been able to locate any similar problems from other users on the www, and in despiration i thought i would try 'Fixya' :)

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: H30 Crashing

The only thing I can think would be that the projector is heating up because the air filters are clogged.

Posted on Jul 10, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

My DLP projector SIM2 DOMINO D35 is turned on and works normally BUT picture is absent on all of inputs (projector shows NO SIGNAL, green indicators is ON). Sources of signal and cables are in order. What...

It is possible that the last time this was connected there must have been an higher input applied than is recommeded so that the input PRE_AMPS were loaded to fail.
You need to check with an signal trace on the input to find if an OP-AMP has failed or the LOGIC switching IC had failed.
Need to test using a signal tester and meter.

Jul 14, 2011 | SIM2 DOMINO D35 DLP Projector

2 Answers

Optoma H30 projector hooked up to JVC RX-D201S receiver

Hi Tomyka81,

I will investigate the problem you are having and get back to post a comment momentarily. If you can describe the yellow cord for me a little better. Please describe the connectors on both ends for me. I will post back soon with a proper hook up.

Dec 10, 2007 | Optoma H30 Multimedia Projector

2 Answers

No picture

Hi, Possibly either of 2 reasons: 1. Your player is not sending any signal to the Optima meaning it is the one in question and not the projector; or 2. Your Optima lost its input signal, go through the signal source selection menu, try manual selection & set it to where your source/player is connected. Hope this works out for you, if not pls post again . Good luck and kind regards.

Aug 03, 2007 | Optoma H31 Multimedia Projector

1 Answer

Sp4805 turns on by itself, direct tv picture will run for a short while then dorps out. I can't seem to pick a source? I tried my dvd player and it seemed to work normally. menu options are not highlighted...

In the sources menu where you assign sources, the second selection from the bottom is where you enable/disable sources which can inhibit a source/input from working even if it is assigned. Also check mark the auto source enable box.
If the input you are trying to use is not assigned or enabled many of the menu items are grayed out.

A quick fix is selecting the "factory reset" in the menu as the default factory settings are such that all input's are set to work.

Good Luck!


Nov 13, 2009 | InFocus ScreenPlay 4805 Multimedia...

1 Answer

Infocus X1 picture freezes and dissapears and then comes on again

your display settings may be off, so change settings to factory reset and you may have to drop the resolution on your computer. you may also have a bad cable, so try a different cable.

Jul 03, 2009 | InFocus X1-RE Projector, Factory...

1 Answer

Canon LV-S2 projector not work with component signal input

Try unplugging the projector. This seemingly works but I can't figure out WHY....

Mar 18, 2009 | Canon LV-S2 Multimedia Projector

1 Answer

Optoma h57 purple tint

Hi tassos2000

I'm afraid this is indeed a Mainboard problem that will require either repair or replacement.

You nearest dealer / repairer of Optoma Projectors in Greece is in Athens , details of the company is as follows:

LEC Hellas S.A.
31 Salaminos Street
Tel : +30-210-2851948

They should be able to sort you out mate.

Thanks for using Fixya and good luck !

May 26, 2008 | Optoma H30 Multimedia Projector

1 Answer

3M MP7740i Projector no input is detected

Hi mrus821

If the signal won't go through you will have to either have your Mainboard Repaired or Replaced.

This is unfortunatelly a common Mainbaord problem , and the above is the only way to get it fixed.

Apr 22, 2008 | Multimedia Projectors

1 Answer


Hi there

First try to bypass the box and put signal directly into the Projector from the source - i.e. DVD Player

If the signal still doesn't pick up , try using a different cable.

If the problem is solved , then your Converter Box is faulty.

If the problem still occurs then you might have a faulty Mainboard - as all the inputs on this Projector is situated directly on the Mainboard.

Hope this will help you !

Jan 03, 2008 | Mitsubishi HC100U Multimedia Projector

Not finding what you are looking for?
Optoma H30 Multimedia Projector Logo

Related Topics:

91 people viewed this question

Ask a Question

Usually answered in minutes!

Top Optoma Multimedia Projectors Experts


Level 3 Expert

2236 Answers

color wheel light...
color wheel light...

Level 2 Expert

137 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

5327 Answers

Are you an Optoma Multimedia Projector Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides