Question about Kicker 2010/10 Dx500.1 Car Audio Monoblock Mono Class D Dx Amplifier Amp 10dx500

1 Answer

Kicker dx 500.1 keeps ruining my subs

I've been running this amp with a sony xplod 10" sub for a few months with no issues. recently the sub stopped working (no sound or movement at all). Other speakers worked when I did a quick test with them. Today, I bought a brand new 1200 W 4 ohm DVC sub and wired it for 2 ohms and hooked it up, In less than 5 minutes, I had the same issue...no sound or movement. The protect light is not coming on, the amp has power. I'm really not sure what to try next here.

Posted by on

  • Chris Thumm Jan 17, 2013

    UPDATE 1/17/2013: After testing anything I could think of with a DMM, I determined that the issue MAY be the connections inside the speaker box I am using. I have not pulled the new speaker out to confirm my suspissions yet though. I do know the issue is NOT the amp, as I now have an old Rockford Fosgate hooked up to it (in a different box), I will update again after checking the box in case anyone else has a similar issue and is looking for info.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 65 Answers

If your sub isnt blown, i'd follow your own idea and look for a bad wiring connections, also what kind of head unit do u have? check the settings on ur head unit to see if there is a seperate setting for your amp/subs if it does have one, make sure it is set properly

if it does not have a setting like above, check the rca cable from the radio to tthe amp, and make sure that the rca cable is plugged in to " input instead of the output

Posted on Apr 13, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have 2 12 inch kicker rt dual 2 ohm subs. On a kicker cx1200.1 i want to kno how to hook it up to 2ohm to the amp. And if i can add another 10 inch kicker rt 2ohm sub in the future.


Do to the impedance Of your sub u can't run it @2ohms its going to either be @1ohm or 4ohms and your amp isn't 1ohm stable and u will risk damaging your amp. So your only option is to run it @4ohms and on a good note your sub is 100-600 watts RMS and your amp will push 400-500 watts RMS @4ohms. Now if you want to run 2 sub's in the future That amp will work perfect because it pushes 1,200watts RMS @2ohms and to wire your 2 sub's @1ohm just follow the steps in the image below. Hope this helped.25345194-v0hbouy2nvquqteoroa5j5rq-3-0.png

Dec 30, 2014 | Car Audio & Video

1 Answer

Are sony xplod 1100 watt 10'' subs 2 ohm stable


No keep on trying end blow everry thing up, Buy some real subs.

Nov 29, 2012 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

1 Answer

I just bought a cvr kicker 10' sub, hooked it up in my car replaceing a polk audio sub. The kicker keeps blowing my fuse. i have checked the wireing. i have an 800watt sony xplode amp. Please help


i am assuming that you bought this sub used? their could be a problem with your voice coil. the voice coil moves the cone of the speaker in and out. the problem with the voice coil is that it has become lose and is doping the impedance of the sub. A lose voice coil can be cause by over powering the sub. this problem is not fix able.

Aug 01, 2011 | Kicker 01C8VR4 Car Subwoofer

1 Answer

I have a sony xplod 2/1 channel amp 800 watts. I already have 2 sony 6 by 9's hooked up to it running at 60 rms each but I wanna bridge a sub to it too. I was planning on taking a positive from one...


I don't recommend it. It may work good during low volume, but from experience, you will only turn it up so high before it trips the protect light on the amp since it's drawing too much current due to extra speaker(sub), then you have to turn off the radio and turn it back on to get it working again, it gets annoying. I recommend saving up for a mono amp, it will keep your system sounding clean and clear. the setup you specified will work, but it's not recommended. Your amp may run hot as well.

Jul 22, 2011 | Sony Car Audio & Video

1 Answer

Does a 1200W amp run 2x800W subs


ya youll be fine 800watts is at peak power on the speakers

May 29, 2009 | Kicker KX Series 04KX1200.1 1200w RMS...

1 Answer

Kickers dont beat like they should


try to check and clean the wiring as clean as possible to avoid messing up on your connection. Check the polarity of you subs to yuor amp if you have it connected on the outher way around it would not give you a good result. check the polarity this will solve your problem. Over powering your sub will fry it easily try to tune it a 10" sub wont give you a 15" performance..

Jan 20, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Subs dont beat like they should


you've spent alot of money on **** by the sounds of it!!. you should only ever run multiple subs the same brand, power and resistance you can just connect any old subs to a system you need to wire them depending on the load that the amp needs to see. first thing is to try the amp/s on a individual sub to check your amps still work once done check the subs 1 by 1.

Jan 20, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Sub not working any more


mine does the same DONT BUY SONY XPLOYED THEY EXPLOYED!!!!!!!!!!!!!!!!!

Jun 23, 2008 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Problem with amp?


Give that new sub a chance to "break in". New speakers require a few hours of use before the voice coil(s) and spider break in and began operating at their best performance. Is the box within the operating specs of the sub? Is this a ported box; if so you will here some turbulance type noise from the port. What type of distortion are you hearing? Alternator noise(dentist drill like sound) would only be noticable through a sub at lower volumes due to the frequency response of a sub. Is the amps lowpass crossover turned on?

Mar 08, 2008 | Sony Xplod XM-1652Z Car Audio Amplifier

Not finding what you are looking for?
Kicker 2010/10 Dx500.1 Car Audio Monoblock Mono Class D Dx Amplifier Amp 10dx500 Logo

98 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

yadayada
yadayada

Level 3 Expert

75117 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...