Question about M-Audio Delta 66 Sound Card

1 Answer

Soundcard problems I have a powermac g4, running osx 10.3.9, I am having problems with sound... when using logic express 7 and reason, after playing for awhile the sound quality cracks up, crackles,getting worse and worse until I quit the programs. I use M-audio soundcards, have had an audiophile 2496 for awhile which worked ok and recently added a delta 66 (so both installed at once), using delta driver 2.0.3. on multicard setting. any clues as to how to sort this out appreciated. also an intermittent problem I have is sometimes there is the last sound repeating making a loud noise when paused.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert whose answer gotĀ voted for 20 times.


    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 153 Answers
Re: soundcard problems

I'd say to look at latency settings and sample rates. also disable screen savers and power management.

Posted on Aug 26, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Driver for windows 7 yet?

To help me better see what is going on please reply with your BSOD info. The link below will show you the info that I need.


Apr 25, 2010 | Tascam US-122 Sound Card

3 Answers

Nasty ***** distortion on Delta 1010's on Mac G4

Your first line stated the obvious; the PC can run 2 cards, but the G4 cannot. The Mac, although a 'PC' has significant hardware differences with an IBM derrved PC.

Feb 01, 2010 | M-Audio Delta 1010LT Sound Sound Card

1 Answer

Windows Media Player cannot play the file because there is a problem with your sound device. There might not be a sound device installed on your computer, it might be in use by another program, or it might...

You might encounter this error message for one of the following reasons:
  • Your sound device is in use by another program. Quit other programs that might be using your sound device, and then try to play the file again.
  • Your sound device requires an updated driver. To determine if an updated driver is available, see Windows Update, or see the sound device manufacturer's Web site.
  • The selected sound device does not support Secure Audio Path (SAP). If you have multiple sound devices installed on your computer, try using a different one.
  • Your sound device is not functioning properly. To troubleshoot the problem, see Windows Help and Support or refer to your sound device's documentation.
  • You do not have a sound device installed on your computer. Install a sound device (such as a sound card), and then try to play the file again. If you can't install a sound device in your computer, you might be able to resolve the problem by attaching USB-based headphones or USB-based speakers to your computer instead.

Apr 26, 2009 | Razer BARRACUDA AC-1GAMING SOUNDCARD 7.1...

1 Answer

0xc00D118A:Cannot play the file

This should be a compatible driver for your soundcard (AC97), download and reinstall it.

Post your results here, especially if you are still in need of assistance.

Apr 02, 2009 | HP (153147-001) Sound Card

2 Answers

HELP!!Setting up my Mbox1 as general sound output in my mac!!

I've had the same problem. I got it to work using Soundflower and LineIn.


After installing soundflower, it should show up like a virtual soundcard in your sound prefs. Send your audio output to the soundflower 'card' in sound prefs. Then use LineIn to route the outpout from soundflower to the Mbox like this:

Input from: Soundflower (2ch)
Output to: Digidesign HW ( Mbox )

Dec 28, 2008 | Digidesign Mbox External Sound System

4 Answers

My computer does not bring any sound when playing music

Well, how about telling us what computer u have, is that a separate soundcard or is that the soundcard on your motherboard? There is diferent soundcards on computers. So if u want us to help u u need to come up whit some more info.

Nov 13, 2008 | Audio Cards

1 Answer

Lower and Upper filters Gone!!!!.

sounds like permission issues in the registry or the system folder.
for files try cacls xp reset in google and go to tweakxp website.

for registry you have to right click , permissions and make sure your user name is checked for full access to multiple locations of registry.

Jul 31, 2008 | Edirol UA-4FX External Sound System

2 Answers

Phones 1-2 has both channels coming out of it

Had the same problem and fixed it today. It is the mute button. Whem you change from 1-2 to 3-4 if the mute button for 1-2 does not activate you will get the sound from 1-2 thru 3-4. Just change the setting and you are away. worked for me.


Jun 03, 2008 | Echo Indigo DJ Sound Card

3 Answers


Are you hearing the sounds from your speakers on your computer only?...accordianman

Feb 03, 2008 | Tascam US-144 Sound Card

1 Answer

IBook sound card performance?

I've seen USB soundcards, on ebay, that you can plug in and use...they were pretty cheap tho, so dunno if you'd want one...but I guess that it shows that it is possible to do :>

Dec 19, 2007 | Apple (6612068) Sound Card

Not finding what you are looking for?
M-Audio Delta 66 Sound Card Logo

Related Topics:

137 people viewed this question

Ask a Question

Usually answered in minutes!

Top M-Audio Audio Cards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Gareth Cockram
Gareth Cockram

Level 3 Expert

657 Answers

Jazz Boyce
Jazz Boyce

Level 1 Expert

728 Answers

Are you a M-Audio Audio Card Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides