Question about Hifonics Titan TX 8805 Multi-Channel Amp Car Audio Amplifier

1 Answer

Power light when i turn my amp on the green power light comes on for about 1 sec. then you can hear a click and the power light turns red but its not the protect light

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 48 Answers
Re: power light

This could be a DC offset condition. Check you manual for what this means. Or other condition. First Disconnect the Subs and try it. If it still goes red then disconnect the RCA's and try it again. If the Led continues to go red after the click then the Amp is hosed. The Click you hear is an internal relay that cuts the subs in after a dely so you do not get the turn on THUMP of the radio at your subs.

Posted on Jul 14, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Green light comes on for a sec the red light comes on,1200 watt sony xplod amp 10'' Orion sub,I think the subs right around 3000 watts. What's wrong?:(

Your Sony Xplod amplifier turns on briefly (green light) then possibly senses a mismatch between the nominal output impedance of the amplifier and impedance of your Orion sub and goes into protect mode (red light) to prevent internal damage.

Jul 19, 2014 | Car Amplifiers

2 Answers

I have a kicker 500.2 red protection light is on and red light on top of amp flashes every couple seconds. Have checked all connections and other amp in truck works good. I bought two of these amps and...

Disconnect all the wires except the three main power wires, ground, 12v battery and remote. Now, turn on your radio, if the protect light is still on then there's an internal short in the amp. If the light turns green, then there's a short in either the auxiliary cables or the speaker outs. If it turns green, then troubleshoot the other wires that plug into the amp by connecting them one at a time until the protect light comes on, which will tell you that there's a problem with that speaker/aux wire.

Jul 25, 2011 | Kicker KX500.2 Car Audio Amplifier

1 Answer

My amp was working good and i didnt use like for two months and know it doesnt work the green light turns on but the red light too of over current and i cant hear nothing i dont know what is it..

if it turns red its a protection light you most likely got the ohms wired wrong on the speakers and the amp is going into protect mode so you dont fry it or the subs

Mar 04, 2011 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

When i turn the amp on the green light comes on for about 5 sec then the red light comes on for pertection mode

disconnect speakers and cycle the power if the same thing happens the amp is bad!

Feb 23, 2011 | Pyle Car Amplifiers

2 Answers

The red protect light is coming on

It is possible that your amp is going over the threshold limit of draining current to give out the protect signal. What could be done is to first checkout if your speakers are loading the amplifier, check the rating of the speakers and the impedance, must not be too low.below 2 ohms. Now check the source signal if this is bringing in any transcient signals to power out the outputs particularily high/low freq. So decrease off your bass and treble to mid position and test again. see if there is any improvement, if so there could be a filter problem with your set. Connect an external source and see if the amp powers better , in such case check for fault in cables, input lines and ground with in the set. Repeat this and check. Hope this helps you out. Good day

Jul 19, 2010 | Verge VGA285 Car Audio Amplifier

1 Answer

Green light (protection mode) on, NO red light (ready)

double check your wires aren't shorting out or power or remote wires aren't grounding. check if speakers are blown with nine volt battery

Sep 05, 2009 | Kenwood Car Amplifiers

1 Answer

Power light turns from green to red protect mode and then there is no sound coming from my speakers

there are 2 reasons for it to be going into protect mode 1 is heat 2 is the load on it. if it is going into protect mode soon after it starts there is a problem with the speaker. if it is after it has been on for a while it is that the amp itself is overheating. hope this answers your question

Apr 27, 2009 | SPL Audio Phantom DK2-1000 Car Amp

1 Answer

Protection Light Comes on

your amp isnt getting enough power to it you may need to install a compacitor unit

Mar 23, 2009 | Sony NTX-2136 DHD 2Channel Car Amplifier...

2 Answers


sounds like a bad ground or power.

Jul 12, 2008 | Car Amplifiers

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

248 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Amplifiers Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers


Level 3 Expert

6993 Answers


Level 3 Expert

56797 Answers

Are you a Hifonics Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides