Question about Standard Power Center for Aqualink Rs

1 Answer

I have a Jandy Aqualink Power Center that is humming. I have not heard it hum befor. Is this normal.

Posted by Anonymous on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Renaissance:

    An user who is expert in 3 categories / brands.

  • Standard Master
  • 1,448 Answers

Check to see if you have proper voltage coming in then test transformer to see if 24 volts if so start unplugging the auxs 1 at a time until it goes away sounds like a relay is stuck if not give me more info

Posted on Sep 07, 2014

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 372 Answers

SOURCE: I have an Aqualink RS power center that is humming. It did not seem to hum before. Is this normal.

I have worked on RS systems for many years and have not yet run across one that hums. I would think that it may be coming from one of the relays or a light dimmer, if you have one installed. Unless you are well comfortable working with high voltage, call out a tech to isolate the source and determine if any repair is necessary. Sorry I couldn't be of more help.

Posted on Jan 13, 2013

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have an Aqualink RS power center that is humming. It did not seem to hum before. Is this normal.


I have worked on RS systems for many years and have not yet run across one that hums. I would think that it may be coming from one of the relays or a light dimmer, if you have one installed. Unless you are well comfortable working with high voltage, call out a tech to isolate the source and determine if any repair is necessary. Sorry I couldn't be of more help.

Jan 13, 2013 | Standard Power Center for Aqualink Rs

1 Answer

AquaLink RS8 switchs itself from Pool to Spa pump


make sure no programs if ok remove spa side remote plug if ok then replace spa side remote istill does it reset board but before write down all auxs and jvas

Mar 15, 2010 | Jandy AQUALINK RS TELELINK KIT

1 Answer

Jandy aqualink rs8.Pool and spa lights wont come on. (programming?)


If it's both lights and they are on seperate switches I would start by checking the GFCI and be sure it is not tripped and if it is you would need to find out why. Then check power in and out of the light module in your power center. If you can set the power center to service and turn the lights on manuley from there then it is programming but most of the time it will be something in the lights or their circut.

Mar 06, 2010 | Jandy AQUALINK RS TELELINK KIT

1 Answer

NAD S300 Amplifer humming


You have either got a bad earth connection, or possibily there's a capacitor failed.
If you can't find a dodgy conection, I would replace the large Electrolytic Capacitors in the power section, they are used to take out 50hz hum in the mains electric, when they go you get that hum coming into your system.

Nov 15, 2009 | NAD S300 Amplifier

1 Answer

My aqualink power center and indoor control has no power, but the aquarite chlorine system is still lit up. Is there a fuse or a board the can be replaced?


The chlorine controller is wired seperately from the aqualink, you need to find a different circuit breaker/fuse to power it down or trace the cord and unplug them.

Sep 15, 2009 | Jandy AQUALINK RS TELELINK KIT

3 Answers

Jandy Aqualink display reads "waiting"


System locked up. Handheld is frozen at WAITING screen means Microprocessor is locked.

Here is what you do:

1. Turn off power to the system (control box)

2. Disconnect battery at the Power Center (9volt battery in control box/cross tip screwdriver required)

3. Turn on power

4. Reconnect the battery

5. Reset time and date on PDA.

6. Thank me.... BadWally sends

Aug 20, 2009 | Jandy AQUALINK RS TELELINK KIT

2 Answers

I have a jandy aqualink RS PDA. It will not



System locked up. Handheld is frozen at WAITING screen. Microprocessor is locked.

Here is what you do:

1. Turn off power to the system.

2. Disconnect battery at the Power Center and turn on power.

3. Reconnect the battery and reset time and date.

4. Thank me.... You are welcome... BadWally sends.

Jul 03, 2009 | Jandy AQUALINK RS TELELINK KIT

1 Answer

Jandy one touch control screen


your RS board in the power center is shot. that message means there is no communication to the power center.

Sep 13, 2008 | Jandy Aqualink - Rs24 One Touch Pool / Spa...

Not finding what you are looking for?
Standard Power Center for Aqualink Rs Logo

Related Topics:

38 people viewed this question

Ask a Question

Usually answered in minutes!

Top Standard Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1338 Answers

Bill Jordan

Level 2 Expert

372 Answers

David Spradling
David Spradling

Level 3 Expert

3543 Answers

Are you a Standard Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...