Question about CyberPower Office Power 585AVR (obcps585avr_1) UPS System

2 Answers

The cyberpower 585 AVR suddenly is´nt working...

When push the "on" button, only turn "on" and then turn "off" again, again and again by itself, and can use the PC because is not back up since then. What can I do?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 26 Answers

I would say less a hardware problem and more of an expired battery issue. These can be easily replaced by removing the six screws from the bottom of the unit and the top will come off. The battery is easily accessible. Here's a link to the replacement battery: http://www.batteryinternational.com/cyber-power-cps585avr-ups-battery-ups-batteries-f1.html

Hope that helps!

Posted on Oct 23, 2009

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    New Friend:

    An expert that has 1 follower.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 37 Answers

The ups hardware of the relay and driver might be spoil..ask of the service? you can try this asia systems technologies look for our sale person william +65 65478990 william@asiasystemstech.com i suspected that now that u UPS is have hardware issue.. to determine if the unit is really the problem it hav to be do a further diagnos..

Posted on Mar 24, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The reset button is pushed in and therefore unable to reset it. Do you have any suggestions?


A faulty reset button. They are usually spring loaded. Replace the push button as it is stuck.

Jun 27, 2014 | CyberPower POWER,550VA,UPS,BK (CPS550) UPS...

1 Answer

Where can I get a manual for my 825 AVR Cyberpower?


Here's the User Manual [click HERE] and here's the PowerPanel Personal Edition Manual [click HERE].
Let me know if you need further help.
Good Luck.
Thanks for using FixYa.

Apr 19, 2011 | CyberPower (R) CP825AVRLCD Uninterruptible...

1 Answer

Cyberpower 575SL stored unplugged x 5 wks-won't power up


check the battery it could be the battery is dead.. if it is so replace the new batts.. than plug in the power to ups.. n turn on it i suggest doen't turn off the power all the time i might cause the lifespam of the battery to shorting.. normal the ups can be use up to 3 yres time..

Mar 22, 2009 | CyberPower 575SL (CPS575SL) UPS System

8 Answers

Cbyer power 525Sl keeps turning off and on and beeps.


I have the exact same issue with my 525SL.
When you push in the red button - the green power light comes on for about 5 seconds = then the light goes out and the device plays a single long beep for about 5-8 seconds.

Given the dialogue here - I took out the battery and bough a brand new BB replacement battery and returned it into the unit as it should. The device continues to have the same behavior.

So it is NOT always a new battery that will fix the system.
Don't jump into spending $30.00 for a replacement.
Look into this further or you'll wind up wasting your money.



Oct 26, 2008 | CyberPower 525SL (CPS525SL) UPS System

3 Answers

CyberPower 800 AVR


Hi. I've had one since 2003 no problems. Then suddenly I come home and the power had temp gone out, come back on and the tone is constant. I hit the button, on and off. powers, then off, a couple of beeps. Nothing improved it.

I read online...the back up battery eventually wears out and can be replaced! This will happen will all units, it's normal. No biggie and less expensive than a new unit. I haven't replaced mine yet as this all coincided with a new computer purchase and I was planning on getting at least one more unit anyway, so I've just grabbed a 825 off the shelf. I'll figure out ordering a replacement battery as I have time, and perhaps order a couple of smaller units for some other applications in the house.

One of these units is cheaper than the deductible on insurance, and I've had lighting just going overhead take out 2 tv's and such in different houses, 3 different events totalling thousands. My cyberpower protected the tower and computer I'm using now, but others in the house, router, etc were destroyed. You can't risk getting those hits on your insurance if you can help it. If only I'd had one hooked up to the garage door opener, lol. $61 would have saved me $500.

Jun 21, 2008 | CyberPower (CP800AVR) UPS System

5 Answers

My computer won't boot and the CyberPower 825 AVR makes a continuous sound.


It sounds as though the UPS is not receiving power. Check that it's cable is properly plugged into the wall. Also verify that it's internal ground fault interrupter has not tripped, it's usually a little red button on the back of the unit, it should be pressed in and should stay that way, if it pops out then there is a problem with the ground of your electrical outlet. Also check that the breaker for that electrical has not tripped at your fuse box.

Since the UPS is not receiving power the batteries have discharged and that is why your computer cannot start, there is not enough juice from the UPS to boot it. That is also why it is making a noise as most UPS's sound an alarm to indicate that they are not connected to power.

There is a chance that the batteries in your UPS have gone bad or that something has become faulty in your UPS. Try plugging your computer and monitor directly to the wall bypassing the UPS to see if they work fine.

Jun 18, 2008 | CyberPower OfficePower 825AVR UPS System

1 Answer

944


I got lucky with my cyberpower 1000. Found that the black wire from the outlets to the board was not tight enough. Squeezed it a little with my pliers, and it works now. Don't worry about the on-plug falling out, you can push it in from the outside when you're done.

Mar 21, 2008 | Cybernet Systems CyberPower 625AVR...

1 Answer

Backup unable to communicate with computer


Plz check your computer without ups.If it is runing there.And wattage of ups .It seem over load or shortage of ups.Check power cable.
Hope this be of initial help/idea. Pls post back as requested, how things turned up or should you need additional information.
Good luck and kind regards.
Thank you for using FIXYA.

Mar 06, 2008 | CyberPower 1350VA UPS w AVR & LCD...

Not finding what you are looking for?
CyberPower Office Power 585AVR (obcps585avr_1) UPS System Logo

Related Topics:

388 people viewed this question

Ask a Question

Usually answered in minutes!

Top CyberPower Computers & Internet Experts

Dale Jones
Dale Jones

Level 1 Expert

21 Answers

Paul Bade

Level 3 Expert

1398 Answers

Andrew Taylor
Andrew Taylor

Level 3 Expert

12143 Answers

Are you a CyberPower Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...