Question about Hoover U5453-900 WindTunnel Supreme Bagged Upright Vacuum

1 Answer

Just not sucking like it did

Hoover windtunnel just wont pick up like it did,put in new bag,filter,when i leave filter door open seems to work a little better

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

The impella on the motor is clogged and needs to be scraped. dissasemble and its an easy fix from the bottom of the unit

Posted on Jan 23, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Hoover Turbopower 5100 . I have power, and my spinner turns. But I have no suckson power. I look for and blockage. couldn't find a thing. what's wrong?


Same problem here, after 1 month of use, it just wont suck on the bottom side, the hose works correctly with the accessories, but the bottom wont suck, the brush works fine by the way. I removed the hood checked the inside, looked for clogs and nothing.

Oct 01, 2013 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

Hoover windtunnel dirt finder light stays red. We've cleaned the elbow the roller the hose and have a clean bag. The vacuum is new only had it for 3 months.


I'm not sure about a 3 month old vac, I'd probably go the warranty route. However, for the older vacs thy start getting false positives. The sensor is simply a microphone hooked to a computer chip detecting sounds of dirt entering the bag.
To rig it to start working, you'll need to remove the tool accessory tray and elbow that enters the back of the vac, and attached to the bag. This will reveal the microphone at the elbow, and wire that runs into the bottom area of the vac. When on, a large amount of air comes from the bottom screw and area where the wires enter. My fix was to clean up the microphone contact points a little bit with a screwdriver, and then leave the vac running while putting in dampering in the hole at the bottom, and around the back of the elbow. Cotton balls and electrical tape at the bottom hole, and napkins around the outside of the elbow (wedged between the back of the vac assembly and elbow did the trick). The schematic for the vac is here: http<colon>//www<dot>vacsrus<dot>com/CartGenie/pg_U6485900<dot>asp
Look for micrphone.

May 12, 2010 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover wind tunnel not picking up properly


My turbopower 6200 does not seem to be picking up. The beater bar I don't think is working?

May 01, 2010 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Final Filter-Hoover U5399-900 WindTunnel Lite Upright Vacuum


Hi you could try these people who deal with hoover parts their number is 0845 230 6 230
they are called www.espares.co.uk
hope this helps if they dont have your part they should be able to get one or direct you to another supplier.

May 18, 2009 | Hoover U5399-900 WindTunnel Lite Upright...

1 Answer

No suction


I have found more vacuums on the way to the dump because they were full. Check. Is it full?
If not the air way is clogged.

May 17, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

My dirt finder light is not working My dirt finder red light never goes off. Have changed the bag, cleaned all filters.


take the bag out and the filter,put the coveer back on and start it up.see what the light says.if there is a clog somewhere and air is not getting into the bag it will read full.if that workd then put the filter back in and start it up.when the bag is in and hooked up does it expand when you turn it on.try putting the bag in and no cover and see what the bag does.please leave feedback

May 05, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

My self-propelled windtunnel bagless hoover does not pick up.


Remove the dirt cup.
Remove the filter screwed in at the top of the dirt cup opening.
Remove the hepa filters on the side of the machine.
Clean all filters and re-install them.

Feb 21, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

Hoover doesn't suck well


Did you check the inlet from the bottom? Take the bottom plate off, make sure that the tube(inlet)is free of any clogs. Also if the belt is stretched, then it won't drive the brush roll like it should, replace it part #38528033.

Feb 04, 2008 | Hoover U5444-900 5100 Wind Tunnel 15 Inch...

Not finding what you are looking for?
Hoover U5453-900 WindTunnel Supreme Bagged Upright Vacuum Logo

Related Topics:

278 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18408 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1467 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...