Question about Sony KDE-42XS955 42 in. Plasma HDTV

Open Question

Sony wega plasma tv has sound but no picture - Sony KDE-42XS955 42 in. Plasma HDTV

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 5 Answers

SOURCE: I have a sony wega lcd tv (bought 12/2005). The picture and sound goes off and it blinks 5 times and then pauses and blinks another 5 times. If I shut the tv off and wait a while, it works fine for th

Your lamp is getting dim. You need a new one.

Posted on May 11, 2009

  • 6 Answers

SOURCE: Sony 60" HDTV Plasma WEGA....Picture Problem

Sounds like your component cables may have come off its contact point. Check to see if your cables have become loose. Pushing them back in place should take care of that but check at the source output and the TV's input. Red Green Blue, when ever one of these 3 come out of contact the TV will produce a color hue relevant to what color remains in contact, looking faint and discolored. If you do find a loose cable connection, inspect the contact ends and squeeze lightly to restore a snug fit but don't do it to hard or you may damage the prongs.

Posted on Jan 11, 2010

jhinsincity
  • 616 Answers

SOURCE: My Sony plasma tv made a pop sound and now picture is dark.

You will need the y and x sustain boards replaced, possibly the buffers. very expensive repair. you can replace one board but its best to do all of them.

Posted on Jan 22, 2010

  • 1 Answer

SOURCE: Sony WEGA KE-42M1 sound but no picture.

i have the same problem! did you ever solve the issuE??

Posted on Mar 30, 2010

  • 8457 Answers

SOURCE: my sony grand wega 55 constantly will turn off

The LED light "LAMP" indication stay on or flashes in this problems?Yes,the projection lamp is the causes and problems.Change the projection lamp,should solved the problems.

Posted on Jan 30, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No sound or picture but lights come on sony wega plasma


Typical failure for all plasma tv's is a blown Y-sustain board. Another high failure for all tv's is dried out bulging capacitors in any of the power boards. You likely have one of these problems.

Mar 18, 2015 | Sony KDE-42XS955 42 in. Plasma HDTV

1 Answer

I need a replacementnbase stand for a sony wega 42" plasma tv


Contact Sony with the model number to see if available or not, other than that Google the model number with base to see what comes up, last resort might be to look on EBAY.

Dec 10, 2012 | Sony WEGA KE-50XBR900 50 in. HDTV-Ready...

1 Answer

6 blinks


trying to locate you to ask you if you found out the problem to your sony ke37xs910 plasma 6 blinks. i have the same tv with the same problem. does your tv set have sound but no picture.

May 05, 2010 | Sony WEGA KE-37XS910 37 in. HD-Ready...

2 Answers

Sony WEGA KE-42M1 sound but no picture.


i have the same problem! did you ever solve the issuE??

Oct 16, 2009 | Sony WEGA KE-42M1 42 in. HD-Ready Plasma...

1 Answer

Tv comes on and goes right back off


IT GAVE OUT A LOUD BANG AND NOW I HAVE NO PICTURE OR... Mosfet Transistor blow out.  Transistor K3316 or replace the Power unit supply. This problem was caused by a low power voltage. SONY SONY KE-42TS2U

Apr 01, 2009 | Sony WEGA KE-42TS2 42 in. HD-Ready Plasma...

1 Answer

No picture-Sony


did you ever get your tv repaired?

Apr 29, 2008 | Sony WEGA KE-42M1 42 in. HD-Ready Plasma...

1 Answer

Sony 60" HDTV Plasma WEGA....Picture Problem


Sounds like your component cables may have come off its contact point. Check to see if your cables have become loose. Pushing them back in place should take care of that but check at the source output and the TV's input. Red Green Blue, when ever one of these 3 come out of contact the TV will produce a color hue relevant to what color remains in contact, looking faint and discolored. If you do find a loose cable connection, inspect the contact ends and squeeze lightly to restore a snug fit but don't do it to hard or you may damage the prongs.

Oct 22, 2006 | Sony WEGA KDE-61XBR950 61 in. Plasma HDTV

3 Answers

Plasma tv vertical lines


I am getting a vertical green line on my lg 50 incs is the screen or have you a solution

Sep 03, 2006 | Sony WEGA KZ-42TS1 42 in. Plasma...

Not finding what you are looking for?
Sony KDE-42XS955 42 in. Plasma HDTV Logo

Related Topics:

25 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Televison & Video Experts

kakima

Level 3 Expert

102366 Answers

The Knight
The Knight

Level 3 Expert

74106 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1667 Answers

Are you a Sony Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...