Question about Electrolux Vacuums

1 Answer

Z8220 STOPS WORKING HEPA FILTER LIGHT FLASHING & NEW FILTERS INSTALLED

I have replaced hepa filters & still the sensors are registering that they are dirty have blown out & clean any area of the vacuum I can get to & still no joy

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 91 Answers

Check your hose for a clog, id even check from where brushroll is at bottom to the end of hose. sounds like that could be your problem.

Posted on Jan 08, 2013

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

TheMobilian
  • 8220 Answers

SOURCE: burning smell coming from vacuum

use a penny to turn the 2 screws on top a quater turn then fold down the vacuum and lift up the cover and you will have access to the belt. Clean the small hepa filter with soapy water. their may be 2 of them. The cannnister filters need to be shaken but not washed. Good luck.

Posted on Apr 09, 2009

  • 8404 Answers

SOURCE: how do I clean the lifetime hepa filter

Check with the manufacturer. I have always had good response from Hoover.

Posted on Sep 23, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Hoover Elite Rewind just lost power while vacuuming and wont power back on?


Hi! It appears your thermal protector sensor has kicked in and caused your cleaner to power off. This is usually due to a clog or a filter that needs to be cleaned or replaced. Try these steps to get your vacuum back up & running!

1. Remove the dirt cup canister from the vacuum. Twist off the dirt cup lid.
2. Remove the primary foam filter. Hold filter under running water until water runs clear. Squeeze out the filter and allow 24 hours to air dry.
3. Slide the Hepa filter out. Tap the filter against the trash can until dirt stops falling. Replace the Hepa filter. (Do not wash)
4. Remove the hose from both ends. Use a broom stick to gently loosen and clear any clogs from hose.
5. Use a wooden spoon or something similar to loosen and remove any clogs from the lower hose.

Your vacuum should turn back on after it cools off, this can take up to an hour. Hope this helps!

Oct 07, 2014 | Hoover Vacuums

1 Answer

My Hoover Elite Rewind just lost power while vacuuming and won't power back on?


Hi! It appears your thermal protector sensor has kicked in and caused your cleaner to power off. This is usually due to a clog or a filter that needs to be cleaned or replaced. Try these steps to get your vacuum back up & running!

1. Remove the dirt cup canister from the vacuum. Twist off the dirt cup lid.
2. Remove the primary foam filter. Hold filter under running water until water runs clear. Squeeze out the filter and allow 24 hours to air dry.
3. Slide the Hepa filter out. Tap the filter against the trash can until dirt stops falling. Replace the Hepa filter. (Do not wash)
4. Remove the hose from both ends. Use a broom stick to gently loosen and clear any clogs from hose.
5. Use a wooden spoon or something similar to loosen and remove any clogs from the lower hose.

Your vacuum should turn back on after it cools off, this can take up to an hour. Hope this helps!

Oct 07, 2014 | Hoover Vacuums

1 Answer

Why does it shut off after 10 minutes?


Hi Will! It appears your thermal protector sensor has kicked in and caused your cleaner to power off. This is usually due to a clog or a filter that needs to be cleaned or replaced. Try these steps to get your vacuum back up & running!

1. Remove the dirt cup canister from the vacuum. Twist off the dirt cup lid.
2. Remove the primary foam filter. Hold filter under running water until water runs clear. Allow 24 hours to air dry. If the filter is really dirty it may need to be replaced.
3. Slide the Hepa filter out. Tap the filter against the trash can until dirt stops falling. Replace the Hepa filter. (Do not wash)
4. Remove the hose from both ends. Use a broom stick to gently loosen and clear any clogs from hose.
5. Use a wooden spoon or something similar to loosen and remove any clogs from the lower hose.

Your vacuum should turn back on after it cools off, this can take up to an hour. Hope this helps!

Jul 27, 2014 | Hoover Nano Cyclonic Compact Bagless...

1 Answer

Why does the thermal protection keep shutting the vacuum off?


Hi! It appears your thermal protector sensor has kicked in and caused your cleaner to power off. This is usually due to a clog or a filter that needs to be cleaned or replaced. Try these steps to get your vacuum back up & running!

1. Remove the dirt cup canister from the vacuum. Remove the dirt cup lid.
2. Remove the primary foam filter. Clean the filter as suggested by the owner's manual.
3. Slide the Hepa filter out. Tap the filter against the trash can until dirt stops falling. Replace the Hepa filter. (Do not wash) Filters should be replaced once a year.
4. Remove the hose from both ends. Use a broom stick to gently loosen and clear any clogs from hose.
5. Use a wooden spoon or something similar to loosen and remove any clogs from the lower hose.

Your vacuum should turn back on after it cools off, this can take up to an hour. Hope this helps!

Jun 28, 2014 | Hoover Vacuums

1 Answer

Blows hepa filter from mounting


I have seen generic filters do this. Be sure to use original Miele filters. The generics are a few dollars cheaper to buy but you end up with an inferior quality filter that could cause other problems by continued use. same is true with bags.

A clogged filter may also do this. Miele vacuums are very tightly sealed, the exhaust air has to come out. If the filter is clogged, the pressure could pop the filter out, HEPA filters are suggested to change out about every 50 hours, for most people this is between 1 - 1.5 years.

We had a Miele come in for service the other day with the same complaint, installed filter was a generic, customer said it was a new filter just installed. We replaced with an original filter and problem ceased.

If you need any help feel free to contact me.

Tim
TheVacCenter.com

Mar 16, 2013 | Miele CatAndDog700 Bagged Canister Vacuum

1 Answer

Subject: Eureka Tru Hepa Wirlwind Amps Model 4383. Working fine then just stopped. Later worked fine again? What is/was the problem? Does it need a new filter?? also has the # 0108017529 on machine


I'm not sure all machines are the same, but many have thermal overloads on the motor that can only be reset upon cooling, so wait 30 minutes and try again.
Secondly, my vac has 3 filters, one in the dust tray that you empty, one under where that dust collector installs and the HEPA filter on the back.
Ensure that all three are cleaned.
Gary

Feb 12, 2011 | Eureka 7619AT Vacuum

1 Answer

My Miele Silver Moon "Reset" light is blinking. What do I do?


Greetings from GoVacuum,

Ahh yes, the Silver Moon. One of Miele's best made vacuums ever! So good that out of all the different vacuums that I could of chose for my home, the Miele S558 Silver Moon was the one I chose.

When you're Reset button is flashing, this simply means that it's time to replace the HEPA filter on your vacuum cleaner. Miele included this feature on their upper end models to alert the user when their filter needed to be changed.

The Miele Silver Moon uses Genuine Miele S-Class HEPA Filter for S300i/S600i, and Miele S7 Uprights. Miele Part # 04854915 (replaces 04854911) Which can be purchased from GoVacuum for $52.95 with free shipping.

Once you have installed the new HEPA filter, simply press down on the flashing Reset button to restart the 50 hour internal timer inside. Miele recommends to replace this filter after every 50 hours of vacuuming.

If this answer was helpful, please click on the helpful Thumbs Up icons in the top right hand corner of this Solution.

If you have a repair that you would like explained, please check out our Q & A website, askgovacuum.com.

Thank you very much,

Chris Jones
GoVacuum.com

Feb 19, 2010 | Miele s558 Silver Moon Vacuum

1 Answer

My HEPA filter get's blown off of the vacuum when I vacuum. I just got all new filters and a new brush roll. Could something be clogging in the inside?


There should be a cover that closes over the HEPA filter. If the cover is missing, or is there, but does not snap closed, then either snap it closed, or replace the cover.
If something was clogged inside, then the HEPA filter would be less prone to being blown off. But, it sounds like the filter or filter cover is not being correctly installed. The manual is not clear on whether the cover snaps closed.

Dec 10, 2009 | Eureka Altima Upright Vacuum Model 2996AVS...

2 Answers

Hoover Z-400 - Hepa Filter


These filters should be changed at least once a year, they get clogged up and won't clean out. So I would try a new filter and go from there, make sure there are no clogs in the hose and down below where the dirt inlet is.

Feb 20, 2008 | Vacuums

Not finding what you are looking for?
Vacuums Logo

Related Topics:

55 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

yadayada
yadayada

Level 3 Expert

75066 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...