Question about Pioneer GM-D510M Car Audio Amplifier

1 Answer

Amp trouble my amp wont turn on i looked at the wires and the fuses they are all fine. everything is connected it just shut off 2 days ago and wont turn on. what could be the problem.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 105 Answers
Re: amp trouble

Check the remote turn on line from your deck & make sure there is 12 volts on it when everything is on. Check the ground, too.

Posted on Jul 15, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

JBL amp, worked fine untill 2 days ago. protection light on..

might have roasted your speakers voice coils a little which may be sending the amp into protect mode throw a speaker on it that you know works and if it doesnt trigger the protect circuit then you probably have a blown or almost sub.

Jan 02, 2010 | JBL BP1200.1 Car Audio Amplifier

1 Answer

Amp will not power on at all all of a sudden, fuses look fine

Hello schapman81,

You do not say if there are any indications or errors displayed.

I'd recommend you follow the troubleshooting steps here starting at Step 2 (B+ and Remote Voltage:). This should tell you if there's a problem in the wiring or if the amp itself has failed.

Hope this helps.

May 09, 2009 | Crunch Powerzone P2200 Car Audio Amplifier

1 Answer

Mrv F345 power cut out and now the screen flashes blue

disconnect all of the speaker wires at the amp and turn your system on -if the amp stays on then you likely have a roasted coil in one of your speakers somewhere and causing a short which is shutting your amp down into protection mode-if the amp wont stay on with nothing connected to it then you have probably roasted something inside the amp and uhhh good luck bro

May 09, 2009 | Alpine MRV-F345 Car Audio Amplifier

1 Answer

My sub flickers on and off in my truck!!!

could be a number of things loose wires bad ground fuse on its way out or internal problems

Feb 13, 2009 | Profile BAJA HA700M Car Audio Amplifier

1 Answer

Kenwood 9102d wont power on

YOu might have burned out the inner fuse. Better yet the source connect...

Nov 06, 2008 | Kenwood KAC-9102D Car Audio Amplifier

3 Answers

Jl audio 250/1 thermal light

Disconnect all speaker wires from the amp and disconnect the RCA cables from the amp. If it still goes into protect mode, use a multimeter to confirm that you have 12v on the B+ and remote terminals. Place the black meter probe on the ground terminal of the amp when measuring the voltage. If the voltage is sufficient and the amp goes into protect, it will have to be repaired. JL only accepts repairs from authorized dealers. You'll have to find one in your area or you'll have to find a repair shop willing to work on JL amps.

Let me know if you have any other questions.

Oct 15, 2008 | Jl Audio 250/1 Car Audio Amplifier

1 Answer

Car amplifier wont turn on

Your best bet is to call Alpine directly at: 1-800-832-4101

Jul 15, 2008 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

2 Answers

My amp wont turn on

The reason it used to cut-off at 60% volume as you said before,
Is probably due to the "protection circuit mode" being tripped.

You can try resetting it by turning off your CD player ,removing the Batt( + ) and Gnd ( - ) terminals from the amp for a short period. Reconnect them Allow the amp to receive power but not switch on (keep cd player/remote power source off)

If you dont know how to wire the CD player to control the amps power status , the easiest way is to connect the 'power antenna' or similar low voltage throughput wire from the head-unit to the amp's Remote terminal.

My old amp did the same thing ,and would need to be powered off/on before resuming sound output, sometimes I had lots of trouble with the protect mode staying on , even with little or no sound output from headunit.

Jul 14, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer


The best I advice I could give you right now is to check all of your connections. Check your ground. make sure it is a solid connection to bare metal. I wouldn't recommend using an existing bolt on the car like a strut tower bolt. If you do clean the surface to bare metal then attach the ground. If you check all your connections, make sure nothing shorted then you might have a problem with the amp. What impedance are you running your subs at and what impedance is your amp capable of? My brother had 2 12" subs wired to 2 OHMs a piece wired together to make 1 OHM into a 2 OHM stable amp. This made his amp shut off and blow fuses. So, check impedances. I hope I could help.
-Andrew Hawkins

Mar 18, 2008 | AudioBahn A2150HCT Car Audio Amplifier

1 Answer

Amp wont turn on

It's possible the ground is not a good connection. Sometimes it may look good but dirt or corrosion builds up resistance creating a voltage drop where the wire is grounded to the frame.

Jan 26, 2008 | Jl Audio E1200 Car Audio Amplifier

Not finding what you are looking for?
Pioneer GM-D510M Car Audio Amplifier Logo

Related Topics:

94 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pioneer Car Amplifiers Experts

Lawrence Oravetz

Level 3 Expert

7235 Answers

David Payne
David Payne

Level 3 Expert

13437 Answers

Are you a Pioneer Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides