Question about Vacuums

Open Question

Can i remove the hose from the base on hoover turbopower 4500

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

reddevil6
  • 1673 Answers

SOURCE: hoover belt replacement

Turn vac. over, remove the buttom plate over the brush roll, then at the bottom edge of the top cover, using a flat blade screwdriver, insert into the slots and pry up to unlock the tabs, then the top cover will come off. Put the belt on the brush roll and feed the belt thru the opening and put stretch it over the motor shaft. Put the top cover back on and push to lock the tabs.

Posted on Jan 29, 2008

  • 1214 Answers

SOURCE: I can't seem to find

It's on the Hoover website, I just looked it up.

www.hoover.com F6213900

Let me know if you need anything else.

Posted on Feb 01, 2009

  • 190 Answers

SOURCE: How to change the belt in the Hoover TurboPower

Please see pages 11 thru 13 on the User Manual.
You may use this link to access:
http://www.hoover.com/pdfs/manuals/U5046930.pdf

Posted on Oct 03, 2009

Vac Belts
  • 701 Answers

SOURCE: how to change a belt on a hoover turbopower 1700

You can get the replacement belt you need and view the manual with instructions here:

Hoover U5046-930 Belt and Manual

Posted on Dec 06, 2009

  • 2 Answers

SOURCE: Hoover Turbopower Wind Tunnel V2 - clogged -

i took off the bottom black piece...removed the brushes ..took a coathanger and went down in silver dollar sized hole and got a big clog out...i also removed the black hose on the back at the very bottom...and used a coathanger up in there as well. mine is picking up some..but ive still gotta clog myself...i was hoping to find an answer here...-_-

Posted on Feb 10, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Help - vacuum cleaner heating up and stopped working


Check for clogs in the hose and suction path. Replace bag and filters. The vac is designed to turn off when over heated.

Sep 10, 2014 | Hoover U59 WindTunnel TurboPOWER Bagged...

1 Answer

I have a Hoover Turbopower 5100 . I have power, and my spinner turns. But I have no suckson power. I look for and blockage. couldn't find a thing. what's wrong?


Same problem here, after 1 month of use, it just wont suck on the bottom side, the hose works correctly with the accessories, but the bottom wont suck, the brush works fine by the way. I removed the hood checked the inside, looked for clogs and nothing.

Oct 01, 2013 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

When I switch it on the plastic compartment which holds the bag starts to be sucked in towards the bag and there is no suction at the end of the hose


Your Hoover U5076 has a clog. Fist unplug the vacuum from the wall socket. Remove the attachement hose from the door on the head, close the door. Remove the screw just below the main bag compartment, with a phillips or flat head screw driver. Be sure not to loose the nut in back. Hold the base down with your foot and pull up on the handle to sperate the two pieces. The lower portion revieled is the exhaust for the dirt from the motor and that is where your clog should be. Use a flat head screw drive to remove what is there so you have a clean path. If there is no clog there check the up portion that you pulled off for a clog, you may need a coat hanger to dislodge the clog. Once the path way is clear you can reassemble the vacuum and it will work fine.

Apr 20, 2010 | Hoover Turbopower Dual U5076 Vacuum

1 Answer

The Hoover Steamvac Widepath will NOT pick up water. The dispenser with cleaner DOES have water. The TANK that would receive the dirty water is NOT full. All tanks are on properly and the machine will...


Sounds like a clogged air path (no vacuum action) from the floor pick-up to the collection tank. Take the tanks off and deal with the vacuum problem alone. The collection tank should have a air exit vent--is it clear? Check the interior hose that you repaired--is it clogged? Remove the bottom plate and inspect the air path from it. Because this machine deals with water, clogs can become like concrete! Hope this helps!

Apr 12, 2010 | Hoover F6213-900 SteamVac Agility...

2 Answers

My Hoover Steamvac Widepath will NOT pickup the water after dispensing. I checked the hose inside the cleaner, there was a cut in the hose so I put electrical tape and completely sealed the cut. Still...


Hi, empty the recovery tank of the Hoover SteamVac if the cleaner fails to pick up dirt. Once the tank is full, many Hoover models have an automatic shutoff that stops the cleaner. If the does not resolve the pickup issue, check the hose of the machine and remove any blockage.

Examine the water tank if water does not dispense from the SteamVac. It could be empty and need of a refill, or you may not have locked the dispenser firmly in place. The detergent tank should also be looked at and filled if empty.

Take care

Apr 12, 2010 | Hoover F6213-900 SteamVac Agility...

1 Answer

Not picking dirt and small items, doesnt to be working well.


make sure bag is empty and there isnt any cloggs in the hose or nozzle. If that is good, change the belt. these should be replaced every 6-12 months and when something gets caught in the brushroll

Apr 08, 2010 | Hoover U5264-930 TurboPower Bagged Upright...

1 Answer

Hoover Turbopower Wind Tunnel V2 - clogged - cannot find a way to get at the clog - HELP!


i took off the bottom black piece...removed the brushes ..took a coathanger and went down in silver dollar sized hole and got a big clog out...i also removed the black hose on the back at the very bottom...and used a coathanger up in there as well. mine is picking up some..but ive still gotta clog myself...i was hoping to find an answer here...-_-

Jan 13, 2010 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

I can't seem to find the direction guide for my Hoover F6213-900 Steam Vac PowerMax TurboPOWER


It's on the Hoover website, I just looked it up.

www.hoover.com F6213900

Let me know if you need anything else.

Feb 01, 2009 | Hoover F6213-900 SteamVac Agility...

1 Answer

Won't work cleaning tools


There is a clog somewhere.

Most likely at any bends or where the hose enters the main body of the vac.

Make sure it's unplugged.
Romove the hose, stretch it out straight and see if you can see through it.

If there arer any hard piped bends try running a pipe cleaner through it to see where the blockage is.

Again, it's likely where the hose base meets the vac housing.

Needle nose pliers com in handy for pulling out string, hair, rig fibers pet fur etc.

Dec 06, 2008 | Hoover U5264-930 TurboPower Bagged Upright...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18392 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...