Question about Hitachi 42EDT41 42 in. HD-Ready Plasma Television

1 Answer

No picture i have the schematic. i have -vy (75volts) but no vsc or vsetup voltage on the ysus board. Can you help me trace source (can email you the schem/manual). The image that i get (color verticals) does not match manual's image for bad ysus board. Looks like the cable from formator to pwb. visual check cable ok(could still be bad). need to look at signals to pwb too.

Posted by on

  • tazz1243 Dec 26, 2007

    i have the same problem

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 48 Answers

Send an email with the schematic and I'll try to point you in the right direction.

Posted on Jun 29, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Vy and vsc voltage are not stable what to do??


The main power supply regulator section circuit fault. Either it will be a separate board, or the part of main board. Check and replace damaged component/s at its main power regulator [SMPS] section circuit. Contact any service technician. If you wish to get some details; check the site linked here. Pull up older posts.
http://electronicshelponline.blogspot.com/
It will be best to replace the power supply regulator board as card basis rather than making "Surgery" to it; which usually will make loss for both money and time. Even though you can make it right, it will cost around an amount equal to the cost of a new board; including the cost of (spare parts + service charge) More to say, most of the spare parts to it will be difficult to get from open electronic spare part market. This is true to most of the flat panel TV power supply boards; irrespective of its brand and screen size.
Search the site by type in the "brand name" to your device; in the "Search box at the top right of the display window of the Homepage" to get gathered related posts.

Sep 29, 2016 | Televison & Video

1 Answer

Tv no picture but sound


hi, mate,

when you reparing you have to do meassurement not just swap. you waste your too much money like this! how much va, vs, vsc..especially vsc?

Feb 01, 2014 | Televison & Video

1 Answer

Picture went out on Vizio P50HDM


Check you voltages before just swapping out boards. Although a YSUS is common for no picture, so is your upper and lower Y Buffer boards or the panel itself. Check youe -VSC voltage. Does it look like it is being loaded down? If so then your YSUS is not the problem. You can run the set with just the upper or lower Y Buffer boards untill the load is gone. That will let you know wich board to replace.

Jun 20, 2012 | Vizio Televison & Video

1 Answer

The TV suddenly does not have a picture. It has sound and you can turn it over but no picture. We have checked the aerial but this seems ok.


what you need for this problem is trouble shooting since you already checked the aerial. if you have an idea in repairing or trouble shooting you can fix the problem. first you need to open the back door to perform trouble shooting, then check all the board inside observe the physical appearance of its part, smell burnt parts and connectors. and then look for the Y sustain board and turn on the power check the 4 voltage used Va, Vs, -Vy, Vsc if present use digital tester for good accuracy. then if their is no problem with the supply and still doesn't picture goes on might be in the Y sustain board was the problem. check the FET if fail then the ceramic fuse if busted.

Apr 25, 2011 | Televison & Video

1 Answer

While checking Vscan voltages on my LG du-42px12x picture died.


I have the same problem the pic went out but have sound. where do i go to get the Yboard? do i need a special number off of it or something? I took it to repair shop and he said it would be like 500 dollarss to repair. but i see all kind of yboards on ebay for like 150?? how do I know what one to buy?

Mar 15, 2010 | LG DU-42PX12XC 42 in. Plasma HDTV

1 Answer

To make a long story short originally bought the LG du-42px12x with a bad ysus board(no picture just sound) replaced the ysus now the picture and sound work great but there are colorful dots all over the...


Sounds like the y sus was blown out but what cause it. Were you careful when you were checking voltages? As long as you didn't short 2 components together, your y sus should be fine. Unless the y buffer up and/or down blew them out. Even the panel could blow it.

Basically you need a scope to adjust the ramps and everything. You can adjust VA and VS with a meter. If you don't have access to a scope, then just start changing the ramps etc by eye. It might take a little bit to get but eventually you'll get it.

Mar 13, 2010 | LG DU-42PX12XC 42 in. Plasma HDTV

2 Answers

Vizio p50hdm red flashing pixels


Try to adjust the Vs voltage on the power supply by lower it a little bit or increase it a little bit. It will help to decrease the red pixel flashing.

Apr 24, 2009 | V, Inc. Vizio P50HD Plasma Television

1 Answer

Vizio P50HDM is dead


Measure the -Vy and Vsc on the Y Sus board. If there are no voltage reading then you have to replace both of them.

Hope this will help!

Feb 17, 2009 | Vizio P50HDTV10A 50 in. Plasma HDTV

2 Answers

Plasma no picture, fades to black from startup logo


UPDATE:
I finally isolated the problem, the problem has to do with the Y SUSTAINER BOARD not receiving enough/necessary voltage when turned on, while initially thinking it was just the yboard was the problem, i replaced the Y sus board with no success, with only further diagnosis, i discovered the board voltages coming from the powersupply, there are 5 voltages that relate to the Y sustainer board, VA, VSC, VS, VE, VSET. they all supply a certain voltages that all have to be supply the correct voltage in order for the y sustainer board to be working, well guess what, the VA line, which for my set needs 70volts, which upon startup quickly drops from 75volts to a jumpy 8.5-9.5 volts, which of course is nowhere near the 70 volts needed, so this quick drop in voltage is directly related to the screen fade upon startup, i found the problem now the real problem is finding a replacement power supply. hope this helsp anyone with similar issues.

Mar 02, 2008 | Dell W4201C 42 in. Plasma HDTV

1 Answer

Missing voltage?


alot of voltage adjustments at that high voltage are likely from another source that develops it like the the swith-mode power supply upstream on power supply board that feeds it ..look for burnt resistors in this case.. I bet your in the wrong circuit but u can test all wires and pins coming in for 200 volts. get a schamatic of it and find a good tech if u dont know what i am saying. ty crazylarry

Jun 27, 2007 | Hitachi 42EDT41 42 in. HD-Ready Plasma...

Not finding what you are looking for?
Hitachi 42EDT41 42 in. HD-Ready Plasma Television Logo

Related Topics:

80 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hitachi Televison & Video Experts

Jaime Hernandez

Level 3 Expert

2336 Answers

The Knight
The Knight

Level 3 Expert

75846 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hitachi Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...