Question about Eureka Vacuums

1 Answer

Motor runs fine and hosed not clogged will not pickup dirt

Took out filters and tried it without filters. There is no suctions. The belt is turning fine. Plenty of air is being pushed out the side where the side filter is located.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 32 Answers

Check your fan for damaged or worn blades, then following the flow towards the bag check for blockage. Does your bag inflate when the vacuum is on? If so, it is less likely that you have blockage, than it is that there is an issue with the fan.

Posted on Jan 19, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Upright Vax vacuum has no suction or hadly none from the base. Belt, motor, hose all working fine


yes turn it upside down and look real close at the area where dirt goes .they do plug up when too much big stuff gets in there .

Jun 15, 2015 | Vax Vacuums

1 Answer

My Miele S3141 canister began acting strange this morning. No suction...so I took off the hose and checked for blockage, (nothing). Now I can't get the hose back on the canister. It just slips ar


see this causes and fix it. God bless you
Air filter:
If the vacuum cleaner won't pick up dirt and has no suction the air filter might be clogged. Remove the filter and either clean or replace it as needed.
Exhaust Filter If the vacuum cleaner won't pick up and has no suction the exhaust filter might be clogged. Remove and clean the filter, replace it if its torn or damaged.


Vacuum Hose If the vacuum cleaner won't pick up and has no suction the vacuum hose might be clogged. Remove the hose from the vacuum cleaner, stretch it out straight, shine a bright flashlight in one end and try to see light through it. If no light can be seen, use something to run through the hose and free up the obstruction.
Vacuum Bag If the vacuum cleaner won't pick up and has no suction the vacuum bag might be full. Clean or replace the bag as recommended by the manufacturer.

Dust Cup AssemblyIf the vacuum cleaner won't pick up and has no suction the dust cup assembly might not be installed tightly, or it might be cracked or broken. The dust cup must seal tightly in order to produce the right amount of suction. If it is cracked or broken, replace it. Most glues and adhesives will not successfully seal the crack.
Blower Wheel If the vacuum cleaner won't pick up and there is no suction, the blower wheel might be jammed or broken. Check the blower wheel to be certain it turns freely. If it doesn't, check to see if there is anything rubbing against it. If not, but it's hard to turn, the motor is most likely the problem.
9_28_2012_11_32_31_am.jpeg9_28_2012_11_32_53_am.jpg

Sep 27, 2012 | Vacuums

1 Answer

Bag was not on good, resulted in dust,dirt, dog hair everywhere...have cleaned pretty thoroughly but vacuum does not have any suction. After taking apart did find that the larger wide belt is broke but I...


Greetings from GoVacuum,

There are two things that you should check on this vacuum after running it without a bag inside. The first thing you should check is the filter that is underneath of the vacuum bag. This filter is underneath of a bracket, and the bracket can be removed by pulling straight up on the bracket. The bracket and filter are directly below the vacuum bag inside the vacuum bag housing. If the machine was run without a bag (or the bag fell off) then this filter is most likely going to be extremely clogged. You can simly remove the filter, and run it under hot water until clean. Make sure the filter is 100% completely dry before putting it back in the vacuum and using it. Running the vacuum with a wet filter will destroy your motor.

Now in terms of the belts. Where as the belts don't directly control the suction of the vacuum cleaner, they certainly facilitate the pick up of dirt and debris on the floor. Many people assume that since the vacuum is not picking up from the floor, then the vacuum doesn't have suction. You can test this by pulling out the attachment hose and feeling for suction, is there suction at the end of the hose? If yes, then the reason the vacuum is not picking up on the floor is because of the belts. If you don't have suction at the end of the hose, then you have a clog, some where or a dirty filter.

The belts actually are what spin the brush, and the brush basically sweeps the carpet, and throws the dirt and debris into the suction port, and when the dirt and debris are near the suction port, the suction then takes over and takes it to the bag.

There are two belts on this model, it's best to replace both of these belts at the same time. If you replace just one, then the other belt will wear out quicker. It's always best to replace these two belts in conjunction.

The two belts that are used on this vacuum are:

Hoover Windtunnel V-Belt Part 38528034

Hoover Windtunnel Flat Belt, Hoover Part 38528035

Once you have the belts, and you're ready to replace them, here's a great video that we shot here at Govacuum.com that shows you exactly how to replace these belts, as well as some basic maintenance on your roller brush;





I really hope that my repair solution was helpful to you in fixing your vacuum cleaner. If you have any further questions about this repair, or any repair, feel free to contact me at chris.jones@govacuum.com, or request a clarification here on Fixya.

If you did find this repair solution helpful, please kindly rate this repair helpful by clicking the 4 Thumbs Up Icons in the top right hand corner of this solution.

Thank you very much,

Chris Jones
GoVacuum.com

Mar 19, 2010 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Low suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Dirt Devil Vision Turbo W/Bonus Upright...

1 Answer

Motor runs fine and hose not clogged will not pickup dirt


This may sound silly, but have you checked the belt? A lot of Eureka vacuums use the vac motor to run the brush, and if the brush is not running the vacuum won't pick up. Another thing to check is the condition of the fan blades.. if they get worn they will push air out of the exhaust ports, but not push enough air to pull the dirt into the vacuum bag. Another thing to check is the length of the bristles on the brush... you can change a lot of the bristle strips and save the cost of a whole brush roll.. All of these fixes are under $10.00 (Belt: $1-2, Brush Strip $3-6, Fan $5-10) at most places.

Jan 19, 2009 | Eureka Vacuums

1 Answer

Motor works, but no suction! what do you think?


No suction usually means a clog somewhere or bad filters. The hose and/or the dirt inlet by the brush roll may be coulded. The belt may have stretched enough to not turn the brush roll under load and that can seem like no suction. The worst is the motor is running at full speed, which would mean replacing the motor.

Apr 24, 2008 | Vacuums

1 Answer

Cloged, will not pickup Hose also cloged no suction


Generic problem for all Vacuums
Clogged, will not pickup Hose
Clogged, will not pickup Hose also clogged no suction

I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
I’m not sure if you have a canister or an upright but there are thing you can check on both machines, canisters – you can check the suction from the end of the hose and work your way back to the canister, start with the end of the hose, then remove the hose and check the suction on the vacuum – most clogs are in the hose – if you have a hose clog run a steel ball thru the hose to see if goes thru all the way if it does than check the bad and the filter, if those are ok you may have a bad motor. If it is an upright, make sure the height adjustment is correct and is adjusted correctly, then use the steel ball and run it thru the attachment hose to see if that is blocked or clogged. Then check the belt and the extension wands to see if there is a blockage there as well, if you have good brushes and the tone changes from high to low and the brushes are actually hitting the floor, then you may have a motor problem and then you might have to replace the motor or fan assm. I hope this was helpful.

Apr 21, 2008 | Vacuums

2 Answers

Loss of suction in my Hoover Windtunnel bagless selfpropelled upright


Did you check the dirt inlet by the brush roll, filters ok, they should be replaced once a year. Belts can look fine, but if they are a few months old, I am sure they have stretched and the brush roll will not turn like it should under load. It is possible that the motor isn't running up to speed, thereby reducing suction.

Mar 11, 2008 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Hoover Windtunnel


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is a filter at the bottom where the dirt cup (and bag) is, check it also.

Dec 28, 2007 | Vacuums

4 Answers

Dirt devil mvp not sucking


Could be bad filters, is there suction at the end of the hose. That will tell you which direction to start looking. If no suction at hose end, then filters could be the problem. If you have suction, then the problem is down lower, dirt inlet is clogged, if belt has never been changed, then I am sure it has stretch to the point that under load it doesn't turn like it should. Could even be that although the motor is running, it may be running at a slower speed, in which case it would have to be replaced.

Oct 14, 2007 | Dirt Devil 12 Amp HEPA Filter Vacuum...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

64 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eureka Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18304 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Jim Parker
Jim Parker

Level 3 Expert

1040 Answers

Are you an Eureka Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...