Question about Little Giant Plumbing

Open Question

Little Giant pump model 977459 (581507) sounds like the motor is frozen, you can hear the motor trying, but no blades spinning.

Little Giant pump model 977459 (581507). Can it be fixed/rebuilt? How do you oil the pump (as it suggests, the pump and tank were given to me me so did not know about the oiling)

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

reg501
  • 413 Answers

SOURCE: Burning Smell when spinning

8 yrs old....The LATs were the best models for Maytag...Maybe it's time to replace the belt..Slipping belts smell bad.

Posted on Jun 10, 2008

  • 1 Answer

SOURCE: Blade not turning

I am looking at the same problem, the aluminum bottom part (on blade assembly) that contacts the black rubber on the motor part is no longer "attached" to shaft that drives the blade on top side. So like said the top and bottom "turn freely" but independent of each other.... not good, they should be one piece. Ebay does not have a replacement for this original part in my case and would have to buy a complete jar assembly. I will attempt to fix the original one by cutting a slot through aluminum and center shaft and dropping in a pin to make them turn together, with a spot of weld to hold pin to shaft... not sure how long this will last.... unless somene has a better idea to fix it?

Posted on Oct 29, 2008

bunnydawg
  • 5158 Answers

SOURCE: Oil pressure light comes on then goes off in 2003 VW Passat.

it's expensive but not as expensive as replacing the engine... was the oil pressure checked ?

Robert

Posted on Jan 28, 2009

  • 10 Answers

SOURCE: Low oil pressure light comes on and goes off

the noise is the chain tensioner in the cylinder head between the two camshafts. it is a job for a proffesional shop. the 1.8t passats had an oiling problem and were fixed with a larger oil filter. some times you have to remove the oilpan and replace the oil pickup tube.

Posted on Feb 15, 2009

  • 76 Answers

SOURCE: husqvarna 235 oil not getting to chain

try using thinner oil

Posted on Jul 16, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have an external little giant water pump 3qxmd nothing wrong with pump motor hums not turning can ot be fixed it it 110v


Unplug and try freeing up the impeller by hand. You may have to remove bottom of pump to gain access.

Feb 15, 2017 | Little Giant Plumbing

1 Answer

Who makes the motors for little giant pumps 3-MDQX-SC


Try taking it to a Grainger's store or go online to Graingers.com. There are usually enough numbers on the motor to find a match if there is one available.

Oct 21, 2014 | Little Giant 581507 3-MDQX-SC Magnetic...

1 Answer

Waterfall pump hums but won't pump


this sure sounds if the impeller is blocked and not being able to turn ,Dont let it run this way , can dammage motor of pump , remove intake cover (unplugged) and wash out with garden hose real well , see if impeller (black plastic blade) can turn with your finger (unplugged) , should move easy ! this might be an indacation of need for a filter on pump inlet !!!

Oct 14, 2012 | Little Giant Submersible Fountain Pump

1 Answer

Only way to shut off Little Giant sump pump is to unplug it. What is making it run all the time?


Assuming that your pump has a built in float switch, I would suggest that the float switch is frozen, stuck or damaged. If you have an underwater pump that does not have such a switch then it probably is designed to only be used manually. I have a little giant pump which is designed to go underwater but must be plugged in to use and unplugged to stop. I'm assuming you have had this pump a while and in the past has always worked automatically. Again , if yours is automatic, it's the switch. Unless it's a simple thing like a frozen arm, I doubt you can fix it unless you can replace the entire waterproof assembly without tearing into it. It must remain waterproof to be electrically safe.
You may find that only a factory repair will be the proper solution.
Nimsgame

Feb 15, 2011 | Little Giant 6 Cia, 1/3 Hp, 45 Gpm, 230V...

1 Answer

Fountain pump motor runs but no pressure to push water


You can try to force prime with a garden hose. Put the hose in ether side suction or discharge.

Jul 07, 2010 | Little Giant Submersible Fountain Pump

1 Answer

My little giant water pump model 4mdsc has three


Sounds like you may have a 220V pump. So you need to confirm that this is a 110V pump and not a 220V pump. There should be a label or more info on line with any other info on the label. If you can confirm that this is a 110V pump, then put a standard plug on the cord - the green is ground and the other two can be wired to either blade of the plug. If you do have a 220V pump and you connect it to 110V anyway, the pump will perform poorly and will probably overheat and fail.

Jun 25, 2010 | Little Giant SPS25 Water Removal System...

1 Answer

Pump stopped


Possibly just blocked up, try taking it apart, and see if anything is stuck in the "Impeller". If it isn't that then it may be the Motor, or the Connections to it.

Feb 10, 2010 | Little Giant 3 Mdqx Sc 1100 Gph, 1/15 Hp...

1 Answer

Little Giant Pump - dialectic oil to use


ck your local yellow pages for an electric motor repair shop they should be able to get silicone oil to add , but in a pinch ive used full synthhic auto transmission oil that works too

Jul 29, 2009 | Little Giant Submersible Sump Pump, 1/4 Hp

1 Answer

Affinity washer not spinning


It doesn't pump or spin If it doesn't pump water out or spin, check to see if the motor is running, then proceed as follows:

  • If the motor is running, your washer probably has a frozen pump pulley or a broken pump belt. To check the pulley, remove the pump from the washer and try to rotate the pulley manually. If it doesn't turn freely--if it's frozen or stiff--replace it. If the pump belt is broken or looks quite worn, replace it--but be sure to check the pump pulley before you change the belt.

  • If the motor isn't running, the lid switch may be defective. If so, the washing machine can't spin and may not function at all. The switch is inside the washing machine main housing near the door frame. Often you have to raise or open the top or front of the washing machine to get to the switch. If it's defective, you need to replace it.

Jul 12, 2008 | Frigidaire Affinity ATF7000E Front Load...

Not finding what you are looking for?
Plumbing Logo

Related Topics:

92 people viewed this question

Ask a Question

Usually answered in minutes!

Top Little Giant Plumbing Experts

JOHN LAPIER

Level 3 Expert

2422 Answers

Mack Baxter

Level 3 Expert

381 Answers

Tom Chichester

Level 3 Expert

33294 Answers

Are you a Little Giant Plumbing Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...