Question about Bissell SpotBot Robotic Wet/Dry Vacuum

1 Answer

SPOT BOT NO SUCTION

No suction in manual hose mode, but sprayer works just fine. Also, the other modes and settings work fine with suction and cleaning just not through the hose.

Posted by on

Ad

1 Answer

  • Official Brand Answer
  • 315 Answers

Hey Courtney! Sorry to hear about the suction problem on your SpotBot. Here's a quick link to troubleshooting steps to assist you.

http://www.bissell.com/FAQDetail.aspx?id=1040&cid=ccsocial

Posted on Jan 04, 2013

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
bissellcs508
  • 315 Answers

Life Inspired Cleaning Innovations

    Verified Fixya Pro

    SOURCE: Automatic Clean on Spot Bot 1200 dosent work

    Ted, it can be bear when the auto settings aren't working. One of our service centers can inspect and fix any warranty repairs needed.

    To locate a BISSELL Authorized Service Center, please click on the following link:http://www.bissell.com/service-centers/&=ccsocial

    Posted on Oct 22, 2012

    Add Your Answer

    Uploading: 0%

    my-video-file.mp4

    Complete. Click "Add" to insert your video. Add

    ×

    Loading...
    Loading...

    Related Questions:

    2 Answers

    No suction when using wand on electrolux precision upright


    There is a ball valve between the wand hose and the base hose. It can get stuck in the "base" mode, which won't then redirect suction to the wand hose. There is a spring under the cup that the open end of the hose rests in. When you release the wand from the holster with the one-touch quick release, that spring pushes the cup up and turns the ball valve to the wand setting.
    1. Unplug the vacuum.
    2. Using the one-touch quick release, remove the wand from the holster.
    3. Verify that the wand "cup" is indeed in the higher position. Do this by pushing on the bottom of the cup with your finger. It should easily depress.
    4. Remove the wand hose from the main unit using the quick disconnect feature. Put your fingers into the hole and feel to the right. You will feel the closed valve, verifying that it is stuck in "base" mode.
    5. Using a screw driver, insert the tip at the TOP of this valve and gently pry it downward. This shouldn't take much force.
    6. Reassemble the hose wand using the quick connect feature and reholster the wand.
    7. Plug in the unit and verify that the base unit has suction.
    8. Remove the wand from the holster and verify IT has suction.

    Jul 27, 2013 | Electrolux EL8807A Precision BrushRoll...

    Tip

    How To Replace The Hose On A Bissell Spot Bot, SpotBot, and Little Green...


    Replacing the Suction Hose on a Bissell SpotBot can be a challenging repair. We frequently get this question, how do you remove the old hose, so we decided to shoot a video repair demonstration on how to replace the hose assembly.
    This repair works for all Bissell SpotBot models in the 1200 Series, as well as the 7887, and some Little Green Machines.
    If you need to purchase a new Hose Assembly, you may find it on our website below:Bissell SpotBot Hose Assembly Part 203-6665

    Here's the video showing how to replace the hose:





    Please feel free to email us with any questions or clarification requests, and please be so kind and rate the video helpful if you found it to be.
    Thanks so much,
    Chris JonesGoVacuum

    on Jul 26, 2011 | Bissell 12005 Spot Bot Handheld Vacuum

    1 Answer

    Automatic Clean on Spot Bot 1200 dosent work


    Ted, it can be bear when the auto settings aren't working. One of our service centers can inspect and fix any warranty repairs needed.

    To locate a BISSELL Authorized Service Center, please click on the following link:http://www.bissell.com/service-centers/&=ccsocial

    Oct 22, 2012 | Bissell SpotBot Robotic Wet/Dry Vacuum

    3 Answers

    My Dyson 41 has just started only sucking through the tube


    We've had our DC41 for 4 months now and suddenly noticed no suction at the base as well. Base motor works fine.Thought I'd take one last look before sending in for repair. At the base of the attachment hose near the motor is a small red tab. I depressed it and pulled the entire hose off the motor. Sure enough inside was a eyeliner pencil our daughter had unknowingly vacuumed up. I couldn't see it just peering the length of the hose. Even with a flashlight. You don't see mention of the small red tab but it allows you to see close up rather than peering down the hose if something is lodged near the motor. Apparently this pencil prevented the internal hardware to switch from wand to base suction when the handle is reclined in floor vacuum mode. These vacuums have strong suction and they will pull up the oddest things! Hope this helps!!

    Aug 14, 2012 | Dyson Dc 41 Ball

    2 Answers

    Leaving bigger dirtier wet spots after cleaning


    Sounds like the vacuum motor is defective or you have a clog in the vaccum line. Basically everything is running except the vacuum "Suction" cycle. Do you hear the "Suction" phase (light indicator) during operation when it loudens like a whine? That would be the vacuum phase. Is the dirty water reservoir clean, do you rinse it thoroughly when you empty it? Have you removed the hose assy and rinsed it out? I think it is still part of the auto cycle even if you don't use the manual tool.

    Feb 24, 2010 | Bissell SpotBot Robotic Wet/Dry Vacuum

    1 Answer

    No suction in carpet cleaning mode with Empower


    Check the nozzle . Turn it over on it's belly and remove the 4 screws that hold the base plate on. Take off the plate and remove the brushroll. I bet you will see a clog in the intake. If not take it to your local vac shop and let them fix it.

    May 28, 2017 | Hoover U5262-900 / U5260-900 / U5266-900 /...

    1 Answer

    Suction only works using the hand held mode, there is no suction when try to use on carpet mode,


    There must be a clog in either the hose, dirt inland by the brush roll, or bad filters. If you have suction at the end of the hose, then look lower all the way to the brush roll.

    Mar 25, 2008 | Vacuums

    8 Answers

    SpotBot: all lights flashing!


    Per the manual, periodically you should clean the rubber lining in the dirty water tank(it comes out). I found mine a little dirty, but after cleaning it, it solved my 'all lights flashing' problem.

    Aug 07, 2007 | Bissell SpotBot Robotic Wet/Dry Vacuum

    Not finding what you are looking for?
    Bissell SpotBot Robotic Wet/Dry Vacuum Logo

    Related Topics:

    858 people viewed this question

    Ask a Question

    Usually answered in minutes!

    Top Bissell Vacuums Experts

    Les Dickinson
    Les Dickinson

    Level 3 Expert

    18394 Answers

    Brad Brown

    Level 3 Expert

    15644 Answers

    Jim Thurston

    Level 3 Expert

    670 Answers

    Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

    Answer questions

    Manuals & User Guides

    Loading...