Question about Audio Players & Recorders

Open Question

When connected I cannot get any sound from technics amp sux 301

The unit powers up but will not play sound through the speakers

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
megatronix
  • 57 Answers

SOURCE: Technics SU-V2 keeps cutting out

An amp will cut out if the output protection circuit kicks in. This circuit compares output power against the preset level. Each channel has it's own, independent protector. There are calculations that can be done, but for a novice the rule of thumb is to "never use a speaker with a power rating less than the amp AND a lower impedance than stated". Typically using a 4 ohm load on a 8 ohm system is inviting disaster. Even if the system does not become a smoke generator, you might notice that though "louder", the sound quality is deteriorated. Many "audiophiles" often hook up some combinations of speakers to have "surround" without really understanding that the collective impedance actually changes (generally lowers).

Posted on Jan 21, 2008

Ad
  • 1 Answer

SOURCE: no lights to sux 902 amp when powered up

Have now taken amp to a local repair shop as there does not seem to be any answers on this site :-(

Posted on Dec 04, 2008

  • 273 Answers

SOURCE: rotel power amp

some amps have a switch to bridge them rather than wiring a bridge meaning output is mono check to see if yours has this switch if you do simply put back to stereo

Posted on May 20, 2009

caroldon
  • 17130 Answers

SOURCE: Technics SE-A 2000. Powers up

It is not so easy to probe into to find a protection fault condition. The fault can be your output drivers- the mosfets fitted for both the channels, Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes.
If so replace the outputs. If not there can be issues in the mother board, maybe the protect circuit by itself is shutting off due to a faulty bias , maybe a leak in any voltage/current sensing circuit.Also disconnect the speakers and test, if the protect is off then check for short on the speakers.

Posted on Apr 28, 2011

Testimonial: "thanks for the advice."

  • 360 Answers

SOURCE: Hi I just got a Technics SU V2 amp and can't

Being a 500W amplifier, you need to connect speakers with 300W each. The correct method to connect speakers is red terminal of speaker should be connected to red terminal of amplifier & black to black. The left side to left side speaker & right to right speaker. There may be main & remote terminals. Main speakers are the speakers at local place of the amplifier & remote for remotely placed speakers. I do have Technics SU-V85A which is somewhat similar. Enjoy! A nice piece to listen.

Posted on Oct 22, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 15 inch powered Technical Pro speaker with a damaged audio board from applying too much eat trying to remove a bad transistor where can I get a replacement audio board


Shop for 15 inch powered Technic... on Google


Eminence Kappa Pro 15...
$154.99
Google Trusted StoreMusicians...

(5) Eminence Kappalite 301...
$209.99
Google Trusted StoreMusicians... Eminence Kilomax Pro P...
$239.99
Google Trusted StoreMusicians...

(3) Eminence Kappa Pro?15...
$169.99
Google Trusted StoreMusicians...

(3) Technical Pro zxp18 18 in. 4...
$151.88
Jet.com Search Results

    I have a 15 inch powered Technical Pro speaker with ... - Fixya

    www.fixya.com/.../t26013584-15_inch_powered_technical_pro_speaker
    1 hour ago - I have a 15 inch powered Technical Pro speaker with a damaged ... to remove a bad transistor where can I get a replacement audio board.

    Technical Pro Speakers ' eBay

    www.ebay.com/bhp/technical-pro-speakers

    eBayFind great deals on eBay for Technical Pro Speakers in Speakers and ... Package: (2) Rockville RSG12.4 Single 12" Three-Way, 4-Ohm Pro Audio ... Pro STAGE-212XU 3,000 watts Powered Speaker + 8 channel Mixer System + ... Technical ProPSHAKE1500 Two Way 15" Active 1500W Speaker Bluetooth and USB / SD.

    SA-15T - Seismic Audio Speakers

Dec 19, 2015 | Technical Pro power15usb 15 powered molded...

2 Answers

I have a Sony TA-AX 301..powers up fine.. and can


Make sure your speakers are the correct impedance for the amp. They should be 8 Ohm.

Connect them to the Speakers A sockets on the back of the amp.

Set the Speaker selector switch on the amp's front to Speaker A

Connect your source as detailed in the other answers.

Set the graphic EQ to either Off or Flat or put all the sliders to the middle position.

Apart from setting the volume on the amp, that should be it. If there's still no sound then you should recheck your wiring and input selection (make sure the red & white are connected to an IN and not and OUT on the amp). KIf there's still no sound then either the speakers or the amp (or both) have a fault.

Sep 16, 2014 | Audio Players & Recorders

2 Answers

I am playing Cd's and have a pair of Definitive Technology- Model BP-10 tower speakers connected to my Technics SA-DX1040 5.1 Channels Receiver and while the music is playing, all of a sudden the music...


There are 2 major possibilities and since you didn't say if the sound comes back here's the general split.
1. The power amp section could be having problems and/or protection circuits are kicking in. In this case repair of the amp will be needed.
2. There is a bad connection somewhere making the audio path go bad. In this case a good can of contact cleaner applied to all switches and controls may help. If not, the bad connection may be internal. If tapping (or rapping) on the unit makes it come back, there's probably a bad internal connection.
If letting the unit cool down brings back the sound, its the power amp section.

Dec 27, 2010 | Technics SA-DX1040 Receiver

1 Answer

Distorted sound on Technics SL-1200/1210


You could be getting acoustic feedback from the speakers to the TT's. Lower the volume or somehow isolate them from room sounds and vibrations.

Jul 05, 2010 | Technics SL-1200 Turntable

1 Answer

Cd player plays, but no sound comes out of speakers.


first off the amp gets power straight from the battery. the amp is used to power the subs. the subs are suppose to be connected to the amp only( never the speakers).

for the second part you mostlikely killed the wires. you should get some one to look at it and check the wires. thee speakers might need to be re-wired

Jan 31, 2009 | Kenwood KDC-MP238 CD Player

1 Answer

No lights to sux 902 amp when powered up


Have now taken amp to a local repair shop as there does not seem to be any answers on this site :-(

Dec 03, 2008 | Technics Audio Players & Recorders

1 Answer

P-301 onkyo pre-amp


Hi juicer, If you use the switched outlet, then everything will be turned on/off when you operate the preamp power switch. Use the unswitched, then you have to turn off each unit separately. You choose which one you want. It wont matter.

What connection do you intend to use to connect the LBT zx6 to the Onkyo preamp??

Mar 20, 2008 | Audio Players & Recorders

1 Answer

Connection between CD, EQ, SP technics


Each unit (the EQ and the Processor) should have left/right in/out rca jacks as well as L/R tape in/outs. The EQ or processor use the receiver's tape loop and then provide a tape loop to replace the one they've used on the receiver.

You plug the first unit (let's say the Sound Processor into your receiver/amp as if it were a tape deck (Processor's outs connect to reciever's tape ins (play) while the Processor's ins connect to the receiver's tape outs (record).

Then you chain the EQ off the Processor in the same way (EQ outs connect to Processor's tape ins (play) and EQ ins connect to the Processor's tape outs (record).

Last you connect the tape deck to the EQ as follows. Tape deck outs connect to EQ's tape ins (play) and the tape deck ins connect to the EQ's outs (record).

This will put both the Sound Processor and the EQ in the receiver's tape loop. In order to have all the receiver's source signals routed through them you may have to engage a Tape Monitor switch or button somwhere on your amp which will route the tape loop to your speakers.

Jan 09, 2008 | Technics RS-TR272 Single Cassette Deck

1 Answer

Technics SA-DA10 Receiver-no sound


Most of these problems are rooted in a failed power amp module.
I'm working on an older technics unit but with the same troubles.

Aug 08, 2007 | Technics SA-DA10 Receiver

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

23 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5158 Answers

The Knight
The Knight

Level 3 Expert

74383 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...