Question about Lowrance Boating

Open Question

My x67c ice machine doesn't find depth,flashes all the time. have purchased a new transducer and that didn't help. tried the transducer from another x67c,still no result. can it be repaired or am i screwed?

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Editor925
  • 285 Answers

SOURCE: My Lowrance X-51 is not reading the depth sitting

Yes quite possibly... But a few things to try/check first before you go out and get a new transducer...

1. Ensure the transducer is fully submersed below the waterline when floating and when on the plane... try lowering it more if you can.
2. Check the surface of the transducer itself (the underside) pointing down... If there are any minor scratches or scuffs, this can effect its function or performance. Minor scratches or marks can be sanded out with fine wet/dry sandpaper (at least 400 or 800 grit).
3. Isolate any electrical wires running near or next to the transducer cable. Also check connection of cable at head unit, and that the pins etc are clean, free of corrosion and making good contact.
4. Take your head unit to your Lowrance dealer and they may have a transducer there to use to diagnose whether it is indeed the trasnducer or a problem with the head unit.

Good luck!

Posted on Aug 01, 2009

  • 1 Answer

SOURCE: Marine Faria depth finder, with thru the hull transducer.

I'm having the exact same problem. I spoke with the service manager at Faria (Ted) and he was thinking that as long as the gauge is showing a reading, it should default to reading the depth. I'll probably send the guage in to FARIA - they'll repair it for $55. You bring up a good point - maybe the transducer is bad? I put a call in to the Tedmeister to see what he thinks. I'll post if he sheds any light.

Posted on Aug 18, 2009

  • 5 Answers

SOURCE: I have a GPS Map 498-depth sounder not working? Ha...

If the transducer is out of the water, you will not get a reading and see the flashing depth. You should hear and feel the clicking in the transducer when out of the water and working properly. Are you getting a temp reading when out of the water?

Posted on Jul 31, 2010

snowghost1
  • 784 Answers

SOURCE: Hello, our Raymarine ST40 depth sounder on our

now there is a chance that the transducer is bad ,, but I would check the battery voltage and make sure you have a soild 12 volts to the unit. also in my many years of working with and installing these units on boats I have see the needle pins ( where the plug inserts in the back of the display unit ) bend and/or break off completely. look in the plug area of the display unit and make sure all pins are intact. one more place to look for the problem is in the plug itself, take the plug apart and inspect the wire connection and make sure they are all good. if after all the above has been checked then I would assume that it is the transducer itself.
if you have anymore questions with this problem, please feel free to write back and ask,

c...

Posted on Jan 30, 2011

  • 1833 Answers

SOURCE: I have a 190c installed

Hi,

According to your problem, first make sure that you have mounted the Transducer inside the Hull or Transom. Check the transducer cable. Set the video resolution. Master reset may require for the Fishfinder.

Posted on Apr 26, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Mark 4 sometimes shows incorrect depths. The transducer has not moved and no problem with electrical. One point it is working fine, the screen then runs multiple vertical lines and the depth chan


Take note if when the vertical lines appear on the screen if the depth numbers begin to flash. If this is the case then the transducer has lost bottom contact and the unit is trying to reacquire bottom contact. If the transducer is parallel to the bottom of the lake while your boat is not moving then, the next time you have it on the trailer, turn your unit on and go listen and or feel the transducer to see if you can hear and or feel the tick or sonar ping. If you can't your transducer may be faulty. If the loss of bottom contact occurs when you are moving it will happen at a certain speed. This is the result of air bubbles passing under the transducer and disrupting the sonar signal causing loss of bottom contact.

Sep 19, 2014 | Lowrance Mark 4 Chartplotter/fishfinder...

1 Answer

Garmin 498


burned up get a new one they do that at times( no bottom lock)

Sep 15, 2013 | Boating

1 Answer

My Garmin depth finder/gps combo is giving me a false depth reading,like way way outta sack,not a foot or two. It came as an extra on a boat I purchased and elsewise seems ok,just inaccurate depth. Is it...


YOUR TRANSDUCER MAY BE SET FOR HORIZONTAL MODE...MEANING FROM BANK TO BOAT, NOT DEPTH...CHECK THE TRANSDUCER TO MAKE SURE, IT IS AIMING DOWN, NOT OUT...OTHERWISE YOU'LL NEED TO CHECK YOUR MODE SETTINGS IN YOUR MENU.

YOU CAN ALSO DO A TEST ON YOUR TRANSDUCER, BY SCREWING IT ONTO A BROOM STICK ...ADJUST THE TRANSDUCER DOWN, CHECK YOUR SETTINGS ON THE SCREEN, THEN DO A SIDE TEST WITH THE TRANSDUCER TILTED SIDEWAYS TOWARDS THE BANK AND CHECK YOUR SCREEN!

THEY CAN BE TRICKY...AND ARE VERY SENSITIVE, BUT ONCE YOU FIGURE OUT, HOW YOU WANT TO USE IT, YOU'LL LOVE IT!

HOPE THIS HELPS!

Sep 03, 2011 | Garmin GPS

1 Answer

I've purchased an Eagle 320 fishfinder 2 years ago and I've had to replace my transducer twice. Every time I'm out fishing lakers in 50 to 100 feet of water, I keep loosing the bottom mark and...


I have never heard of Eagle Fishfinders, but I would be inclined to package it up and send it back to them for checking under warranty, with a fault that should never happen. The brand leaders are Lowrance and Humminbird, with Garmin in 3rd place.

I have a Humminbird 998HD with Side Imaging. I had a 798SI before that and never a problem. the 998 cost me nearly 2 grand Canadian and is used on Lake Ontario, twice a week every week from May to October, and has been faultless. The 798 was used from 2008 to 2014 and also faultless. I think you have a 'Friday Special'.

Mar 14, 2017 | Eagle Fishmark 320 Portable Fishfinder

1 Answer

My Garmin 400c dual beam transducer keeps freezing up, it will flash "0" depth and then go to a "updating software" screen.


check your battery voltage. Low voltage can cause errors end prevent the sonar from starting up. If charging the battery doesn't work then contact garmin for a replacement.

Nov 30, 2010 | Garmin Fishfinder 400c With Dual Beam...

1 Answer

I have a gps Map 498-depth sounder not working? Have new transducer from Garmin-it flashes "00"-it is not connected to boat yet (transducer)-need it be or can I put in a bucket of water (need it be in...


If the transducer is out of the water, you will not get a reading and see the flashing depth. You should hear and feel the clicking in the transducer when out of the water and working properly. Are you getting a temp reading when out of the water?

May 16, 2010 | Boating

1 Answer

Lowrance lcx-111c hd, single beam transducer


Hey Tingo,
I have two 113's,, the problem sounds like the transducer is going bad,, Try this.. unplug all your connections,, replug them and see if it helps...

Don't get me started on $$$ updates....

May 15, 2017 | Lowrance Lcx 112c 10.4" Screen Color Gps...

1 Answer

First time run, everything mounted correctly, power on, no depth or sonar return.


So the depth is flashing and you don't see any bottom return at all, right?

Are you in the water, or trying it out before you put the boat in the water?
If you are not in the water, try it out in the water because it can be difficult to get any kind of return out of the water.

Try resetting the X67c to factory defaults:
1. Turn unit off
2. Press and hold the down arrow key
3. Press PWR while still holding the down arrow key, the unit will enter production test mode. Let go of the down arrow key
4. Press EXIT 5 times
5. Press ENT and the unit will shut off

Turn it back on and if you still have the same problem, depth flashing 0.0 or 0.5 or 60 probably and no bottom, then a good bet would be a bad transducer.





Jul 13, 2009 | Lowrance X67c Deep Water Color Sonar...

2 Answers

Unit showing 88.8 in the LCD window.


Hello geld1. Your problem is the transducer, cable or connector. Check transducer with an ohm meter, flex the cable while ohming the restance shouldn't change. The location and mounting of the transducer could be the main problem. Use the the correct gel film including a secure postion support.

Sep 22, 2008 | Uniden Qt206 Thru Hull, Digital Depth...

Not finding what you are looking for?
Boating Logo

Related Topics:

36 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lowrance Boating Experts

The Knight
The Knight

Level 3 Expert

73611 Answers

Phil Walker
Phil Walker

Level 3 Expert

605 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1667 Answers

Are you a Lowrance Boating Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...