Question about Alpine PDX-4.100 Car Audio Amplifier

1 Answer

Amplifier Not powering on.

I am baffled. I have just purchased this amplifier and already the thing is not powering on. When I turn on my radio, I notice that the blue led light comes on for a split second, then shuts off. I checked the fuses to see if that was the problem (two 30 fuses), but the fuses are fine. My mono amplifier is working just fine. Please help.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 156 Answers

Amplifier power problems are generally pretty easy to troubleshoot as long as you have access to a digital multimeter. You need to check the DC volts on the power terminal and on the remote terminal. For the amplifier to turn on, each terminal needs to show around 12 volts. From the sound of it, I suspect a problem with your main power wire, but the multimeter will make certain. If you show voltage on both terminals (with the black probe on the ground terminal) and the amp still doesn't turn on, then there's a defect in the amplifier.

Posted on Jun 25, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Aftermarket amp


The Chrysler Dodge radio sends full volume to the Infinity amplifier using other cables it sends voltage with data to the amplifier and tells the amplifier lower or increase the volume, there is no way to tap or get the signal that is way pac build this interface for your radio CAN buss adapter hi low

Jun 01, 2013 | Car Audio & Video

1 Answer

Every time i hook up my coustic car amp the radio will turn on with out the radio on


THE GOAL HEAR IS TO DETERMINE IF THE INSTALLATION IS CAUSING YOUR PROTECTION FAULT OR IS IT THE RADIO OR AMPLIFIER ITSELF HAVING INTERNAL DAMAGE. REMOVE THE RCA INPUTS AND DISCONNECT THE SPEAKERS, THEN POWER THE AMPLIFIER UP WITH THIS NO INPUT, NO SPEAKER LOAD CONDITION. IF IT STILL POWERS UP ON ITS OWN, THEN REMOVE THE REMOTE TERMINAL COMING FROM THE RADIO. IF THE AMPLIFIER SHUTS OFF, THEN YOU MAY HAVE A SHORTED TURN-ON TRANSISTOR WITHIN THE RADIO AND IT IS OUTPUTTING THE DC NEEDED TO TURN THE AMPLIFIER ON. IF YOU REMOVE THE REMOTE TURN-ON FROM THE RADIO TO THE AMPLIFIER AND THE AMPLIFIER STAYS ON, THEN THIS POINTS TO A FAULT WITHIN THE AMPLIFIER AND IT WILL NEED TO BE SERVICED. MAKES SURE THAT THE AMPLIFIER AND RADIO GROUNDS ARE 100%. LET ME KNOW IF YOU NEED FURTHER ASSISTANCE.....V

Jan 15, 2010 | Coustic Car Audio 401SE Car Audio...

1 Answer

I would like to see a wiring dieagram for a 2005 tahoe sterio speakers


Radio 12v red/white + radio harness Radio Ground black - radio harness Radio Ignition (GMLAN Serial Data) Radio Illumination yellow (dimmer) + radio harness Factory Amp Turn-on same as power antenna wire Power Antenna white + radio harness LF Speaker +/- tan - gray +,- radio harness or amplifier Notes: If equipped, the amplifier is under the rear of the center console.

At the amplifier, the left subwoofer wires are dk. blue/white (+) - lt. green/black (-). The right subwoofer wires are dk. green (+) - lt. blue/black (-). RF Speaker +/- lt. green - dk. green +,- radio harness or amplifier LR Speaker +/- brown - yellow +,- radio harness or amplifier RR Speaker +/- dk. blue - lt. blue +,- radio harness or amplifier clear.gifthat should be it **** if u need more help feel free to email me at bertman285@hotmail.com

Oct 05, 2009 | Car Audio & Video

2 Answers

Where does the rem wire plug into


It plugs into the power antenna cord on your radio if your radio does not have a dedicated remote cord. The remote switch is so that you amp can detect when your radio is on and turn on too, or is off when your radio is off so as not to drain the battery

Sep 23, 2009 | Eclipse (XA1000) Car Audio Amplifier

1 Answer

Toyota tacoma 2007 stereo wiring Colors for the following wires: Power-ignition Ground


Radio 12v blue/yellow + radio harness
Radio Ground brown - radio harness
Radio Ignition gray + radio harness
Radio Illumination green + radio harness
Factory Amp Turn-on N/A
Power Antenna N/A
LF Speaker +/- pink - purple +,- radio harness or amplifier
RF Speaker +/- lt. green - blue +,- radio harness or amplifier
LR Speaker +/- black - yellow +,- radio harness or amplifier
RR Speaker +/- red - white +,- radio harness or amplifier

Notes: If equipped, the amplifier is on the passenger side rear cabin wall.

Sep 13, 2009 | 2007 Toyota Tacoma

2 Answers

Wiring diagram for a LXA400 Jensen power amplifier??


Power wire to battery
Ground wire to body of car
Remote wire to power antennea wire on radio or power amp wire on radio if you have aftermarket radio
get back with me for any more ?'s

Jun 05, 2009 | Jensen LXA400 Car Audio Amplifier

1 Answer

Sony XM-1652Z


What head unit do you have?
Is there a dedicated subwoofer output?
If not, have you switched the rear output to sub output?
Is the amplifier set to LPF (low pass filter), and the gain turned up?
Many things can be wrong, but the fact that there is anything coming out of the subs is a good thing.
Start at the beginning - Head unit, then check amplifier gain/crossover setting.
If you are using a hi level adapter on factory radio, is the Bass on the radio up? is the output gain on the convertor up?

Jan 13, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Radio comes on but i cant hear any music


You may be connecting this stereo into an amplified system. If the original factory stereo worked with the factory amplifier, your stereo is not turning the amplifier on. If you purchased the aftermarket wire harness that mates to the factory stereo connector, hook up the "Amplifier Trigger" wire, this wire is usually blue.

Oct 16, 2008 | Pioneer DEH-P3500 CD Player

Not finding what you are looking for?
Alpine PDX-4.100 Car Audio Amplifier Logo

162 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4989 Answers

hoyzee1

Level 2 Expert

150 Answers

Jaime Hernandez

Level 3 Expert

2336 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...