Question about Jl Audio E1200 Car Audio Amplifier

Open Question

Jl audio hd 900/5 red flashing light - Jl Audio E1200 Car Audio Amplifier

Posted by Anonymous on

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 123 Answers

SOURCE: JL Audio 500/1 Amplifier "Thermal" light flashing

pooi

Posted on Jul 25, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why my jl audio 1400d amplifier stays in protective mode?


Check for a speaker wire that come come of , Or a loose grond wire on the amp or where ever you have the ground wire connected two,

Oct 31, 2012 | Jl Audio Car Audio & Video

1 Answer

Have a jl audio 500/1 the red light blinks and no other light turns on. whats the problem with it?


I think you might have your remote turn on from your deck to amp hooked up wrong check that out!! I not are you familliar with the mr. butterworth crossover JL developed for that series of amp? Just like its big nrother the 1000x1 class D the built in smart crossover has many built in pretect modes. If your subs are drawing to much power it shuts down if they draw to little of ohms or to many but that 500 is 1 ohm stable so download the crossover settings from JL and go from there

Apr 28, 2012 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

I have a JL total mobile audio T500.1 mono amp and it was playing then all the sudden it stopped and the power light which is usually green is now red and stays red and no sound comes from the subs any...


This happens when the amp goes into protection mode. 90% of the time, it means there is a short or has another issue inside the unit and has to be fixed or replaced. Hope this helps and good luck!

Jul 09, 2010 | Jl Audio Car Audio & Video

1 Answer

I hookd my jl 500/1 up i like it louddd but the bass goes in and out??? can you help .


is there a green light? does it go red? the unit could be auto-protecting from your speakers, are they old speakers?

Feb 07, 2010 | Jl Audio 500/1 Car Audio Amplifier

2 Answers

JL Audio 500/1 Amplifier "Thermal" light flashing


Re-check all the connections to the speakers, The uPC monitors all the outputs and if any are taking more power than they should, the uPC shuts the amp down to protect the internal components. Don`t use tape joints alone, try to run the cable the full length without any joints. If you do have to piece the wires together, solder them and stagger the connections, in other words, make one lead shorter than the other so that if the tape does come off, the offending connection is well away from the other so they can never meet or connect to each other. Ian

Jul 24, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Jl audio 500/1 amp low ohm light at high volume


I would try running the subs in parallel. Pos to Pos Dual Voice, Neg to Neg Dual Voice. Then Run + to + stereo - to - stereo on both channels.
So you have + and - running to one channel and + and - running to the other channel.
Also your LPF filter could be set too high.

Feb 07, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

JL Audio e1200 Red protect light on


it sounds like you have a bad ground make sure its on the frame or body and any rust or paint is scraped off

Feb 11, 2008 | Jl Audio E1200 Car Audio Amplifier

1 Answer

Jl audio E6450 cutting out


hi, have you figured out whats wrong with ur amp ...i have the same amp ....and as soon as i finished the connections ...and connect the remote on wire,,, the amp goes on ...making a ticking sound with the green light blinking and the red light staying solid on ...whats the problem please help ....how can i fix this ......my amp is a jl e6450 ....im using a panasonic cd player with a built in amp ....and thats the cd player im trying to connect to the jl amp ...please HELP

Nov 01, 2007 | Jl Audio E6450 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio E1200 Car Audio Amplifier Logo

Related Topics:

84 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Mark Skinner

Level 2 Expert

77 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...