Question about Flotec 1 Hp Deep Well Pump

1 Answer

Motor running but not pumping any water, why?

Flotec, 1hp, deep well pump, f3332 model

Posted by on

  • 1 more comment 
  • mark_s_kamin Jan 19, 2009

    this is a brand new motor and is in the water, unclogged in take ports. I can hear the motor running, just no water is pumping up.

  • mark_s_kamin Jan 19, 2009

    wow, say it is not true, I have had great luck with flotec in the past, this is so sad, but based on all the trouble shooting I have done, the brand new pump is my the only option to replace. sad day for flotec

  • Anonymous Mar 31, 2014

    Motor 1HP suguna make under warranty period.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,990 Answers

You very well could have a bunch of Sediment on the Intake for the Water OR The water table has Drpped Below the Pump.

Posted on Jan 19, 2009

  • Travis Humphries
    Travis Humphries Jan 19, 2009

    Got the Same pump on my Well right Now. I had to go through 3 Before I got one that works Correctly.

  • Travis Humphries
    Travis Humphries Jan 19, 2009

    Sorry about that! I hate too tell people bad news!

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Should a deep well pump feel hot?


Usually when the pump is getting hot it is going, unless it lost prime and if it ran any long period that will cause it to prematurely die

Aug 02, 2014 | Flotec 1 Hp Deep Well Pump

1 Answer

Water pump not running


Hi have you removed the pump from the well and tested if it will run without going via the presure switch. It could be that the pump is blocked. If it is blocked and has been for a while it may well have burnt out the pump. How deep is your well and how far from the bottom of the well is the pump. The pump should be positioned a good distance from the bottom of the well to prevent any silt getting into the pump to block it. I have a 110 meter deep well and the water level is 38 meters below ground. I have the pump at 50 meters below ground. I have only changed the pump once in 10 years.
I hope this helps
Steve

Mar 27, 2014 | Flotec 1 Hp Deep Well Pump

1 Answer

I have a deep water well, the water is brown & does not seem to clear itsself even after we let the water run for an extended period of time. The well has not been used in excess for the last few


Do you have a filter system..is this water going to be potable?
I would reccomend a water softener, and an iron filter for brown well water. We have used well water S Cal and Minnesota

Mar 19, 2014 | Flotec 1 Hp Deep Well Pump

1 Answer

I have a deep water well, it has not been used a lot in the last few years & the water is brown, can this problem be rectified


Hi Enslow, I can only guess that if the well hasn't been in use for some time then it's possible that if you run the pump and get brown water it may clear in time. My suggestion is simply continue to run the pump few a decent period of time that maybe a few days . As you do this take samples in say clear glass containers and see if there is improvement. So take samples every couple of hours and it will be apparent if the water is clearing or not. Make sure the pump is a decent distance from the bottom of the well.
Hope that helps
Regards
Steve

Mar 17, 2014 | Flotec 1 Hp Deep Well Pump

1 Answer

Flotec Float switch did not automatically shut off,enginburn out


Hi Lamont .. I would first check test the float switch and make sure that it is faulty, set it up in a tub of water and manually move the float switch. see if it cycles on and off. sometimes the float will get hung up on its support or on the edges of the sump pit. If the float switch is faulty then YES it can be replaced,. try a building supply store like home depot or the pl;ace where you got the switch originally.

Please Vote !!

Jun 01, 2010 | Flotec 13 Hp Automatic Submersible Sump...

1 Answer

Have 1hp pump turnon hose out side good pressure for few mintues then lose it deep well and bladder pump whats wrong


One of 2 things, you are either exceeding the pumps capacity for flow or your water well just simply cannot kep up

May 02, 2010 | Grundfos MQ3-45 1 HP Pressure Booster...

1 Answer

My Flotec pump runs 5 seconds shuts off for 30


fully submerse pump in bucket of water, tilt to get all air bubles out,(keep hose off) plug in and it should work fine

Dec 02, 2009 | Flotec 1/6 Hp 1260 Gph Utility Submersible...

2 Answers

Flotec Sprinkler Pump not priming


it might be that the pump is prewired at 230 volt and you are running a 115 power supply to it, if motor just humms and little water comes out this might be your fix

Mar 13, 2009 | Flotec 1 - 1/2 Sprinkler Pump Composite...

Not finding what you are looking for?
Flotec 1 Hp Deep Well Pump Logo

Related Topics:

738 people viewed this question

Ask a Question

Usually answered in minutes!

Top Flotec Garden Experts

tsmith198007

Level 1 Expert

40 Answers

Jay Finke
Jay Finke

Level 3 Expert

1224 Answers

nathan

Level 3 Expert

634 Answers

Are you a Flotec Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...