Question about NAD C370 2-Channel Amplifier

Open Question

No sound from right speakers

I only have sound from my left speakers, the right channel is dead. I have checked connections and swapped speakers etc, all work. Appears to be problem with amp

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

SOURCE: Output volume has dropped in right channel

dear sir,pls check the HT voltage fuse, LTsupplay also and out put stage,and volume controle,

Posted on Feb 01, 2007

Ad
petraman7
  • 1175 Answers

SOURCE: Gem Sound XP-350 both channels failed

Speaker fuses are generally fast-blow styles 250 volt glass
If an amp shuts down, with speakers connected, it sounds like one of the power supply lines does NOT like what it's "seeing" . Probably output transistors bad ( or module)

Take it to a tech.

Scott out.

Posted on Jan 08, 2008

marsrover
  • 682 Answers

SOURCE: The right channel on my NAD intergrated amplifier C320Bee no longer works.

if you did test for your cable and speaker and you find it fine-your problem will be in output stage of your amp and needs aid of service center.

Posted on Jul 15, 2008

  • 4 Answers

SOURCE: NAD C272 Amplifier: Intermittent left channel

My solution was actually indeed the output protection relay. What I did was to open up the relay and use contact cleaner and a very fine abrasive to clean the contact surfaces of the relay. After that, the problem was gone!

The way to diagnose this for me was to run the amplifier open until the problem recurred and to simply tap the relay's box. The sound came on immediately, and I was convinced.

Posted on Feb 05, 2009

Grubhead
  • 5190 Answers

SOURCE: NAD C370 Right channel distortion

Sounds like you have lost the power amp transistor(s) or IC for this channel.

Posted on Feb 16, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No sound on left channel on home stereo optimus sta-795 will changing fuse out restore sound


Not likely! Suggest swapping input connection, red RCA connector to white and white to red and see if problem swaps speakers.

If still left channel bad swap speakers left to right see if problem follows speaker.

Check balance adjustment and confirm that it is set to the middle!

Check all other inputs and confirm always no left output.

The goal is to confirm that the left channel is defective!

The service manual is MS3102101 would normally be available from Radio Shack.

Check for defective capacitors or failed solder joints on the PC board. These units are repairable even by DIY however replacement recievers are relatively inexpensive.

Hope this helps?



26364739-n5uv4pl0imrm51spsuhjadcc-3-0.jpg

26364739-n5uv4pl0imrm51spsuhjadcc-3-2.jpg

Nov 20, 2016 | Optimus Audio Players & Recorders

1 Answer

In my JVC RX 8SD only works a channel. How do I repair this defect?


Start with the simple things.
  • Check left right balance
  • Swap output speakers left to right
  • Swap the speakers at the receiver to make sure no wire open/short
  • Swap input RCA cables left to right red/white - white/red
Ok No JOY!
JVC has thermal overload circuits/overload on most of there Amps.

Remove power for a minute or two to see if there is a reset.

Rewire speaker connections to speaker set 2.

Connect REC out to Rec In swap cables and see if problem is in pre-amp or power amp.

Check internal fuses.

Jan 19, 2016 | JVC Audio Players & Recorders

1 Answer

Mission m73 with a woofer which seems to have gone dead


I use to have some warfdales that did that, and generally it was the cross over unit that would blow a fuse, if fitted.

Dec 26, 2013 | Audio Players & Recorders

1 Answer

Speaker leads shorted on right rear channel of Logitech Z-5500 system


First check the speakers by connecting to front connector if thr no sound then replace the speakers.If you here sound while swap the rear amp IC might be damaged replace the IC .

Dec 19, 2011 | Logitech Z-5500 Computer Speakers

1 Answer

My left channel in my JVC RX-305 isn't working...what do I do to fix it? When I either push the volume up or down it makes a clicking sound. It was working just fine last night. My right channel is...


Try swapping the speakers or just check the left connections WITH POWER OFF. Disconnect the left speaker completely and see if the clicking stops.

Sep 05, 2011 | JVC RX-618V Receiver

1 Answer

No sound from left speaker on right deck. left deck is fine. confused! tried unplugging one at a time and only the right plug is working. is there anything simple i can do to rectify this problem? as...


To find out what the problem is try this, swap over the right and left leads from the deck to the amp. If the problem stays on the left channel there's something wrong with pre-amp in your amp. If it goes to the other channel (right dead) it's the deck. Next remove the wires to the cartridge to the deck with the fault. Make a note of how they fit on the cartridge before you do. With the amp connected to the deck and on. Touch (one at a time) each of the four wires with your finger. Two of them will probably produce no sound. But from one wire you should hear a buzz on the left channel and from another wire a buzz on the Right channel. If you get a Buzz on the left speaker then all the connects are good and the cartridge has gone. If you don't get a buzz, then there is something wrong with the left cable connector between the deck and amp.

Jun 01, 2011 | Technics SL-1210 Turntable

1 Answer

I have a studiomaster proline 1648 gold mixer, when i input stereo out from my pc into 2 channels. the out put is 2 xlr to amplifier speaker. but the sound is only one side (either left or right). i have...


Pleas check which side of the cable does give you sound. Lets say the red RCA line works with the right speaker. Now swap the wires at the back of your mixer ie. change the red plug to the white input on your mixer. If no sound comes through, your mixer might be dead on that channel.

Jul 16, 2010 | Audio Players & Recorders

1 Answer

No sound from front left channel


Try swapping the connectors for front-left and front-right (just swap right at the back of the amp)

After the swap, does the front-left speaker work, and now the front-right is dead? If so, then it's a problem in the amp.
If not, then the problem is in the wiring and/or the front-left speaker itself.

Post back here with your findings, and we'll troubleshoot whichever part of the system is broken.

Apr 08, 2010 | Onkyo TX-SR605 Receiver

1 Answer

One of my numark turntables tt 500 the left channel does not work. i only hear the music on 1 speaker. doe you know what to do?


Swap the channel cables from the turntable left to right to see if it follows a channel from the turntable or the same speaker is dead. If it swaps with the cable, then look for a break in the wire to the pickup on the tone arm. If the dead speaker remains the same, you have a problem in that side of the amp or the phono preamp.

Jan 10, 2010 | Numark TT500 Turntable

1 Answer

Help


I recommend you swap your left and right input cables to make sure it's not a source issue.

So from your headunit, plug the left channel output into your amps right input and your right channel output into your amps left input.

If the same side is still not working then disconnect both (or single speaker if it bridged) the speakers from the not working side at the amp. Connect the front and then the rear speakers individually and retest to see if one of them works.

If one does work then check the cabling and speaker connections on the one that doesn't. If it's shorting out anywhere it will stop your amp from powering that channel.

Failing that, it could just be that your amp has partly failed.

Feb 15, 2008 | Boss Riot 1500D Car Audio Amplifier

Not finding what you are looking for?
NAD C370 2-Channel Amplifier Logo

Related Topics:

72 people viewed this question

Ask a Question

Usually answered in minutes!

Top NAD Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5190 Answers

The Knight
The Knight

Level 3 Expert

74473 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a NAD Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...