Question about Polaris 360 Head W/Hose

1 Answer

Polaris 360 hose splitting

New hose splits after one week

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,669 Answers

THere must be a problem with the quality of the plastic on the hose! Try to get some satisfaction from the dealer who sold it to you. If not, post a complaint with the manufacturer!

Posted on Dec 31, 2012

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hose has split


VacuumSpot are miele agents for Australia and New Zealand if you need any Miele parts in this area you can hit us up on the contact us page and we will get you anything you might be after

Feb 12, 2013 | Miele Vacuums

1 Answer

Engine p0446 . i replaced purge valve but light still coming on


There may be also a flow sensor in line with that valve, also check for split rubber hoses.
On mine, a dose of intake cleaner in the valve and sensor and a replaced split hose turned off the light.

Larry

Oct 23, 2011 | 2000 GMC New Sierra 1500

1 Answer

Have had my current Polaris 380 for around 6 years. Nothing has changed...but suddenly the cast to my backup valve split 3/4ths of the way around above the threads. Replaced with backup valve from...


It is likely a coincidence but you may have a restriction of the water downstream from the device. This would cause a higher pressure and might therefore add to the stress on the backup device. Regardless of the cause you still need to new backup valve or a new part to replace the part that split. They are not hard to replace if you can get it apart.

If you have trouble getting it apart you can bring it down to Leslies Pool Supplies and they can put it back in order for just the price of parts.

I hope this helps.

Sep 04, 2011 | Polaris 380 In Ground Pool Cleaner

1 Answer

Have had my current Polaris 380 for around 6 years. Nothing has changed...but suddenly the cast to my backup valve split 3/4ths of the way around above the threads. Replaced with backup valve from...


I think it is a coincidence. On the other hand, there could be a restriction downstream causing the pressure to be too high. I would check for this but either way you will need to buy a new one. I hope this helps.

Sep 04, 2011 | Polaris 380 In Ground Pool Cleaner

1 Answer

The wheels on my polaris 360 don't turn


if pressure ok look inside and check hoses and belts and gears on wheels

Jul 25, 2011 | Polaris 380 Automatic Pool Cleaner with...

1 Answer

Why are there 360 degree in a circle


360 is more easily mentally divided than 10-based numbers. Once you break 360 down into quarters, you get 90. 90 can be split easily in many ways.
2×45, 3×30, 5×18, 6×15, 10×9, 9×10, 15×6, 18×5, 30×3, 45×2 - 10 ways100 can only be split 7 ways before breaking down into fractions:
2×50, 4×25, 5×20, 10×10, 20×5, 25×4, 50×2 - 7 ways.

Sep 02, 2010 | Computers & Internet

1 Answer

Vacuum not picking up much but the hose attachment has no problem


I assume you've checked for blockages and that there's a useful length of bristles on the brush roll. Turn the machine over, and just behind the brush you will see a short length of clear plastic tubing with spiral reinforcing. That tube often splits, so there's an air leak and consequent loss of suction at the brush. A split may not be immediately obvious - to get the tube off, pull it off from the motor end and then unscrew it at the brush end. As a temporary measure you can cover a split with tape, but the tube undergoes so much flexing that tape is rarely effective for very long. A new hose (it's called the internal hose) is not expensive and is the only permanent solution.
If the internal hose is not split, post a reply here and we'll see what else we can think of. Good luck!

Jun 05, 2010 | Dyson DC07 Animal Bagless Upright Cyclonic...

1 Answer

My 2001 Polaris Trailblazer has a grinding noise in the transmission when in high and driving. It doesn't seem to make any noise in neutral or reverse. Any ideas?


The problem is most likely the silent chain inside the transmission. I had this problem on a '98 Trailblazer. Made the grinding noise in forward but no noise in reverse. The new chain solved the problem. You will have to remove the transmission and split the case. Not a hard job if you have some mechanical know how.

Jun 12, 2009 | Polaris ATV

1 Answer

Split main hose


You can attempt a repair, but you'll be luck if it remains satisfactory for very long.  The only real solution is a new hose.  

Apr 20, 2009 | Dyson DC07 Bagless Upright Cyclonic Vacuum

Not finding what you are looking for?
Polaris 360 Head W/Hose Logo

Related Topics:

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaris Garden Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Paul Bade

Level 3 Expert

1572 Answers

john h

Level 3 Expert

12650 Answers

Are you a Polaris Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...