Question about Alpine PDX-F4 Car Amp

Open Question

How to set alpine pdx f4 crossover to run alpine spr 68 speakers

Posted by on

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 9 Answers

SOURCE: Alpine PDX-1.1000 to a 10 "Alpine SWX-1043D

straight up. Since it has the power saving technology where it gives out the same power at 2 ohm and 4 ohm loads then u dont have to bridge it and since its a single speaker you dont have to bridge it and since it is a mono block oyu dont have to bridge it. just wire + to + and - to -.

Posted on Jun 02, 2009

  • 8 Answers

SOURCE: what do i set my crossovers to i have an alpine

Set the two switches filter to: off. You do no need filtering your speakers as they are full range ones.

Posted on Aug 19, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Spr-69 crackling


It may be a bad voice coil. It would make that type noise. If the cone isn't cracked its the coil.

Jan 25, 2014 | Alpine Type-R SPR-69 Car speaker - 100...

1 Answer

What do i set my crossovers to i have an alpine pdx-4.100. and im useing it in sterio to power 4 2 way speakers


Set the two switches filter to: off. You do no need filtering your speakers as they are full range ones.

Aug 15, 2011 | Alpine PDX-4.100 Car Audio Amplifier

1 Answer

How to install spr-17s


The six 1/2 speakers are your woofers,connect the positive and negative wires from the speaker to the 2 connections labeled on the crossover as W(woofer)+ pos and W(woofer) -- neg,hook the tweeters to the crossover connections labeled T(tweeter)+ pos and T(tweeter) -- neg,then hookup the 2 remaining connections labeled Amp to your amplifier,amp must be 2 or 4 channel stereo capable and give out enough power to properly drive the speakers so they achieve optimal performance.

Mar 05, 2011 | Alpine SPR-17S Car Speaker

1 Answer

I just install my new setup ,i have 1 pdx f4 ,1 pdx m12 and 2 sub 10''type r and my pproblems is when i put a song the pdx f4 lights become red and my mid and tweeter cut ...


Disconnect all speaker leads from the PDXf4 - test. If the amp turns on and says on ok - then turn off, and attach one speaker lead at a time until it turns off. When it does check that speaker and the speaker wire to see if it is blown, shorted out etc.

Feb 06, 2011 | Alpine PDX-F4 Car Amp

1 Answer

How do you bridge an Alpine PDX amp


you have 2 + and 2- right? twine both speaker wires together. like + to + and - to - and then pick only 1+ and 1- to hook up and then you should double the power to the speakers only

Mar 20, 2010 | Alpine PDX-4.100 Car Audio Amplifier

1 Answer

PDX-1.600 no sound from speakers


check your coil wires on the back of the sub

Apr 11, 2009 | Alpine PDX-1.600 Car Audio Amplifier

2 Answers

Channel 2 crackles


Make sure your speaker wiring does not come close to the 12v power cable running for your amplifier. If your amplifier's 12v power cable runs on the drivers side of the vehicle, run your speaker cables on the passengers side and make sure your tweeters have a high pass filter to stop any pickup of engine sound (When you are driving you *WILL* notice it at high RPM. a HPF (High Pass Filter) will also stop those nasty hissing sounds on S's.

Feb 11, 2009 | Alpine PDX-4.100 Car Audio Amplifier

2 Answers

PDX 4.100 In Protect Mode..


According to the manual, the issue could be:
  • Internal issue with the amp circuitry.
  • A short on the speaker output(s).
  • Power source voltage is too high (aka above 14.5V).
  • Overheating.
The easiest thing to do is to try removing the connections to the speakers at the amp and see if the issue disappears after each set has been disconnected. Keep removing wires until both LEDs stay blue.

Mar 15, 2008 | Alpine PDX-4.100 Car Audio Amplifier

Not finding what you are looking for?
Alpine PDX-F4 Car Amp Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4836 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Jaime Hernandez

Level 3 Expert

2315 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...