Question about Hoover U5780900 Bagless Upright Cyclonic Vacuum

1 Answer

Low suction when using attachments

I have a wind tunnel+cyclonic There are several areas where it gets clogged up and it doesn't seem to whirl around like it did when I first bought is (March 2008) I clean it out often, even before it gets to the full line. Also, when I use the attachment hose, there is hardly any suction. There was not a operation manual in the box when we bought it. Can you help?!

Posted by on

  • jlhenn1 Jan 19, 2009

    Thank you for telling me about the filter above the dirt tank! I didn't know there was one there. I took it out and it was full! After cleaning it and putting it back in, I turned on the sweeper and it had powerful suction again!
    I also downloaded a manual.
    Thanks again for the great help!!


×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 294 Answers

Have you cleaned the foam filter? located above the dirt tank after you remove it. the manual can be downloaded from the web site at www.hoover.com ; sounds like an obstruction in the hose or elbow on the back of the unit. the hose can be cleared with a broom hadle when you take the hose completely off the vac.

Posted on Jan 17, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Dirt Devil Dual Cyclone - low suction, can't find clog, trying to take apart


Hi There
After the extensive checks you have carried out. May I respectfully suggest you check all your air filters, as a 'clogged up ' filter will produce the same kind of symptons as a blocked pipe. There is a very strong possibility that a filter on the machine is clogged and that's what is casing your problem

Apr 12, 2014 | Dirt Devil Reaction Twin Cyclone Upright...

1 Answer

Loud rattling noise and no suction


You have something that's been sucked up into the floor cleaning part of the machine... then clogged it off. Be persistent and you should be able to find it and get it out..

Nov 04, 2013 | Hoover Vacuums

1 Answer

My Hoover UH70040W Wind tunnell mach cyclonic has stopped sucking up debris. At the brushes you feel no suction and when you disconnect the tube on the side it has some suction but not much at all. The...


Well if the vac motor is good then its either a clog or a leak ,if you say no clog then it has to be a leak. Make it blow out and see where the air is coming out or try and find it while it is running with a piece of typing paper loosly around the hose and piping. Seals at the connection areas go bad so check them as well.

Mar 31, 2011 | Hoover UH70040W Bagless Upright Cyclonic...

1 Answer

No suction when using the hose.


The beater bar is supposed to stop when the vac is upright. Sounds like you have a clog. There are several access points to check, fairly easy to clear obstructions.

Nov 14, 2009 | Dyson DC07 Animal Bagless Upright Cyclonic...

1 Answer

No suction on wind tunnel vaccum cleaner


Your brush might be clogged with hair. while uplugged, flip over the vacum and check to see if there is any hair or string wrapped around the brush...

Jun 03, 2009 | Hoover U5194-900 Mach5 Multi-Chamber...

1 Answer

Low Suction When Using the hoses on the Dyson Animal


there is a washable filter either on the side of the motor or in the dust cup clean it out using water make sure it is dry before reinstalling also check for clogs there are several pices that are removeable the peice under the hose and vent clip? on the side remove and check for clogs

May 22, 2009 | Dyson DC07 Animal Bagless Upright Cyclonic...

1 Answer

LOSING SUCTION


is brushes moving, if so it is clogged , usually takes a star bit to take apart to clean

Feb 07, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

I have little suction when using the hose attachment


Check the hose for a blockage. If you remove the hose, if there is suction at the point where the hose hooks to the back of the vac, then the hose is clogged. If no suction there, check filters, make sure they are clean.

May 31, 2008 | Hoover Company Wind Tunnel U53019 Upright...

1 Answer

Hoover wind tunnel self propelled U6617-960


http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=40485&thid=557365
Hoover Windtunnel self propelled U6617-960
Posted by srkelly on Apr 29, 2008
The vacuum has no suction at the floor. I have checked the hose, and no blockage. When I try to use the attachments, still no suction. What could be the problem.

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
Hoover U6437-900 / U6439-900 Windtunnel upright Vacuum
You definitely have a clod between the tube by the brushroll area and the attachment hose and the best way is to take a wire hanger and make a little hook on the end to see if there is a clog, the clog is closer to the fan area and anything big would clog up the area sideways and
-- you may have to remove the top cover to see if there is a clog and to better get @ it from the top. Another suggestion is to do a belt change whether you have one or 2 belts on the vacuum and to change the belts @ the same time every 4 to 6 months. Also, check you owner’s manual under trouble shooting to see if there is something else, other wise that is what I think is the problem. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Don – The Vac Man
Go Ahead. Use Us.

Apr 29, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Wind tunnel hoover


Do you have suction at the hose end, if you do then it may be clogged at the inlet by the brush roll. Is the filter cartridge clean? If it is clogged and air can't pass thru it, then you will have no or low suction. Might also check the belt to make sure it is turning.

Nov 30, 2007 | Hoover U5753-900 WindTunnel Bagless...

Not finding what you are looking for?
Hoover U5780900 Bagless Upright Cyclonic Vacuum Logo

147 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18297 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...