Question about Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

Open Question

Roller brush on/off switch on hoover windtunnel u6401-9rm broken

We have checked both belts and even replaced the v-belt with an extra and there is no difference. the problem seems to be with the brush roll on/off switch. it seems that the v-belt should be slack when in the ''off'' or ''floor'' position and taut when in the ''on'' or ''carpet'' position. we would like to do the repair ourselves. what part(s) do we need and how do we go about the repair?

Posted by on

  • kiki_vandenb Jan 20, 2009

    this is clarification for the issue. it seems the roller brush switch is broken (or, according to elektek, it could be the idler assembly). the switch moves back and forth freely where before there was some resistance.
    both belts are in perfect condition. one was changed recently.

  • Robert Pagliaroli May 11, 2010

    What is your exact problem with the vac? from your description I gather that the roller does not spin This model, when in the upright position, the roller will not spin ( the v-belt will be loose) regardless of the carpet switch position. When tilted back to use, this is where the switch position determines if the v belt is taught or loose as to when it engages the roller. If you had changed the v belt when the vac was in an upright position and just turned over, then yes, the v belt will be loose. The proper way to change the carpet mode is to tilt the vac forward and move the carpet switch to on or off.

    If all of this check ok, and changing the carpet switch has no effect on turning the roller on then the switch may be broken, or the idler assembly that engages the v belt belt. Check or change the flat belt - thi drives the roller as well as your self propelled operation (should be replaced anually)

×

6 Suggested Answers

reddevil6
  • 1673 Answers

SOURCE: Hoover Windtunnel

Sounds like you have a bad brush roll(48414115), take it out and see the the ends turn freely or not, if not, then replace it. Also check the the slots that the brush roll sits in to make sure they haven't melted. I am assuming that the motor is running, if not, then it may have froze up.


e6c90bc.jpg

Posted on Feb 28, 2008

mattozan
  • 555 Answers

SOURCE: Hoover Windtunnel U6401-9RM turns it self off

How old is this vacuum? Have you made sure that the filter is clear?

Posted on May 21, 2008

  • 2 Answers

SOURCE: Belt Stretched on my Hoover Windtunnel Farrington upright model U6431-900

hi, In order to to replace the V belt the one that turns the brush, One must take off the bigger belt " drive belt" that goes over that hugh wheel towards the back. When a belt gets stretched they will not turn the brush very well. If you have bought replacement belts the bigger belt Drive comes 2 in a package. Then you have your little V belt that helps turn your roller brush over. Yes the belts don't last long on my hoover. For kpatr22101 When you rpelace that V belt it goes over the roller brush into a little groove on the brush and then over a plastic round wheel then you must put on that bigger drive belt that must fit over that hugh wheel towards back and smaller on in front. Yes it is hard to get on. the I hope this helps. Cindy G.

Posted on Aug 16, 2008

reddevil6
  • 1673 Answers

SOURCE: Brush Roll belt won't engage on WindTunnel self-propelled

When you had the brush roll off, did the ends turn freely? If not then the brush won't turn and the belt will just slip. You would have to replace the brush roll if either of the ends are frozen. Other then that you would have to remove the top cover to see if there any broken parts, there is a spring loaded asm, it has a black wheel that will push the V belt when it is in the carpet setting and the handle is in the down position, it could be jammed so the roller is stuck.

Posted on Sep 18, 2008

landsend
  • 1066 Answers

SOURCE: hoover windtunnel vacuum roller brush doesn't

does the motor turn?  if it does replace the belt.

Posted on Apr 04, 2009

  • 1 Answer

SOURCE: Hoover WindTunnel Self-Propelled V Belt

when you released the end to slide the new belt on it allows the tension roller to slide into the wrong position. Remove the top so that you can see the roller, at the left side of the roller mechanism there is a screw, loosen it enough to allow the roller to return to the correct position.
good luck

Posted on Jul 29, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I replace the belt for this model


Make sure vacuum is not plugged in to power outlet. Lay it upside down and remove 4 screws from bottom plate covering brush roll. Remove bottom plate and pull the brush roll out. Clean hair and debris from brush roll and make sure it spins freely. Remove end caps from brush roll if possible and clean debris out. Install new belt around motor shaft then insert brush roll into belt and pull on brush roll to give you enough leverage to stretch belt far enough to put. Brush roll back into position. Reinstall bottom plate and screws. Make sure brush roll will turn before turning vacuum back on. Belt will lose elasticity and should be replaced twice a year.

Jan 17, 2015 | Hoover U5434-900 WindTunnel Plus Bagged...

1 Answer

Brush is not rolling. I have checked the belts


Unhook the belt see if the motor shaft turns by itself. If it doesn't then the motor is the issue. If it runs then its probably the belt or the brush roll.

Dec 01, 2009 | Eureka Altima Upright Vacuum Model 2996AVS...

1 Answer

I have a Eureka Altima and not sure how to change the belt?


1) Use handle release to lower handle
flat onto floor
2) Remove 2 screws from the front side of
brush roll cover
3) Lift and remove brush roll cover .
4) Remove brush roll and belt. Thread
new belt around motor shaft and
brush roll
5) Insert left end of brush roll first. Make
sure square on brush roll cap is in
place. Pull right side of brush roll to
stretch belt. Secure right end cap into
base.
6) Rotate brush roll 2 turns to center belt.
7) Replace brush roll cover
8) Replace 2 screws

And you can get the maual here.

http://www.eureka.com/service/manuals/80244.pdf

Good luck

Sep 27, 2009 | Eureka Altima Upright Vacuum Model 2996AVS...

1 Answer

WHAT'S THE EASIEST WAY TO INSTALL BELT?? I KEEP BURNING BELTS.


First check to see if the brush rolls freely with no belt in place. If not remove the brush roll and clean and lube the end caps. If the caps are nylon try to gently pop them off to inspect underneath.
Clean the motor shaft with extra fine wet dry sandpaper, then install the belt around the shaft and onto the brush before engaging the brush in it`s socket. Now use the brush to leverage into place.Check again for free smooth rotation, then replace the cover plate

Sep 06, 2009 | Bissell 3576 CleanView II Bagless Upright...

1 Answer

Flat belt on Hoover Windtunnel requires to be replaced regularly


No it is not normal. The brush roll may be bad causing extra stress on the belt. The other option is the belt is installed incorrectly. I believe this model has a brush on/off option and the belt must be correctly installed around both the motor shaft and the shaft for that brush on/off switch.

Apr 15, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

Hoover WindTunnel Self-Propelled V Belt


when you released the end to slide the new belt on it allows the tension roller to slide into the wrong position. Remove the top so that you can see the roller, at the left side of the roller mechanism there is a screw, loosen it enough to allow the roller to return to the correct position.
good luck

Mar 23, 2009 | Hoover U6441-940 WindTunnel Bagged Upright...

1 Answer

Brush Roll belt won't engage on WindTunnel self-propelled


When you had the brush roll off, did the ends turn freely? If not then the brush won't turn and the belt will just slip. You would have to replace the brush roll if either of the ends are frozen. Other then that you would have to remove the top cover to see if there any broken parts, there is a spring loaded asm, it has a black wheel that will push the V belt when it is in the carpet setting and the handle is in the down position, it could be jammed so the roller is stuck.

Jul 16, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

"brush bar spins erratically"


Belt needs to be replaced, it has stretched to the point that under load, it won't turn the brush roll like it should, so I would advise replacing the belt. And while you are doing that, check the brush roll and make sure the ends turn freely, if not, then replace it also. Then check the dirt inlet while you have the brush roll out.

Feb 29, 2008 | Dirt Devil Vision Turbo W/Bonus Upright...

1 Answer

Eureka vacuum belt how do i replace on model #4688


How To Replace Brush Roll Belt
NOTE: Turn off the switch and unplug the electrical cord
before replacing belt. Belt pulleys can become
hot during normal use. To prevent injury, avoid
touching the motor shaft when checking the belt.

1. Lower handle to floor to change belt.
2. Loosen, but do not remove, two screws to release hood.
Lift hood to remove.
3. Lift left end of brush roll.
4. Remove and discard belt.
5. Place new belt around motor shaft.
6. Place belt around brush roll pulley.
7. Align left end cap with base. Push end cap
securely into place.
8. Pull right side of brush roll to stretch belt.
Secure right end cap into base.
9. Rotate brush roll to seat belt.
10. Replace the hood. Make sure hood front is
behind furniture guard. Hood should seat
onto self-locating screw tabs.
11. Tighten screws.

You can goto this website enter in the model number 4688 and you can see detailed pictures of how to change the belt as well as print off a new user manual.

http://www.eureka.com/servlet/FindOwnersGuide

Regards

Feb 14, 2008 | Vacuums

1 Answer

Brushes not turning


Check the belts, there ia cogged belt that drives the brush roll. Turn the unit over, take out the one screw holding the red lock, pull that off then the cap for the brush roll will pull out, remove the cap and check the belt, also check the pulley on the end of the pump to make sure that it still has cogs on. If there are no cogs, then you will have to replace the pump. While you have the brush roll out, make sure the it looks ok on the end and not melted. This would also be a good time to replace the **** belt if it needs it.

Jan 07, 2008 | Bissell 1699 ProHeat Clear View Upright...

Not finding what you are looking for?
Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum Logo

Related Topics:

1,231 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...