Question about Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

1 Answer

Hoover Windtunnel spits dirt back out the back

I have checked every filter and the belt. My Hoover Windtunnel U5767 will not pick up from the bottom, although the hose cleaner has a great suction. I am at my wits end with this thing!
Any help is appreciated.

Posted by on

  • 1 more comment 
  • mjfallert Jan 17, 2009

    Thanks. I changed the belt which was somewhat stretched but found the problem in the very bottom of the unit where the hose goes into the unit. There was a very large amount of "stuff" clogging is up. Thanks.

  • Anonymous Mar 14, 2014

    where is the dirt sensor on a Hoover Windtunnel anniversary edition vacuum

  • Anonymous Mar 24, 2014

    The attachment hose works fine but the floor vac picks up and blows dirt and dust out the back.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 294 Answers

Your problem sounds to be an obstruction in the foot (lower body) of the windrummel. Most all windtunnel's have a second cavity for suction to go over the top of the roller. When you remove the bottom plate, next remobe the belt and roller, under the roller will be a removable cavity, take it out. remove the dirt and clean out any debris. also check the suction path connecting hose. if your belt has not been changed in the last 12 months, I would recommend changing that as well.

Posted on Jan 17, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why would a Hoover Windtunnel have no suction?


It could be clogged at the head or throat, or you might have a hole in the hose. Unplug the hose; if you're getting suction where the hose plugs in then the problem is in the hose or the head. If you're not getting suction where the hose plugs in then the problem is in the body, probably the throat. If the problem is in the hose or head, detach the hose from the head and check for suction at the end of the hose. If there's not suction there, then you've got a clog or a hole. If there is suction there, then you've got a clog in then head.

May 20, 2014 | Vacuums

1 Answer

My Hoover windtunnel has very little suction. I have cleaned the entire vacuum. Cleaned filters. My Hepa filter is a little torn, don't know if that could be issue. After cleaning it does suck a tad bit...


Is the belt still intact?
Does it has a wand tool, normally they are connected at the bottom of the machine,if it gets plugged up with gunk, that will greatly reduce your suction.

Aug 31, 2013 | Hoover WindTunnel Purely Pet Vacuum...

1 Answer

My Hoover Bagless Windtunnel vacuum has no suction on the bottom, although the hose works. Everything else seems to be working properly.


Check the belt, look like we have the same problem, I just unscrew the bottom part where he brush roller is located and found a broken belt
Easy to replace just follow this instrctions
">

Jan 31, 2011 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

I have the bagless hoover windtunnel and it doesn't pick up anything and it is very hard to push. Changed the belt and The rollers are spinning and the filter has been changed. What else can I do?


It sounds like there are dirt and hair wound around the wheel axels cousing them not to spin freely. You have to remove all hair and carpet fiber. Then drop a drop of lubricant oil on the axel.
Change the filter.
You should even Check the floor nozzle for clogged dirt.

BR
Bruce

Aug 27, 2010 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Hoover self-propelled windtunnel U6430-900 flat belt gets hot & becomes hard to push. It has a filter bag. Purchased 8/2/01. Took one plate off bottom. Used a compressor to blow out dirt & dust. ...


Belts get hot when fibers from carpet get wound arounf the belts mounting shaft. Best to take a razor and cut off any fibers so the belt doesn't get hot again

Aug 10, 2010 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Bag was not on good, resulted in dust,dirt, dog hair everywhere...have cleaned pretty thoroughly but vacuum does not have any suction. After taking apart did find that the larger wide belt is broke but I...


Greetings from GoVacuum,

There are two things that you should check on this vacuum after running it without a bag inside. The first thing you should check is the filter that is underneath of the vacuum bag. This filter is underneath of a bracket, and the bracket can be removed by pulling straight up on the bracket. The bracket and filter are directly below the vacuum bag inside the vacuum bag housing. If the machine was run without a bag (or the bag fell off) then this filter is most likely going to be extremely clogged. You can simly remove the filter, and run it under hot water until clean. Make sure the filter is 100% completely dry before putting it back in the vacuum and using it. Running the vacuum with a wet filter will destroy your motor.

Now in terms of the belts. Where as the belts don't directly control the suction of the vacuum cleaner, they certainly facilitate the pick up of dirt and debris on the floor. Many people assume that since the vacuum is not picking up from the floor, then the vacuum doesn't have suction. You can test this by pulling out the attachment hose and feeling for suction, is there suction at the end of the hose? If yes, then the reason the vacuum is not picking up on the floor is because of the belts. If you don't have suction at the end of the hose, then you have a clog, some where or a dirty filter.

The belts actually are what spin the brush, and the brush basically sweeps the carpet, and throws the dirt and debris into the suction port, and when the dirt and debris are near the suction port, the suction then takes over and takes it to the bag.

There are two belts on this model, it's best to replace both of these belts at the same time. If you replace just one, then the other belt will wear out quicker. It's always best to replace these two belts in conjunction.

The two belts that are used on this vacuum are:

Hoover Windtunnel V-Belt Part 38528034

Hoover Windtunnel Flat Belt, Hoover Part 38528035

Once you have the belts, and you're ready to replace them, here's a great video that we shot here at Govacuum.com that shows you exactly how to replace these belts, as well as some basic maintenance on your roller brush;





I really hope that my repair solution was helpful to you in fixing your vacuum cleaner. If you have any further questions about this repair, or any repair, feel free to contact me at chris.jones@govacuum.com, or request a clarification here on Fixya.

If you did find this repair solution helpful, please kindly rate this repair helpful by clicking the 4 Thumbs Up Icons in the top right hand corner of this solution.

Thank you very much,

Chris Jones
GoVacuum.com

Mar 19, 2010 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

The windtunnel vacuum has suction but does not pick up the dirt. I'm puzzled as to what might be the problem. Help!


The problem is that the belts are stretched and worn and slip instead of turn the brush when it is put against the resistance of the carpet. You simply need to replace the belts. Here are the (2) belts you need and the manual with instructions:

Hoover self-propelled windtunnel belts

Manual

Jan 02, 2010 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Vacuum is spitting dirt and debris out the back--what can I do?


the first thing you should do is clean out the container then check the filter if it looks dirty with a lot of dust it probably needs replacing.
check the hoes for dirt that might stick up.if the problem continues it needs a service.

Jul 30, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover Bagless WindTunnel vacuum cleaner.


very easy. you have clog. take the brush off look where the hole is thats where the clog is. it might be in there you might have to take the housing off of the motor

May 08, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover windtinnel suction problem


the intake hos at the bottom might be clogged.first take all the filters out and disconnect the hos completely from the vacuum,then check and see if you have suction.the intake hose is the clear looking one at the bottom that wrapps itself up from the base to the backside of the upright.you can use a coat hanger to push out the clog if there is one just bend the tip till its rounded.work it down into the intake hose from the back.after removing the hose and the filters you should have suction.just make sure all the filters get cleaned .you can blow out the hose with a garden hose

Apr 02, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum Logo

761 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18385 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1456 Answers

Brad Brown

Level 3 Expert

15220 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...