Question about Polaroid TLA-01911C TV

2 Answers

Polaroid 19" TV TLA-01911C has no picture. Powers up, see logo

Sound comes on, See channel number,...then screen goes black.
Sound remains clear. Can you help?

Posted by on

  • ladydi97 Jan 30, 2009

    Same problem .TV was purchased 7/18/07. When tv turns on it makes a scratchy sound. The Polaroid logo comes on, channel number and then blackness...only sound.

  • Anonymous Mar 15, 2014

    Polaroid TLX-01911C 19" TV No Picture (Black Screen) and No Sound. Which Board do I replace? Power Supply or Main?

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 19 Answers

To add to this solution above - I had the capacitor replacement and there was still an issue. Turns out the solder connection to the lamps themselves was very very poor causing an electrical arc (the scratching noises people are hearing) - then the inverter shuts the lamps down as it should. Fix lights!

Posted on Dec 10, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I had the same problem. I replaced 14 capacitors on the Power supply board. I used Panasonic FC series. You could look for swollen capacitors or ones that are oozing. For sure replace these. My set had capacitors that are known to cause problems so I replaced all of them even though I saw no swelling of oozing. Be sure you label all connections carefully when you disassemble.

Posted on Mar 31, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Fix sound on Polaroid TLA-01911C TV


Audio amp may be blown. A cable may be bad.
What are you connected to?

Apr 04, 2014 | Polaroid TLA-01911C TV

1 Answer

POLAROID TLA-01911C turns on but only white screen. no sound


Hello
The main board has the fault. Your set need a thorough check before confirmiing the fiault.
This is the picture of the board. OK.
2_16_2012_4_20_33_pm.jpg

Feb 16, 2012 | Polaroid TLA-01911C TV

1 Answer

I have a polaroid TV model # TLA-01911C. It has sound but no picture. Just black screen.


Check the power supply and the voltage feeding th baclight inverter board.
Parts:
http://www.shopjimmy.com/catalogsearch/result/?q=TLA-01911C

If you are going to DIY and have proper tools, knowledge of electronics and know safety precaution then please read on:
Please see my basic troubleshooting guide here:
http://www.fixya.com/support/r5093881-lcd_flat_panel_tv_troubleshooting_guide

http://s807.photobucket.com/home/budm/allalbums

http://en.wikipedia.org/wiki/Capacitor_plague

Jul 12, 2010 | Polaroid Televison & Video

2 Answers

PROB LEM WITH POLAROID TLA-01911C


Hello,

The white screen and nothing else usually indicates a failure of the filter capacitors in the power supply board. When these capacitors go out the voltages are not correct so the TV can not power up right. You can rebuild the power board by replacing the bad capacitors and this should bring the TV back to life. Here is a link to a repair guide for this power supply board.

http://www.ccl-la.com/blog/index.php/repairing-a-polaroid-tla-01911c-with-a-bad-power-supply/

I hope this helps,
BuddyMc

Dec 28, 2009 | Polaroid TLA-01911C TV

1 Answer

Hi my tla-01911c tv powers on and displays the polaroid logo on the screen for about 30 secounds then shuts down as if there is a power overload or something. any ideas? thanks


Either the power supply/inverter board is bad, or the bulbs are bad - or poorly connected. In my case, the solder joints at the end of the bulbs in the top and bottom were horrible. A quick resolder on the corroded bits and good as new.

Dec 20, 2009 | Polaroid TLA-01911C TV

3 Answers

Loss of picture


change your inverter

Sep 17, 2008 | Polaroid TLA-01911C TV

2 Answers

Will Not Find A Signal Polaroid HD 15" TV - Model TLA-01511C


same (tla-01911c) issue when trying to watch over the air brodcast try rescanning the channels that normally works for me

i got direct tv basic set on my S-video input so i only need over the air when the sat is down (i.e: storms, wind, snow, ...)

May 15, 2008 | Polaroid TLA-01911C TV

2 Answers

Need code


I called one-for-all and got a repair number and then sent the remote to them to have the codes added.

Dec 13, 2007 | One For All URC4220 Remote Control

Not finding what you are looking for?
Polaroid TLA-01911C TV Logo

804 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polaroid Televison & Video Experts

Dave Naylor
Dave Naylor

Level 3 Expert

834 Answers

The Knight
The Knight

Level 3 Expert

71088 Answers

matt martin
matt martin

Level 3 Expert

1207 Answers

Are you a Polaroid Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...