Question about Bissell 1692 PowerSteamer Upright Vacuum

1 Answer

Brush not turning and no suctions !

My powersteamer model 1692-c .
When the switch is on, motor is running but no brush turing and suction.
checked the belt but OK. Gear which turns the belt is not turning !
pls help

park

Posted by on

  • 1 more comment 
  • yhpark0485 Jan 16, 2009

    Dear reddevil6,

    thank you for ur reply.

    cogs on the belt are OK.

    Pulley turing belt is NOT turning when swich is ON.

    i did not see flat belt, red plastic screen.. where are they located ?also i do not understand oblong gasket,clear window so on..

    video or picture would help, If they are able,,,

    thank you

  • yhpark0485 Jan 28, 2009

    Finally I managed to solve the problems by replacing belt etc...

    Now brush is turning and good suctions BUT the cleaing solution

    liquid is not discharging continuously when the lever is pressed.

    therefore CAN NOT Clean the carpet. it discharges the cleaning

    liquid a little bit and stops...

    Is there problem in my pump??

    pls help...

  • spruce2us Apr 08, 2009

    need instruction on how to install the gear belt.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

If the cogs on the belt and brush roll are ok, then probably the cogs on the pulley are worn off, or the pump isn't turning, is the flat belt ok? If all of this is ok, then replace the pump, part # 2107181If no suction, is the black oblong gasket on the top of the clear window. It seals the gap between the tank and the window, no suction if it is gone. Also should be a red plastic screen on the edge of the tank lid, it may be clogged.

Posted on Jan 16, 2009

  • Lauren Junge
    Lauren Junge Jan 28, 2009

    On the left side there is a small door you can rmove, check the flat belt, make sure it is tight, if loose, replace it. Is the top locked down in the back, if it has broken loose, the top will have raised and can't **** the water from the tank. Is the gasket on the bottom of the tank valve, if it isn't and is sitting loose in the hole, then re-install it onto the bottom of the tank. Pump may be bad.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi, i have a panasonic eco max, the brush has stopped going round, the belt is as new and brushes clean.suction good from hose. Any ideas please? thank you


The brush on this model is controlled by the on/carpet/floor switch and will only work in the carpet position. If the suction motor is running then it could be the roller brush motor, but it's more likely to be the microswitch which stops the brush motor when the handle is returned to the upright position.

Dec 03, 2012 | Panasonic Mc-Ul594 Eco Max - Bagless...

2 Answers

Dyson dc17 No suction


i have the same problem and none of these solutions help. they are all for if suction works but brush doesn't. that isn't what she is saying. brush motor works fine. It's the Suction motor that never kicks on. Mine is doing it now and I would love a fix for it. Resetting suction motor. Not brush....

Jan 02, 2012 | Dyson DC17 Animal Bagless Upright Cyclonic...

1 Answer

No suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Euro-Pro EP602 Bagless Stick Cyclonic...

1 Answer

Great suction through handle, no clogs anywhere,


OK - there are two obvious things to check: 1. Make sure the brush is rotating. The DC14 has a 'brush control system" operated by a knob on the base in front of the right side wheel. Make sure this hasn't accidentally been moved to the "off" position. With it in the "on" position, switch the machine on, tilt the handle back and check that the brush roll is rotating. If it isn't, then there's a broken belt or a problem with the clutch mechanism in the brush control system. 2. If the brush is rotating, switch the machine off (and unplug it), turn it over and you will see a short length of clear plastic hose with spiral reinforcing that runs from the brush area to the motor. That hose often develops a split (which lets air in and reduces suction around the brush). Take that hose off (pull it off from the motor end and then unscrew it from the brush end) and inspect it carefully for any damage. If it is damaged, get a new one - don't try and repair the old one, it's not worth it.
I hope this helps - if so, please remember to rate my response. If you need more help, just post a reply here and I'll see what more I can do. Good luck!

Feb 10, 2010 | Dyson DC14 Full Access Bagless Upright...

1 Answer

No Suction/Brush not spinning on Bissell Powersteamer Pro Deluxeb


make sure hoses are clear and check belt

Oct 08, 2009 | Vacuums

2 Answers

Brush doesn't spin and there is no suction there either, the brushes move freely when manipulated manually


Check for clog in the hose or what ever connects the nozzel to the collection device. I pick up vaccum cleaners all summer, most new, all clogged, all from the trash.

If possible, take the machine outside, open the collection device, run the motor. Is there suction you can detect anywhere?

Sep 07, 2009 | Dyson DC07 Animal Bagless Upright Cyclonic...

1 Answer

No suction


You have a clog somewhere in the vacuum. Check the hose and the little trap door on the underneath side of sweeper.
Does the brush turn? If not, then the belt that drives the brush is broken. Replace the belt

Jim

Jun 08, 2009 | Hoover Tempo Widepath Upright Vacuum -...

1 Answer

No suction, belt is good and turing brush


take off the bottom cover, and see if something is clogged. trace it all the way to the impeller

Apr 14, 2009 | Vacuums

1 Answer

Motor works, but no suction! what do you think?


No suction usually means a clog somewhere or bad filters. The hose and/or the dirt inlet by the brush roll may be coulded. The belt may have stretched enough to not turn the brush roll under load and that can seem like no suction. The worst is the motor is running at full speed, which would mean replacing the motor.

Apr 24, 2008 | Vacuums

Not finding what you are looking for?
Bissell 1692 PowerSteamer Upright Vacuum Logo

Related Topics:

244 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18333 Answers

Roger Potts

Level 3 Expert

694 Answers

Brad Brown

Level 3 Expert

13819 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...