Question about NAD C320 2-Channel Amplifier

1 Answer

Nad C320 right channel stops working then comes back again

Hello, I've had the amp for a few months, worked fine until now the right channel stops working after a few minutes. if i turn it off and on again, both channels will work for a little while, but then the right one dies. I tought it was somehting with the cables, checked them and they seem ok. also, the same thing happens if i put headphones into it, so i'm guessing it's a sort of an "input" problem.

Posted by on

  • 2 more comments 
  • cristi_j Jan 15, 2009

    just noticed, if i turn the ballance fully the right and the volume up all the way, there is sound coming from the right speaker, but it's really low volume.

  • cristi_j Jan 16, 2009

    Did 1,2,3.
    The tape monitor led turned orange a month ago, and remains on, whether you press it or not. I have now connected it via the AUX thinghy (was on CD before), and it keeps on working for the past 8 hours, when yesterday it died after 15 mins. So I’m guessing problem solved for now, can’t believe I didn’t think of this before.
    If i press the tape monitor button while the amp is on, and then try to press the other controls CD, aux etc, they will turn green, but nothing will happen.
    I can do basic soldering, but I'm a bit far away from home and haven't got a soldering iron. I haven’t opened the case yet, and to be honest I’m not that eager to do so, considering it works fine right now.



  • cristi_j Jan 17, 2009

    well, looks like i'm not that lucky.
    it worked perfectly fine yesterday for about 14 hours, today when i turned it on the right channel didn't work at all, regardless of what input I used.


  • Jsonp Feb 02, 2009

    I have the same problem but mine never came back on. when it happend I smelled something burning. Now the right side don't work . you can turn up the vol and barely hear sound. Left side works fine. This is a 60's model stereo receiver. Model #2230. It's been in the family sence it was bought new. Pleeease help me fix it! I do know my way around a solder gun. Thank you in advance.........

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,234 Answers

This sounds like the "pre-amp" section is cutting out or there is some interruption in the signal path. A few things to try:

1) With the unit off, try "working" the volume,balance and tone controls. This means, turn them up and down a number of times to clear any debris that may be in the controls themselves.

2) Work the input selector switch the same way if it is a rotary switch.

3) Try turning on/off the tape monitor switch a few times.

4) Keep track of whether this problem is sensitive to heat. Does teh channel shut down more quickly once the unit has been on for a while?

Lastly, if you can solder, look for any solder joint that appears grainy or has rings and resolder it.

Update this with your results and we'll continue on...

Thanks,
Dan

Posted on Jan 16, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

NAD C320. Only one channel sounds. Problem with the volume control?


Did you try to switch the loudspeakers? Before changing anything always lover the volume and switch off the amplifier.
Assuming you tested already different inputs, you can be sure no cable from signal source is out or defect. (or did you nit check that first?).
When the amp is switched off, disconnect the speakers and switch left to right and right to the left output.. If the other speaker is quiet now, you are sure it is in the amp. Still his can be anything.
You can check the connections between the pre and main amplifier on the back side. When you have an extra set of interlink cables, perhaps you can cross the in and output there too. Take care every time you change something, lower the voltage and switch off the amplifier. Sudden clicks when switching on or changing anything can damage the amp and or the speakers.

Perhaps when you checked this you can locate where the problem is? Speaker, speaker cable, power amp, pre amp, (only a part of the pre amp.

Nov 12, 2013 | NAD C320 2-Channel Amplifier

1 Answer

NAD 272 Channel drop out


well..this is one for the books. Can you tell me what the ratings are between the 252 and the 752 impedance matching wise? even though it might work sometimes, impedance matching can wreak havoc between mismatched amps.

what are you driving from the 752 into the 252?

Mar 10, 2008 | Amplifiers & Preamps

1 Answer

How to connect an MP3 Player to NAD C320?


You will need a cable with headphone jack (for mp3) and RCA left/right to connect to your NAD 320. You can connect to CD or AUX in the back and then you will need to change the input with remote or with on board buttons to CD or AUX depending where you plugged it.

Jun 20, 2012 | NAD C320 2-Channel Amplifier

1 Answer

My NAD C320 outputs a very low sound volume


Hi there I have a C340 that has similar problem, you must have bought this from ebay, lol.

Nad made a mistake on the C range, the pre - power link can be shorted out. if the pre is shorted out it takes out the pre amplifier stage, I have managed to get the right channel working, I will keep you informed what is the cause of the left channel. I have replaced the pre-amp IC and a couple of Jfets and transistors. Once I have repaired the Amp I could repaire yours if you like???

Apr 14, 2012 | NAD C320 2-Channel Amplifier

1 Answer

Lighter does not work in Mercedes C320 ...pleas advice...Mike


There should be a separate fuse for the lighter 10-20 amps?

Oct 12, 2010 | NAD C320 2-Channel Amplifier

1 Answer

I have purchased the NAD C320 used. Have been


yes send it back chances are there could still be a warranty on it and that should be covered by it dont mess with it that could invalidate the warranty even if its not in warranty to replace the switch wont cost much.As for the contact cleaner be careful it is flamable and an arcing power button could ignite it do this with the unit unplugged but also make sure its dry after too do not do this unless you find the warranty has expired. Hope this helps

Oct 28, 2009 | NAD C320 2-Channel Amplifier

1 Answer

AUX problem between my laptop and NAD C 320BEE


HI...
I would check on the Soundmax software set-up on the PC and make sure that the AUX is set for a line-out connect.
Also,make sure the tape monitor isnt on ..On the amp

Mar 01, 2009 | NAD C320 2-Channel Amplifier

1 Answer

PreAmp to Amp problem


Sorted it. You have to put the plugs back in the PreampOUt/Main in or it cuts out the pre-amp.

Nov 18, 2008 | NAD C320 2-Channel Amplifier

1 Answer

The right channel on my NAD intergrated amplifier C320Bee no longer works.


if you did test for your cable and speaker and you find it fine-your problem will be in output stage of your amp and needs aid of service center.

Jun 11, 2008 | NAD C320 2-Channel Amplifier

1 Answer

Speaker connection heat up


NAD is know for loose connections, you have to get to the bottom of the pc board and look for cracked solder or solder that doesn't look shinny anymore.

Dec 05, 2007 | NAD C320 2-Channel Amplifier

Not finding what you are looking for?
NAD C320 2-Channel Amplifier Logo

419 people viewed this question

Ask a Question

Usually answered in minutes!

Top NAD Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4593 Answers

The Knight
The Knight

Level 3 Expert

68368 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

286 Answers

Are you a NAD Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...