Question about Hitachi 53UDX10B 53" Rear Projection Television

1 Answer

HITACHI 53UWX10BA CLEANED LENS WAS DOING CONFERGENCE AND LOST PIC AND HAD SOUND A FEW TIMES SWITHING ON AND OFF THEN SOUND.WOULD HEAR A CLICKING SOUND AND LOST THAT. NOW THERE IS NO POWER AT ALL. Should I replace the power supply? The power supply CONSISTS OF THE BOARD, WHAT PARTS MUST I REPLACE. PART NUMBERS WOULD HELP. Do I buy a kit? The big screen is 6 years old and the convergence went out 3 years ago. Dan

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 326 Answers

Hi there, Check IC601, C603 for leakage, I601 and vertical pulse detector QN05 for poor convergence check RK42 for open circuit. Best regards, Arpi

Posted on Jun 17, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hitachi 53uwx10ba service mode


are you using an HDMI cable? is it a cheap thin cable or heavy duty?
HDMI cables carry sound but it's possible you don't have it seated completely or it's a cheap cable. or your audio settings on your TV are not set to HDMI if that's the cable you're using. try running your audio setup on the TV Menu.

Dec 03, 2013 | Televison & Video

1 Answer

It take about 15 to 20mins for the pic to clear up how can i fix?


U hear alot of clicking within the 15-20 mins.Yes,than,ur tv the ballast board it also dead,require a new ballast board also.The Ballast board,that board help to ignite the the projection bulb.

Jul 05, 2010 | Hitachi 50VS810 50" Rear Projection HDTV

2 Answers

Was shooting with Canon PowerShot S3 IS and the lens won't retract,screen says lens error,restart camera. I have restarted camera, changed batteries etc... still nothing. You can hear a clicking sound like...


The lens mechanism had probably got some dust, sand or grit jamming it and stopping it from retracting. Sadly the lens will be difficult to repair yourself as it needs to be completly stripped from the camera. Find a good repair shop and get a quote locally.

Feb 08, 2010 | Canon PowerShot S3 IS Digital Camera

1 Answer

Hitachi SimgpleTOUGH 320GB portable HDD - Not recognized


Make sure you are using the right USB cable. Also try on a different USB port (preferred one on the back of the PC)

Can you see the HDD on "Disk Management?"

Also if you hear any clicking sound then the HDD has become faulty.


All the best!

Aug 10, 2009 | Computers & Internet

1 Answer

Hitachi 53uwx10ba turns on & off when off red flashing light/clic


Same problem. Replaced both convergence ICs about 5 months ago. Worked fince since then and just recently no sound, no video, blinking red on front panel and clicking sound. I suspect that the ICs went bad again and blew a resistor or two. I used cheap Chinese ICs instead of the Sanyo ones and thing this is why. I'll be looking at it again and post solution.

Jan 21, 2009 | Hitachi 50SBX78B 50" Rear Projection...

1 Answer

Hello


the clicking is the relay. I would suggest checking the voltage regulators and horizontal output transistors

May 11, 2008 | Hitachi 53UDX10B 53" Rear Projection...

2 Answers

Hitachi 53uwx10ba no sound/picture flashing power light cricket sound


Possible shorted cap C702 ? Open E994 pico fuse.....check
carefully with ohmmeter...all fuses and let me know.....T.

Mar 05, 2008 | Televison & Video

1 Answer

Fuses check ok, dead no power


it could be high voltage cap located by flyback,if you have back off of tv and turn tv on,you will see green led's turn on,(on the board)if they turn off there is a small blue high voltage cap hidden under glue(i believe it's a 102 cap)that would be the one change,99% of time that is what will fix problem

Sep 22, 2007 | Televison & Video

1 Answer

My Vivitar 5386


have u checked battery? and otherwise i duno

Apr 01, 2007 | Vivitar ViviCam 5385 Digital Camera

1 Answer

Hitachi 46ex3bc


I have the same problem with mine. i,m pretty sure that it is the built in surge protector is bad. Try unplugging the tv for 30 seconds then plug it back in and turn it on. If your surge protector has not completely gone bad this might work a few times. mine won't turn on at all anymore.

Nov 24, 2006 | Hitachi 46BX01B 46" Rear Projection...

Not finding what you are looking for?
Hitachi 53UDX10B 53" Rear Projection Television Logo

Related Topics:

104 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hitachi Televison & Video Experts

Jaime Hernandez

Level 3 Expert

2336 Answers

The Knight
The Knight

Level 3 Expert

75424 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hitachi Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...