Question about Ovens

1 Answer

Kenmore ultra self cleaning oven or top heat

Neither oven nor top will heat. Electrical display works says "pre-heat" but never get hot.
Before the problem, I saw gray smoke and smell a different odor. We checked the back of stove, saw no apparent problem.

Can you help me?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I found that the 220 plug had burned out, that was where the smoke came from. The display worked because the ground "prong" was the only one burned. Had to replace the electrical 220 socked and the electrical plug on the oven.

Posted on Jan 14, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why don't top oven broiler and bake elements heat?


we had that problem once. it turned out to be the control switch was broken

Apr 10, 2016 | Kenmore 27 in. Electric Self-Clean Double...

1 Answer

Not sure which model my oven its but it takes a long time to preheat then does get warm enough. I put an oven thermometer in it and if you set it for 400 it beeps that it is up to temperature at 300 then...


I have a kenmore electric range/ultra bake, after using the self-cleaning mode on the oven, I cannot get the oven to heat up when I put it in the preheat mode. What should I do?

Apr 06, 2011 | Kenmore 40494 / 40495 / 40499 Electric...

1 Answer

Display went blank during the self cleaning cycle


Hi, Before you go working too hard to get you oven to go intothe self clean mode(self destruct)....check out this tip...

Self Cleaning Oven Problem


heatman101

" Wish I had read this first. I never would have used the self cleaningoption. Thanks for the info!!

uiitu

Apr 29, 2009 | GE JTP28 Electric Double Oven

1 Answer

Kenmore Ultra bake self cleaning oven is showing code E0 - F2


My oven will not stay on, when started to preheat it will come on for a few seconds and they it will make a beeping noise and the codes E0 F2 will appear. The codes stay on even if the oven is off.

Jan 04, 2009 | Kenmore 40494 / 40495 / 40499 Electric...

1 Answer

My oven is a kenmore gas single, self cleaning oven about 8 years old. the oven will not light. the top of the stove is fine.


Open the oven door and take the bottom panel off. you will be able to see it the hot surface ignitor starts to glow or not. Now turn the oven on and see if the hot surface gets red hot it not that is the problem. Should be able to get the part at a heating and air parts house or a appliance parts house. let me know what you find out. ken

Dec 13, 2008 | Kenmore 30172 / 30174 / 30179 Gas Single...

1 Answer

Kenmore Ultra Bake Oven Won't Heat Up


Turn the breakers off and wait 10 minutes and then on.  If this doesn't clear the problem, you'll need an electronic timer module.  Electrical spikes cause problems like this.

Nov 17, 2008 | Kenmore 40494 / 40495 / 40499 Electric...

1 Answer

MY HOTPOINT SELF CLEANING STOVE


how do I get my self cleaning to come on in my hotpoint stove

May 22, 2008 | Ovens

1 Answer

Kenmore 47779 double oven; lower oven doesn't work after self clean


Sounds like a thermal overload has opened up during clean. It may be mounted on the back.

Nov 02, 2007 | Kenmore 47772/47774/47779 Electric Double...

1 Answer

Our oven's heating elements will not come on althought the display seems to work correctly.


Wekiwa, your TCO, (thermal cutout) probably opened during the high temps in self clean. You will have to remove the back panel and replace it. It should be just under the vent back there. Part number 4450934. You can ohm it out first to make sure, it will show open (no continuity) if bad. This is an easy job, won't take you that long. Kill power to the range before going back there. In doing a little more research on your model, I see there was a service flash where they recomend moving the TCO over to one side so the cleaning cycle doesn't affect the TCO. This may be covered by Whirlpool. You might want to call them and inquire. Catriver..post back.

Dec 18, 2006 | Whirlpool RBS275PD Electric Single Oven

Not finding what you are looking for?
Ovens Logo

Related Topics:

115 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ovens Experts

Dan Webster
Dan Webster

Level 3 Expert

8205 Answers

 Fix Your Board
Fix Your Board

Level 3 Expert

310 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

Are you an Oven Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...