Question about Fasco Heating & Cooling

Open Question

Ultra sx 90 (Armstrong) furnace does not always light. Combuston blower stays running, but doesn't lite every time. It does lite sometimes after the power is reset sometimes. Any Ideas?

When it calls for heat, it doesn't always lite. When it doesn't, combustion blower stays running until I turn furnace off and try and restart it. Sometimes it starts and then it may not. I am not sure if the ignition module is bad or the high pressure switch. All I know is that it is not getting the gas to ignite at all times.

Posted by on

  • Dennis Jan 19, 2013

    Ken,

×

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 306 Answers

SOURCE: armstrong ultra sx 80 furnace

You have a dirty flame sensor. Look at the very last burner and you will see a wire going to a ceramic sensor and it looks like a thick wire. Take some steel wool or fine sandpaper and clean the surface off and it will work like a champ.

Let me know how it goes ken

Posted on Apr 15, 2009

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Armstrong ultra SX 93


Restrict the flow on all of the registers on the first floor to get more flow to the top floor.

Jul 15, 2014 | Heating & Cooling

1 Answer

Armstrong ultra 93


The blower motor may have to be replaced.

Jul 15, 2014 | Heating & Cooling

1 Answer

I have an Armstrong SX Ultra 90 propane gas furnace that the fan motor will not shut off ,the thermostat is on auto.


Hit the side of the furnace. Some times there's a sensor inside that gets locked up from a dirty filter.

Oct 19, 2013 | Emerson Lennox Ducane Armstrong Furnace...

1 Answer

I posted a question about the Ultra sx 90 (Armstrong) furnace not lighting and the combustion blower keeps running. I did clean the flame sensor and no change. I also changed the spark control moduleas...


When this problem has occurred on my York furnace, the temperature limit switch had to be replaced. You may have checked this in your troubleshooting but if not, it's worth a try

Jan 19, 2013 | Fasco Heating & Cooling

1 Answer

Turn main furnace switch on, combustion air fan comes on and main circulation fan comes on. About 40 seconds later the igniter lites, two burners closest to the igniter fire up and immediatly snuff out....


Hello, if all the burners are not firing up then they must be cleaned out, usually dirt gets in the crossover parts of the burner and the gas cant flow to all the burners and therefore the flame sensor will turn off the furnace for safety. Clean the burners out this should fix the problem.

Feb 25, 2011 | Heating & Cooling

1 Answer

Armstrong furnace ultra 80sx doesnt always lite on first try,service repair man replaced smartvalve,sensor and igniter he says its ok if it doesnt always lite on the first try ,sometimes it takes three...


Sounds like your gas valve is sticking. Your repair man is somewhat correct by meaning that the furnace will attempt to start 3 times before going out on "Lock-out". The furnace is reaching it's expected life and you will start experiencing more frequent issues with it. Check into some of the incentives to get a replacement with a higher efficiency rating. The newer units have greatly improved in performance as well as comfort.

Jan 13, 2010 | Heating & Cooling

1 Answer

Armstrong ultra sx 80 furnace starts up and runs and then the gas shuts off for a few seconds and then lights backup and causes a small backfire my Ultra sx 80 furnace will ignite then immediately turn...


You have a dirty flame sensor. Look at the very last burner and you will see a wire going to a ceramic sensor and it looks like a thick wire. Take some steel wool or fine sandpaper and clean the surface off and it will work like a champ.

Let me know how it goes ken

Apr 15, 2009 | Heating & Cooling

Not finding what you are looking for?
Heating & Cooling Logo

Related Topics:

206 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fasco Heating & Cooling Experts

Paul Carew

Level 3 Expert

2550 Answers

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Donni Steen

Level 3 Expert

659 Answers

Are you a Fasco Heating and Cooling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...