Question about Bissell SpotBot Robotic Wet/Dry Vacuum

1 Answer

Spotbot will not light up in handsfree mode, but works fine in manual (hose) mode

I made sure hose was plugged in tightly, no gunk in the housing, and had it on flat surface but only hose mode will work. the lights for set in and regular stain won't come on when depressed.. HELP!!

Posted by on

  • Michael Aug 27, 2013

    there is a magnet in the hose behind a plate and screw, remove and inspect. water probably destroyed the magnet. replace with a strong one from a craft store. problems solved.

×

Ad

1 Answer

  • Official Brand Answer
  • 315 Answers

You may want to contact one of our Authorized Service Centers to have a quality technician inspect your machine.

Here's a quick link to locating one.

http://www.bissell.com/service-centers/?cid=ccsocial

Posted on Dec 10, 2012

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 2 Answers

SOURCE: SpotBot: all lights flashing!

Per the manual, periodically you should clean the rubber lining in the dirty water tank(it comes out). I found mine a little dirty, but after cleaning it, it solved my 'all lights flashing' problem.

Posted on Jun 07, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Bissell Spotbot Pet cleaner stopped working. Took it out of the closet, plugged it in, No power? It worked great the last time it was used.


Well, if cycling it manually doesn't work and replacing the controller board didn't make a difference did you check the flex hose sensor? Bots won't run unless everything is clicked into place.

"Testimonials" don't continue the thread :)

I managed to dig up a copy of the service guide since I haven't owned a spotbot in years. http://evacuumstore.com/images/spotbot-repair-guide.pdf

Mar 22, 2017 | Bissell SpotBot Pet Spot Cleaner

1 Answer

On my spotbot, the power light is on, but the only thing that works is the hose button.


Unhook the brush to the hose and make sure the hose is SECURLY attached to where it goes on the spot bot. Unplug, rep plug and I hope that works!

Jun 09, 2014 | Bissell SpotBot Robotic Wet/Dry Vacuum

1 Answer

SPOT BOT NO SUCTION


Hey Courtney! Sorry to hear about the suction problem on your SpotBot. Here's a quick link to troubleshooting steps to assist you.

http://www.bissell.com/FAQDetail.aspx?id=1040&cid=ccsocial

Jan 04, 2013 | Bissell SpotBot Robotic Wet/Dry Vacuum

3 Answers

My Bissel Spotbot will only let me use the Manual Mode, when I try to push "Set in Stain" or "Surface" stain the light won't turn on. My children were playing with it, but I...


There is a small magnet in the end of the hose. Under the phillips screw and plastic cover. Mine rusted to bits and stopped tripping the switch. A bit of a super strong hard drive magnet siliconed back in the end of the hose and all was fine.

May 26, 2011 | Bissell SpotBot Robotic Wet/Dry Vacuum

1 Answer

When plugged in the hose light blinks


My spotbot lights would blink and it, for a time, only worked on deep clean even after unplugging and plugging back in. Finally it wouldn't work at all, only the hose light would blink. I unplugged the hose and plugged it back in and the machine started working as it should.

Apr 10, 2011 | Bissell SpotBot Robotic Wet/Dry Vacuum

1 Answer

Need to clean hose.


I filled a bowl with hot bleach water and sucked the water up. It cleaned the hose pretty well (along with the gunk that was stuck in the hand wand). Mine was filthy. It looked like it had mold growing in it. Then I ran several rounds of hot water through the hose. I alternated hot water & bleach. Did this about 8 times. It is not perfect, but it sure does look a lot better. 90% of the gunk is gone.

Aug 05, 2009 | Bissell SpotBot Robotic Wet/Dry Vacuum

1 Answer

No spray in hands-free mode.


Hi, I had the same problem ... I tried hot water for 30 minutes with no sucess ... then opened the unit and could see nothing real obvious in the solution hoses ... so took the main hose off the valve from the solution tank ... then plugged in the unit over a towel (be careful) ... and selected clean ... the valve opened and a bunch of fluid flushed through - so I knew the valve was ok. I then blew through the remaining hoses and did seem to get some flow .... and reassembeled the unit ... and filled the tank with vinegar solution ... the manual spray immediately cleared with a bunch of dark flakes ... the regular brush spray worked fine.

Sep 11, 2008 | Bissell SpotBot Robotic Wet/Dry Vacuum

8 Answers

SpotBot: all lights flashing!


Per the manual, periodically you should clean the rubber lining in the dirty water tank(it comes out). I found mine a little dirty, but after cleaning it, it solved my 'all lights flashing' problem.

Aug 07, 2007 | Bissell SpotBot Robotic Wet/Dry Vacuum

Not finding what you are looking for?
Bissell SpotBot Robotic Wet/Dry Vacuum Logo

Related Topics:

331 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

Brad Brown

Level 3 Expert

16026 Answers

Jim Thurston

Level 3 Expert

670 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...