Question about Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Deck, Sub and Amp Problems

Just got a new Kenwood Excelon X792, used JL12W6v2 and Kenwood 9152D. Hooked it up everything worked fine then i had to mount the amp so disconnected amp and sub. Hooked back up and now my deck works fine for 5 minutes or so then it turns off sometimes it comes back on while driving. Sometimes when i restart my vehicle it comes back on. I sottered my wiring harness and it is mounted sturdily and wiring harness is not coming out when i hit bumps what would cause the deck to turn off

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Check for any loose connections at the fuse block or a loose fuse
using an ohm meter would help
check the harness on the back of the radio for loose connection
bad igntion switch, again an ohm meter would help !
what type vehicle ?

Posted on Jan 14, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a kenwood eXcelon KDC-X759 and after i hooked it up it just kept flashing code off, and it will take a cd but no sound and the radio works fine


does the cd seem to be working other than no sound? if so, are you running the audio through an amplifier? if you are using an amplifier, you may be using the antenna remote wire (blue) instead of the amp remote wire (blue/white stripe) to turn the amp on. when using the antenna remote wire it turns off when going to cd mode.

Aug 13, 2010 | Kenwood eXcelon KDC-X759 CD Player

1 Answer

How to set clock on kenwood excelon KDC-X792


i looked around and found a manual for you to download.:

http://www.retrevo.com/support/Kenwood-KDC-X792-Car-Receivers-manual/id/20132bh129/t/2/

Mar 15, 2010 | Car Audio & Video

1 Answer

I just installed a kenwood dnx7140. Everything is


Have you checked to see if the sub amp is turning on. Check to make sure you have at least 12 volts on your power as well as your remote turn on (Blue/White on radio harness).
If everything is hooked up correctly, it is possible that the preout is turned off. Some headunits have selectable preouts. If so you should be able to turn the sub on and off in the menu.
Hope this helps
VOTE

Mar 08, 2010 | Kenwood DNX7140 Car GPS Receiver

1 Answer

Kenwoodxw1000f shut off after 10 sec


the problem sounds like your new sub is drawing to much power and your amp can not handle it. bridging the amp is a good way to get the full power out of your amp. But it isnt always suggested, my solution is to get a bigger amp. I install stereo systems for a living, and i tell my customers that it is smart to get an amp about 100 more watts then the rms rating of your subwoofer.

Feb 13, 2010 | Kenwood eXcelon KFC-XW1000F Car Subwoofer

1 Answer

Just installed the sub it work for 10 sec then quit checked the amp and its working with a old sub do the subs freeze or something


The amp needs to "see" a load and if the new sub is incorrect the the amp will sense improper amps and will shut down, a protective circuit. Load the amp with the correct speaker....

Feb 13, 2010 | Kenwood eXcelon KFC-XW1000F Car Subwoofer

1 Answer

How many amp can be hooked uo to the Kenwood X792


Hello clay3227,

The X792 has 3 pairs of preamp outputs, so you can directly connect a 4-channel amp and a monoblock amp for subwoofers directly to the receiver. If you need additional amps connected, you can use RCA "Y" cables to split the signals. Also some amps may have preamp outputs that allows you to "daisy chain" more than one amp to the same set of outputs from the head unit.

Hope this helps.

Oct 31, 2009 | Kenwood Car Audio & Video

2 Answers

Kenwood excelon kdc-x815 display screen no power


recently bought a kenwood kdc-815 car radio from a swamp met. bought it with no security code need security code

Apr 08, 2008 | Kenwood KDC -X815

2 Answers

Sub out put problems


Change the amp ground to the same one as the head unit.

That will cancel out the noise.




Best of Luck.

Oct 26, 2007 | Kenwood Excelon DDX-7015 Car DVD Player

Not finding what you are looking for?
Kenwood KAC-9152D Car Audio Amplifier Logo

119 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

yadayada
yadayada

Level 3 Expert

70346 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6864 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...